summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-27 00:58:52 +0000
committerSam James <sam@gentoo.org>2022-03-27 02:00:09 +0100
commit79dacb355a17541cc945d0fd8f76ac1c08cc28b8 (patch)
tree5b398165be4ac5afb041d73fbb969a2319a0f440 /app-admin/salt
parentdev-util/build2: Bump to 0.14.0 (diff)
downloadgentoo-79dacb355a17541cc945d0fd8f76ac1c08cc28b8.tar.gz
gentoo-79dacb355a17541cc945d0fd8f76ac1c08cc28b8.tar.bz2
gentoo-79dacb355a17541cc945d0fd8f76ac1c08cc28b8.zip
app-admin/salt: add patch for newer Jinja
Bug: https://bugs.gentoo.org/836206 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/salt')
-rw-r--r--app-admin/salt/files/salt-3003.3-jinja.patch155
-rw-r--r--app-admin/salt/salt-3003.3-r1.ebuild203
2 files changed, 358 insertions, 0 deletions
diff --git a/app-admin/salt/files/salt-3003.3-jinja.patch b/app-admin/salt/files/salt-3003.3-jinja.patch
new file mode 100644
index 000000000000..ec5b1ac6156f
--- /dev/null
+++ b/app-admin/salt/files/salt-3003.3-jinja.patch
@@ -0,0 +1,155 @@
+https://github.com/saltstack/salt/issues/61848
+https://patch-diff.githubusercontent.com/raw/saltstack/salt/pull/61856.patch
+
+Dropped a bunch of irrelevant hunks (CI files and a test not in 3003.3)
+
+From 03c2a607a0722ad5e55b6c8f8eda630be7c7fee5 Mon Sep 17 00:00:00 2001
+From: jonyhy96 <hy352144278@gmail.com>
+Date: Thu, 10 Mar 2022 10:41:48 +0800
+Subject: [PATCH 1/5] fix: jinja2 contextfuntion base on version
+
+---
+ salt/utils/jinja.py | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/salt/utils/jinja.py b/salt/utils/jinja.py
+index 4c430b5ccf32..9a1938c2d69b 100644
+--- a/salt/utils/jinja.py
++++ b/salt/utils/jinja.py
+@@ -707,7 +707,11 @@ def method_call(obj, f_name, *f_args, **f_kwargs):
+ return getattr(obj, f_name, lambda *args, **kwargs: None)(*f_args, **f_kwargs)
+
+
+-@jinja2.contextfunction
++if jinja2.__version__ < '3.0.0' :
++ contextfunction = jinja2.contextfunction
++else:
++ contextfunction = jinja2.pass_context
++@contextfunction
+ def show_full_context(ctx):
+ return salt.utils.data.simple_types_filter(
+ {key: value for key, value in ctx.items()}
+
+From 1aba938021b86732a211a899dc4c2a46afa488a2 Mon Sep 17 00:00:00 2001
+From: jonyhy96 <hy352144278@gmail.com>
+Date: Thu, 3 Mar 2022 16:21:17 +0800
+Subject: [PATCH 2/5] fix: jinja2 DeprecationWarning
+
+---
+ salt/utils/jinja.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/salt/utils/jinja.py b/salt/utils/jinja.py
+index 9a1938c2d69b..207a2cb77035 100644
+--- a/salt/utils/jinja.py
++++ b/salt/utils/jinja.py
+@@ -710,7 +710,7 @@ def method_call(obj, f_name, *f_args, **f_kwargs):
+ if jinja2.__version__ < '3.0.0' :
+ contextfunction = jinja2.contextfunction
+ else:
+- contextfunction = jinja2.pass_context
++ contextfunction = jinja2.pass_context
+ @contextfunction
+ def show_full_context(ctx):
+ return salt.utils.data.simple_types_filter(
+
+From 7f281bbfc8efda40cfe7d607c0ddebb2fb00bd5d Mon Sep 17 00:00:00 2001
+From: Megan Wilhite <mwilhite@vmware.com>
+Date: Fri, 25 Mar 2022 08:31:24 -0600
+Subject: [PATCH 3/5] Use the correct Markup from jinja for each version
+
+---
+ salt/utils/jinja.py | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/salt/utils/jinja.py b/salt/utils/jinja.py
+index 207a2cb77035..558f063d7206 100644
+--- a/salt/utils/jinja.py
++++ b/salt/utils/jinja.py
+@@ -26,7 +26,7 @@
+ import salt.utils.stringutils
+ import salt.utils.url
+ import salt.utils.yaml
+-from jinja2 import BaseLoader, Markup, TemplateNotFound, nodes
++from jinja2 import BaseLoader, TemplateNotFound, nodes
+ from jinja2.environment import TemplateModule
+ from jinja2.exceptions import TemplateRuntimeError
+ from jinja2.ext import Extension
+@@ -35,6 +35,12 @@
+ from salt.utils.odict import OrderedDict
+ from salt.utils.versions import LooseVersion
+
++try:
++ from jinja2 import Markup
++except ImportError:
++ # Markup moved to markupsafe in jinja>= 3.1
++ from markupsafe import Markup
++
+ log = logging.getLogger(__name__)
+
+ __all__ = ["SaltCacheLoader", "SerializerExtension"]
+
+diff --git a/salt/utils/jinja.py b/salt/utils/jinja.py
+index 558f063d7206..5d00b134e25f 100644
+--- a/salt/utils/jinja.py
++++ b/salt/utils/jinja.py
+@@ -713,10 +713,12 @@ def method_call(obj, f_name, *f_args, **f_kwargs):
+ return getattr(obj, f_name, lambda *args, **kwargs: None)(*f_args, **f_kwargs)
+
+
+-if jinja2.__version__ < '3.0.0' :
++if jinja2.__version__ < "3.0.0":
+ contextfunction = jinja2.contextfunction
+ else:
+ contextfunction = jinja2.pass_context
++
++
+ @contextfunction
+ def show_full_context(ctx):
+ return salt.utils.data.simple_types_filter(
+
+From 9056e636beaea7de2e3a61876ba0345e5d390973 Mon Sep 17 00:00:00 2001
+From: Megan Wilhite <mwilhite@vmware.com>
+Date: Fri, 25 Mar 2022 11:14:01 -0600
+Subject: [PATCH 5/5] Fix requested feedback
+
+---
+ requirements/static/ci/docs.in | 1 +
+ requirements/static/ci/py3.10/docs.txt | 3 ++-
+ requirements/static/ci/py3.6/docs.txt | 1 +
+ requirements/static/ci/py3.7/docs.txt | 3 ++-
+ requirements/static/ci/py3.8/docs.txt | 3 ++-
+ requirements/static/ci/py3.9/docs.txt | 3 ++-
+ salt/utils/jinja.py | 10 +++++-----
+ 8 files changed, 21 insertions(+), 10 deletions(-)
+
+diff --git a/salt/utils/jinja.py b/salt/utils/jinja.py
+index 5d00b134e25f..aa8ebe90546c 100644
+--- a/salt/utils/jinja.py
++++ b/salt/utils/jinja.py
+@@ -36,10 +36,10 @@
+ from salt.utils.versions import LooseVersion
+
+ try:
+- from jinja2 import Markup
+-except ImportError:
+- # Markup moved to markupsafe in jinja>= 3.1
+ from markupsafe import Markup
++except ImportError:
++ # jinja < 3.1
++ from jinja2 import Markup
+
+ log = logging.getLogger(__name__)
+
+@@ -713,9 +713,9 @@ def method_call(obj, f_name, *f_args, **f_kwargs):
+ return getattr(obj, f_name, lambda *args, **kwargs: None)(*f_args, **f_kwargs)
+
+
+-if jinja2.__version__ < "3.0.0":
++try:
+ contextfunction = jinja2.contextfunction
+-else:
++except AttributeError:
+ contextfunction = jinja2.pass_context
+
+
diff --git a/app-admin/salt/salt-3003.3-r1.ebuild b/app-admin/salt/salt-3003.3-r1.ebuild
new file mode 100644
index 000000000000..fbccb4248798
--- /dev/null
+++ b/app-admin/salt/salt-3003.3-r1.ebuild
@@ -0,0 +1,203 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit systemd distutils-r1
+
+DESCRIPTION="Salt is a remote execution and configuration manager"
+HOMEPAGE="https://www.saltstack.com/resources/community/
+ https://github.com/saltstack"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}stack/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="cheetah cherrypy ldap libcloud libvirt genshi gnupg keyring mako
+ mongodb neutron nova openssl portage profile redis selinux test raet
+ +zeromq vim-syntax"
+
+RDEPEND="
+ sys-apps/pciutils
+ >=dev-python/distro-1.5[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/libnacl[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.9.8[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.2[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ libcloud? ( >=dev-python/libcloud-2.5.0[${PYTHON_USEDEP}] )
+ mako? ( dev-python/mako[${PYTHON_USEDEP}] )
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
+ libvirt? (
+ $(python_gen_cond_dep 'dev-python/libvirt-python[${PYTHON_USEDEP}]' python3_8)
+ )
+ openssl? (
+ dev-libs/openssl:0=[-bindist(-)]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+ raet? (
+ >=dev-python/libnacl-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ioflo-1.1.7[${PYTHON_USEDEP}]
+ >=dev-python/raet-0.6.0[${PYTHON_USEDEP}]
+ )
+ cherrypy? ( >=dev-python/cherrypy-3.2.2[${PYTHON_USEDEP}] )
+ cheetah? ( dev-python/cheetah3[${PYTHON_USEDEP}] )
+ genshi? ( dev-python/genshi[${PYTHON_USEDEP}] )
+ mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
+ portage? ( sys-apps/portage[${PYTHON_USEDEP}] )
+ keyring? ( dev-python/keyring[${PYTHON_USEDEP}] )
+ redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
+ selinux? ( sec-policy/selinux-salt )
+ nova? (
+ $(python_gen_cond_dep '>=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}]' python3_8)
+ )
+ neutron? (
+ $(python_gen_cond_dep '>=dev-python/python-neutronclient-2.3.6[${PYTHON_USEDEP}]' python3_8)
+ )
+ gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
+ profile? ( dev-python/yappi[${PYTHON_USEDEP}] )
+ vim-syntax? ( app-vim/salt-vim )
+ zeromq? ( >=dev-python/pyzmq-2.2.0[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/boto-2.32.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/moto-0.3.6[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/pytest-salt-factories-0.121.1[${PYTHON_USEDEP}]
+ dev-python/pytest-tempdir[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/libcloud[${PYTHON_USEDEP}]
+ net-dns/bind-tools
+ >=dev-python/virtualenv-20.0.20[${PYTHON_USEDEP}]
+ !x86? ( >=dev-python/boto3-1.3.15[${PYTHON_USEDEP}] )
+ )"
+
+DOCS=( README.rst AUTHORS )
+
+REQUIRED_USE="|| ( raet zeromq )
+ test? ( cheetah genshi )"
+RESTRICT="!test? ( test ) x86? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/salt-3003-skip-tests-that-oom-machine.patch"
+ "${FILESDIR}/salt-3003-gentoolkit-revdep.patch"
+ "${FILESDIR}/salt-3002-tests.patch"
+ "${FILESDIR}/salt-3003.3-tests.patch"
+ "${FILESDIR}/salt-3003.1-tests.patch"
+ "${FILESDIR}/salt-3003.3-jinja.patch"
+)
+
+python_prepare_all() {
+ # remove tests with external dependencies that may not be available, and
+ # tests that don't work in sandbox
+ rm tests/unit/{test_{zypp_plugins,module_names},utils/test_extend}.py || die
+ rm tests/unit/modules/test_{file,boto_{vpc,secgroup,elb}}.py || die
+ rm tests/unit/states/test_boto_vpc.py || die
+ rm tests/support/gitfs.py tests/unit/runners/test_git_pillar.py || die
+ rm tests/pytests/functional/transport/server/test_req_channel.py || die
+
+ # tests that require network access
+ rm tests/unit/{states,modules}/test_zcbuildout.py || die
+ rm -r tests/integration/cloud || die
+ rm -r tests/kitchen/tests/wordpress/tests || die
+ rm tests/kitchen/test_kitchen.py || die
+ rm tests/unit/modules/test_network.py || die
+
+ # tests require root access
+ rm tests/integration/pillar/test_git_pillar.py || die
+ rm tests/integration/states/test_supervisord.py || die
+ rm tests/pytests/unit/client/test_ssh.py || die
+
+ # make sure pkg_resources doesn't bomb because pycrypto isn't installed
+ find "${S}" -name '*.txt' -print0 | xargs -0 sed -e '/pycrypto>/ d ; /pycryptodomex/ d' -i || die
+ # pycryptodome rather than pycryptodomex
+ find "${S}" -name '*.py' -print0 | xargs -0 -- sed -i -e 's:Cryptodome:Crypto:g' -- || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_prepare() {
+ einfo "Fixing collections.abc warnings for ${EPYTHON}"
+ local abc
+ abc="$("${EPYTHON}" -c 'import collections.abc; print("|".join((c for c in dir(collections.abc) if not c.startswith("_"))))')" || die
+ find -name '*.py' -type f -print0 | xargs -0 sed -r -e "s:collections\\.(${abc}):collections.abc.\\1:g" -i || die
+
+ # removes contextvars, see bug: https://bugs.gentoo.org/799431
+ sed -i '/^contextvars/d' requirements/base.txt || die
+}
+
+python_install_all() {
+ local svc
+ USE_SETUPTOOLS=1 distutils-r1_python_install_all
+
+ for svc in minion master syndic api; do
+ newinitd "${FILESDIR}"/${svc}-initd-5 salt-${svc}
+ newconfd "${FILESDIR}"/${svc}-confd-1 salt-${svc}
+ systemd_dounit "${FILESDIR}"/salt-${svc}.service
+ done
+
+ insinto /etc/${PN}
+ doins -r conf/*
+}
+
+python_test() {
+ # testsuite likes lots of files
+ ulimit -n 4096 || die
+
+ # ${T} is too long a path for the tests to work
+ local TMPDIR
+ TMPDIR="$(mktemp --directory --tmpdir=/tmp ${PN}-XXXX)"
+ (
+ export TMPDIR
+ cleanup() { rm -rf "${TMPDIR}" || die; }
+
+ trap cleanup EXIT
+
+ addwrite "${TMPDIR}"
+
+ USE_SETUPTOOLS=1 NO_INTERNET=1 SHELL="/bin/bash" \
+ "${EPYTHON}" -m pytest -vv \
+ || die "testing failed with ${EPYTHON}"
+ )
+}
+
+pkg_postinst() {
+ if use python_targets_python3_8; then
+ if use nova; then
+ ewarn "Salt's nova functionality will not work with python3.8 since"
+ ewarn "dev-python/python-novaclient does not support it yet"
+ fi
+ if use neutron; then
+ ewarn "Salt's neutron functionality will not work with python3.8 since"
+ ewarn "dev-python/python-neutronclient does not support it yet"
+ fi
+ if use libvirt; then
+ ewarn "Salt's libvirt functionality will not work with python3.8 since"
+ ewarn "dev-python/libvirt-python does not support it yet"
+ fi
+ fi
+}