summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-12-19 11:47:44 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2022-02-07 13:21:45 +0000
commit568a7b9e1a694dfd564725d82af3c2d502624e96 (patch)
tree34e5a5effb8fd79a3837c831030795337196433a /app-admin/mongo-tools/mongo-tools-4.2.17.ebuild
parentdev-db/mongodb: bump to 4.2.17/4.4.10/5.0.5 (diff)
downloadgentoo-568a7b9e1a694dfd564725d82af3c2d502624e96.tar.gz
gentoo-568a7b9e1a694dfd564725d82af3c2d502624e96.tar.bz2
gentoo-568a7b9e1a694dfd564725d82af3c2d502624e96.zip
app-admin/mongo-tools: bump to 4.2.17/100.5.1
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'app-admin/mongo-tools/mongo-tools-4.2.17.ebuild')
-rw-r--r--app-admin/mongo-tools/mongo-tools-4.2.17.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/mongo-tools-4.2.17.ebuild b/app-admin/mongo-tools/mongo-tools-4.2.17.ebuild
new file mode 100644
index 000000000000..1c622b0ee6a7
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-4.2.17.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="sasl ssl"
+
+DEPEND="dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+EGO_PN="github.com/mongodb/mongo-tools"
+S="${WORKDIR}/src/${EGO_PN}"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv ${MY_P} "${S}" || die
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ # build pie to avoid text relocations wrt #582854
+ local buildmode="pie"
+
+ # skip on ppc64 wrt #610984
+ if use ppc64; then
+ buildmode="default"
+ fi
+
+ mkdir -p bin || die
+ for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
+ echo "Building $i"
+ GO111MODULE='off' GOROOT="$(go env GOROOT)" GOPATH="${WORKDIR}" go build -buildmode="${buildmode}" -o "bin/$i" \
+ -ldflags "-X ${EGO_PN}/common/options.VersionStr=${PV}" --tags "${myconf[*]}" "$i/main/$i.go" || die
+ done
+}
+
+src_install() {
+ dobin bin/*
+}