summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-08 18:53:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-08 20:31:21 +0200
commit280a6e5ed12f75a400f177e016600693b01ca207 (patch)
tree5a1c50be5235b5f9a1b894092e54426aa653c9c2
parentdev-python/pytz: Enable py3.13 (diff)
downloadgentoo-280a6e5ed12f75a400f177e016600693b01ca207.tar.gz
gentoo-280a6e5ed12f75a400f177e016600693b01ca207.tar.bz2
gentoo-280a6e5ed12f75a400f177e016600693b01ca207.zip
dev-python/six: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/six/six-1.16.0-r1.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/dev-python/six/six-1.16.0-r1.ebuild b/dev-python/six/six-1.16.0-r1.ebuild
index df1788703008..9850b41681e3 100644
--- a/dev-python/six/six-1.16.0-r1.ebuild
+++ b/dev-python/six/six-1.16.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -23,9 +23,19 @@ distutils_enable_tests pytest
python_test() {
local EPYTEST_DESELECT=()
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- 'test_six.py::test_move_items[dbm_ndbm]'
- )
-
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ 'test_six.py::test_move_items[dbm_ndbm]'
+ )
+ ;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ 'test_six.py::test_move_items[tkinter_tix]'
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}