summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-06 16:11:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-06 16:24:02 +0200
commit19c45d4b1a2b5786ffde76111bd2e6b963e47501 (patch)
tree24304e9b46286e1a701ab7be12f33c4929c5cd6c
parentkde-plasma/kscreenlocker: 6.1.4 version bump (diff)
downloadgentoo-19c45d4b1a2b5786ffde76111bd2e6b963e47501.tar.gz
gentoo-19c45d4b1a2b5786ffde76111bd2e6b963e47501.tar.bz2
gentoo-19c45d4b1a2b5786ffde76111bd2e6b963e47501.zip
kde-plasma/ksshaskpass: 6.1.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-6.1.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index e7e1383e686a..dd3979e2e26a 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.27.11.tar.xz 27980 BLAKE2B 4fa35480f0ed7389bf41f56fc8266fccb8a33060c37f6df2c1edc44f49466267dbd45584e0afff6aaa79a3b5ffc1aca916c36a7ad768e36a457c081bfa53f217 SHA512 85c4091faa4ec4a6d068d4a0d464601054b88187ccfa05f4156b146dd3b3900dc15bcb3f9f9b0b057fb9b5687eabf55bb34d06d98a9e26ddb6a0afba1684feee
DIST ksshaskpass-6.1.3.tar.xz 29452 BLAKE2B 7d8c5fc9a4da779aeca866762eaebd49c7eaf5e2b30d103935135964a08109b8db0da707729313fa772d555f2f7149baa8e248822a673d93ac123c8afd83357b SHA512 64667c93b918a98d3ca44ed8d00bb3c10d7e52523689e41838d743080aa3bda08c912e6a1939bada558d9915809ea38d3a2ee3d8f4c9b01ef4d7ec10faa447db
+DIST ksshaskpass-6.1.4.tar.xz 29468 BLAKE2B c32a7d65ac6adcf76c558b79e3936d7c87e5f950a79787352376b6e35beb1221103d2e1c134ed3d614eed621f84a241a3f582b51cdb0df26819af2cabc4c5b96 SHA512 391c8135aa8b625a2fcdab1ae2bdd30892daaaeeb9b2379fcbe3b5f37741bc078cb33acc1195429b8d1b26234663a383146fbed3d0d197ac243967a962b62681
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-6.1.4.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-6.1.4.ebuild
new file mode 100644
index 000000000000..51e28013d943
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-6.1.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.3.0
+QTMIN=6.7.1
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 6,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 6 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+}