summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2016-06-27 06:41:32 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2016-06-27 06:41:32 +0000
commitc72b09b36c69faf7caab3aa47a2cedfe581609e3 (patch)
tree5277f2314a4feeb468bbf9a68526a26cc0f4340e
parent2016-06-27 05:42:12 UTC (diff)
parentmedia-video/qgifer: add missing die statement (diff)
downloadgentoo-c72b09b36c69faf7caab3aa47a2cedfe581609e3.tar.gz
gentoo-c72b09b36c69faf7caab3aa47a2cedfe581609e3.tar.bz2
gentoo-c72b09b36c69faf7caab3aa47a2cedfe581609e3.zip
Merge updates from master
-rw-r--r--eclass/tests/tests-common.sh41
-rwxr-xr-xeclass/tests/toolchain-funcs.sh7
-rw-r--r--eclass/toolchain-funcs.eclass16
-rw-r--r--media-video/qgifer/qgifer-0.2.1-r3.ebuild (renamed from media-video/qgifer/qgifer-0.2.1-r1.ebuild)24
-rw-r--r--media-video/qgifer/qgifer-0.2.1.ebuild39
5 files changed, 17 insertions, 110 deletions
diff --git a/eclass/tests/tests-common.sh b/eclass/tests/tests-common.sh
index d3095e5fc350..faca39d57589 100644
--- a/eclass/tests/tests-common.sh
+++ b/eclass/tests/tests-common.sh
@@ -65,47 +65,6 @@ has_version() {
portageq has_version / "$@"
}
-KV_major() {
- [[ -z $1 ]] && return 1
-
- local KV=$@
- echo "${KV%%.*}"
-}
-
-KV_minor() {
- [[ -z $1 ]] && return 1
-
- local KV=$@
- KV=${KV#*.}
- echo "${KV%%.*}"
-}
-
-KV_micro() {
- [[ -z $1 ]] && return 1
-
- local KV=$@
- KV=${KV#*.*.}
- echo "${KV%%[^[:digit:]]*}"
-}
-
-KV_to_int() {
- [[ -z $1 ]] && return 1
-
- local KV_MAJOR=$(KV_major "$1")
- local KV_MINOR=$(KV_minor "$1")
- local KV_MICRO=$(KV_micro "$1")
- local KV_int=$(( KV_MAJOR * 65536 + KV_MINOR * 256 + KV_MICRO ))
-
- # We make version 2.2.0 the minimum version we will handle as
- # a sanity check ... if its less, we fail ...
- if [[ ${KV_int} -ge 131584 ]] ; then
- echo "${KV_int}"
- return 0
- fi
-
- return 1
-}
-
tret=0
tbegin() {
ebegin "Testing $*"
diff --git a/eclass/tests/toolchain-funcs.sh b/eclass/tests/toolchain-funcs.sh
index e6a15389c913..bfbe26f25c33 100755
--- a/eclass/tests/toolchain-funcs.sh
+++ b/eclass/tests/toolchain-funcs.sh
@@ -25,13 +25,6 @@ test-tc-arch-kernel() {
done
return ${ret}
}
-tbegin "tc-arch-kernel() (KV=2.6.0)"
-test-tc-arch-kernel 2.6.0 \
- alpha arm{,eb}:arm avr32 bfin:blackfin cris hppa:parisc \
- i{3..6}86:i386 ia64 m68k mips{,eb}:mips nios2 powerpc:ppc powerpc64:ppc64 \
- s390{,x}:s390 sh{1..4}{,eb}:sh sparc{,64} vax x86_64 \
- i{3..6}86-gentoo-freebsd:i386
-tend $?
tbegin "tc-arch-kernel() (KV=2.6.30)"
test-tc-arch-kernel 2.6.30 \
i{3..6}86:x86 x86_64:x86 \
diff --git a/eclass/toolchain-funcs.eclass b/eclass/toolchain-funcs.eclass
index d3abfb528936..2652e0eef920 100644
--- a/eclass/toolchain-funcs.eclass
+++ b/eclass/toolchain-funcs.eclass
@@ -460,10 +460,6 @@ ninj() { [[ ${type} == "kern" ]] && echo $1 || echo $2 ; }
local host=$2
[[ -z ${host} ]] && host=${CTARGET:-${CHOST}}
- local KV=${KV:-${KV_FULL}}
- [[ ${type} == "kern" ]] && [[ -z ${KV} ]] && \
- ewarn "QA: Kernel version could not be determined, please inherit kernel-2 or linux-info"
-
case ${host} in
aarch64*) echo arm64;;
alpha*) echo alpha;;
@@ -479,7 +475,7 @@ ninj() { [[ ${type} == "kern" ]] && echo $1 || echo $2 ; }
# Starting with linux-2.6.24, the 'x86_64' and 'i386'
# trees have been unified into 'x86'.
# FreeBSD still uses i386
- if [[ ${type} == "kern" ]] && [[ $(KV_to_int ${KV}) -lt $(KV_to_int 2.6.24) || ${host} == *freebsd* ]] ; then
+ if [[ ${type} == "kern" && ${host} == *freebsd* ]] ; then
echo i386
else
echo x86
@@ -497,14 +493,8 @@ ninj() { [[ ${type} == "kern" ]] && echo $1 || echo $2 ; }
# Starting with linux-2.6.15, the 'ppc' and 'ppc64' trees
# have been unified into simply 'powerpc', but until 2.6.16,
# ppc32 is still using ARCH="ppc" as default
- if [[ ${type} == "kern" ]] && [[ $(KV_to_int ${KV}) -ge $(KV_to_int 2.6.16) ]] ; then
+ if [[ ${type} == "kern" ]] ; then
echo powerpc
- elif [[ ${type} == "kern" ]] && [[ $(KV_to_int ${KV}) -eq $(KV_to_int 2.6.15) ]] ; then
- if [[ ${host} == powerpc64* ]] || [[ ${PROFILE_ARCH} == "ppc64" ]] ; then
- echo powerpc
- else
- echo ppc
- fi
elif [[ ${host} == powerpc64* ]] ; then
echo ppc64
elif [[ ${PROFILE_ARCH} == "ppc64" ]] ; then
@@ -529,7 +519,7 @@ ninj() { [[ ${type} == "kern" ]] && echo $1 || echo $2 ; }
x86_64*)
# Starting with linux-2.6.24, the 'x86_64' and 'i386'
# trees have been unified into 'x86'.
- if [[ ${type} == "kern" ]] && [[ $(KV_to_int ${KV}) -ge $(KV_to_int 2.6.24) ]] ; then
+ if [[ ${type} == "kern" ]] ; then
echo x86
else
ninj x86_64 amd64
diff --git a/media-video/qgifer/qgifer-0.2.1-r1.ebuild b/media-video/qgifer/qgifer-0.2.1-r3.ebuild
index 2c646a902fed..721698efdc29 100644
--- a/media-video/qgifer/qgifer-0.2.1-r1.ebuild
+++ b/media-video/qgifer/qgifer-0.2.1-r3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="6"
inherit cmake-utils
@@ -10,31 +10,35 @@ DESCRIPTION="A video-based animated GIF creator"
HOMEPAGE="https://sourceforge.net/projects/qgifer/"
SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug imagemagick opencv3"
-RDEPEND="media-libs/giflib:0
+RDEPEND="<media-libs/giflib-4.2.3:0
dev-qt/qtcore:4
dev-qt/qtgui:4
imagemagick? ( media-gfx/imagemagick:0 )
- !opencv3? ( >=media-libs/opencv-2.4.9[ffmpeg] <media-libs/opencv-3.0.0[ffmpeg] )
- opencv3? ( >=media-libs/opencv-3.0.0[ffmpeg] )
+ !opencv3? ( media-libs/opencv:0/2.4[ffmpeg] )
+ opencv3? ( media-libs/opencv:0/3.0[ffmpeg] )
virtual/ffmpeg:0"
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.8:0"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${P}-source"
src_prepare() {
- epatch "${FILESDIR}"/${P}-desktop.patch
+ eapply -p0 "${FILESDIR}/${P}-desktop.patch"
if use opencv3 ; then
- epatch "${FILESDIR}"/${P}-opencv3.patch
+ eapply "${FILESDIR}/${P}-opencv3.patch"
fi
+
+ # Fix the doc path
+ sed -i -e "s|share/doc/qgifer|share/doc/${PF}|" CMakeLists.txt || die
+
+ eapply_user
}
src_configure() {
diff --git a/media-video/qgifer/qgifer-0.2.1.ebuild b/media-video/qgifer/qgifer-0.2.1.ebuild
deleted file mode 100644
index 47c8279b3b79..000000000000
--- a/media-video/qgifer/qgifer-0.2.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit cmake-utils
-
-DESCRIPTION="A video-based animated GIF creator"
-HOMEPAGE="https://sourceforge.net/projects/qgifer/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="debug imagemagick"
-
-RDEPEND="media-libs/giflib:0
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- imagemagick? ( media-gfx/imagemagick:0 )
- media-libs/opencv:0[ffmpeg]
- virtual/ffmpeg:0"
-
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.8:0"
-
-S="${WORKDIR}/${P}-source"
-
-PATCHES=( "${FILESDIR}"/${P}-desktop.patch )
-
-src_configure() {
- local mycmakeargs=""
-
- use debug && mycmakeargs+=" -DRELEASE_MODE=OFF"
-
- cmake-utils_src_configure
-}