summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-04-16 20:44:07 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-04-16 20:44:07 +0000
commit34c8f4cb04abf8135e80adc61d148ded8c6342fe (patch)
tree7d0bd71ae6166d422fa518fbdf571855573daadb
parent2019-04-16 20:04:27 UTC (diff)
parentapp-editors/vim: fix USE=minimal build (diff)
downloadgentoo-34c8f4cb04abf8135e80adc61d148ded8c6342fe.tar.gz
gentoo-34c8f4cb04abf8135e80adc61d148ded8c6342fe.tar.bz2
gentoo-34c8f4cb04abf8135e80adc61d148ded8c6342fe.zip
Merge updates from master
-rw-r--r--app-arch/vimball/vimball-9999.ebuild6
-rw-r--r--app-editors/vim/vim-8.1.1155.ebuild4
-rw-r--r--app-editors/vim/vim-9999.ebuild4
-rw-r--r--app-vim/command-t/Manifest2
-rw-r--r--app-vim/command-t/command-t-5.0.1.ebuild48
-rw-r--r--app-vim/command-t/command-t-5.0.2.ebuild48
-rw-r--r--app-vim/command-t/command-t-5.0.3.ebuild4
-rw-r--r--dev-db/percona-xtrabackup/percona-xtrabackup-2.4.13.ebuild2
-rw-r--r--dev-libs/botan/botan-2.9.0.ebuild4
-rwxr-xr-xdev-libs/botan/files/botan-2.9.0-build.patch63
-rw-r--r--dev-libs/xmlsec/Manifest1
-rw-r--r--dev-libs/xmlsec/files/xmlsec-1.2.28-test.patch121
-rw-r--r--dev-libs/xmlsec/xmlsec-1.2.26.ebuild2
-rw-r--r--dev-libs/xmlsec/xmlsec-1.2.28.ebuild74
-rw-r--r--games-util/nml/Manifest1
-rw-r--r--games-util/nml/nml-0.4.4-r1.ebuild27
-rw-r--r--games-util/nml/nml-0.4.5.ebuild2
17 files changed, 273 insertions, 140 deletions
diff --git a/app-arch/vimball/vimball-9999.ebuild b/app-arch/vimball/vimball-9999.ebuild
index b24f9bccd79f..82a39960d3ea 100644
--- a/app-arch/vimball/vimball-9999.ebuild
+++ b/app-arch/vimball/vimball-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
diff --git a/app-editors/vim/vim-8.1.1155.ebuild b/app-editors/vim/vim-8.1.1155.ebuild
index d5c9d74833a9..8701b63c9a19 100644
--- a/app-editors/vim/vim-8.1.1155.ebuild
+++ b/app-editors/vim/vim-8.1.1155.ebuild
@@ -143,7 +143,7 @@ src_prepare() {
}
src_configure() {
- local myconf=()
+ local myconf=( --enable-multibyte )
# Fix bug 37354: Disallow -funroll-all-loops on amd64
# Bug 57859 suggests that we want to do this for all archs
@@ -175,7 +175,6 @@ src_configure() {
myconf=(
--with-features=tiny
--disable-nls
- --disable-multibyte
--disable-acl
--enable-gui=no
--without-x
@@ -194,7 +193,6 @@ src_configure() {
myconf=(
--with-features=huge
- --enable-multibyte
$(use_enable acl)
$(use_enable cscope)
$(use_enable gpm)
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index d5c9d74833a9..8701b63c9a19 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -143,7 +143,7 @@ src_prepare() {
}
src_configure() {
- local myconf=()
+ local myconf=( --enable-multibyte )
# Fix bug 37354: Disallow -funroll-all-loops on amd64
# Bug 57859 suggests that we want to do this for all archs
@@ -175,7 +175,6 @@ src_configure() {
myconf=(
--with-features=tiny
--disable-nls
- --disable-multibyte
--disable-acl
--enable-gui=no
--without-x
@@ -194,7 +193,6 @@ src_configure() {
myconf=(
--with-features=huge
- --enable-multibyte
$(use_enable acl)
$(use_enable cscope)
$(use_enable gpm)
diff --git a/app-vim/command-t/Manifest b/app-vim/command-t/Manifest
index 816584c252ec..c9be2b74f2b2 100644
--- a/app-vim/command-t/Manifest
+++ b/app-vim/command-t/Manifest
@@ -1,3 +1 @@
-DIST command-t-5.0.1.tar.gz 81781 BLAKE2B 5d606892d9653c259525b6778cd72309da898fae787964fd4d1c9a6ebfd91e467e1f88f5756d7966c4866f721912164f0bf852efdd19209ce779a56725e2adbf SHA512 54262f4628bbef8a11878a8593510af566dabf35dd70005dc90e4abb4c4e9aebde5dc7d08d808c944980017f8f35d7e9723b0032ccde5ab6d2d2fae38e1c632d
-DIST command-t-5.0.2.tar.gz 83601 BLAKE2B 0391f010252fcd8b48909ad4a8dd504e6cbb74f1a2f776d719a8179f0d44299bfddf8161a2961c9089cbb3a4c4c944daa4adb26927f27c4c3beebceb0b938f53 SHA512 f8c8356231c3fb0f3a91cb61f534acac4dd401721a940c6ea045ada287d29395923eb46b1cb4f55b8254000f10eea9970841531abb2b110992180a1edbd66b81
DIST command-t-5.0.3.tar.gz 84019 BLAKE2B fec893aa698a1d1bfc86cf7bd08562f19b54e58d81b7650e50acdf17bfcec54f78aae38d05ca5f93ae60c981a6e606d5c68c008be3508c7d41e74aa9f064943a SHA512 588ee1516039e6cd45210de43307c02259fed29cc7610c222fe705cdf1d5938f51f823d41b546a36320da31db12e902363867da91b18fe56ea09c1efe2bb51fb
diff --git a/app-vim/command-t/command-t-5.0.1.ebuild b/app-vim/command-t/command-t-5.0.1.ebuild
deleted file mode 100644
index 700b5dbef1e5..000000000000
--- a/app-vim/command-t/command-t-5.0.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24"
-
-inherit vim-plugin ruby-ng
-
-DESCRIPTION="vim plugin: fast file navigation for vim"
-HOMEPAGE="https://vim.sourceforge.io/scripts/script.php?script_id=3025 https://github.com/wincent/command-t"
-SRC_URI="https://github.com/wincent/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-2"
-KEYWORDS="~amd64 ~x86"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
-
-all_ruby_prepare() {
- find "${S}" -name .gitignore -delete || die
-}
-
-each_ruby_configure() {
- cd ruby/${PN}/ext/${PN} || die
- ${RUBY} extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- cd ruby/${PN}/ext/${PN} || die
- emake V=1
- rm *.o *.c *.h *.log extconf.rb depend Makefile || die
-}
-
-each_ruby_install() {
- local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
- insinto "${sitelibdir}"
- doins -r ruby/${PN}/{ext,lib}/*
-}
-
-all_ruby_install() {
- rm Gemfile* Rakefile LICENSE README.md || die
- rm -r appstream bin fixtures data ruby/${PN}/{ext,lib,*.gemspec} spec vendor || die
-
- vim-plugin_src_install
-
- # make sure scripts are executable
- chmod +x "${ED}"/usr/share/vim/vimfiles/ruby/${PN}/bin/* || die
-}
diff --git a/app-vim/command-t/command-t-5.0.2.ebuild b/app-vim/command-t/command-t-5.0.2.ebuild
deleted file mode 100644
index 82f1973dda57..000000000000
--- a/app-vim/command-t/command-t-5.0.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24"
-
-inherit vim-plugin ruby-ng
-
-DESCRIPTION="vim plugin: fast file navigation for vim"
-HOMEPAGE="https://vim.sourceforge.io/scripts/script.php?script_id=3025 https://github.com/wincent/command-t"
-SRC_URI="https://github.com/wincent/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-2"
-KEYWORDS="~amd64 ~x86"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
-
-all_ruby_prepare() {
- find "${S}" -name .gitignore -delete || die
-}
-
-each_ruby_configure() {
- cd ruby/${PN}/ext/${PN} || die
- ${RUBY} extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- cd ruby/${PN}/ext/${PN} || die
- emake V=1
- rm *.o *.c *.h *.log extconf.rb depend Makefile || die
-}
-
-each_ruby_install() {
- local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
- insinto "${sitelibdir}"
- doins -r ruby/${PN}/{ext,lib}/*
-}
-
-all_ruby_install() {
- rm Gemfile* Rakefile LICENSE README.md || die
- rm -r appstream bin fixtures data ruby/${PN}/{ext,lib,*.gemspec} spec vendor || die
-
- vim-plugin_src_install
-
- # make sure scripts are executable
- chmod +x "${ED}"/usr/share/vim/vimfiles/ruby/${PN}/bin/* || die
-}
diff --git a/app-vim/command-t/command-t-5.0.3.ebuild b/app-vim/command-t/command-t-5.0.3.ebuild
index a8bbc97873aa..527019cac449 100644
--- a/app-vim/command-t/command-t-5.0.3.ebuild
+++ b/app-vim/command-t/command-t-5.0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
inherit vim-plugin ruby-ng
diff --git a/dev-db/percona-xtrabackup/percona-xtrabackup-2.4.13.ebuild b/dev-db/percona-xtrabackup/percona-xtrabackup-2.4.13.ebuild
index b30c9c1a026b..b6f649295f2b 100644
--- a/dev-db/percona-xtrabackup/percona-xtrabackup-2.4.13.ebuild
+++ b/dev-db/percona-xtrabackup/percona-xtrabackup-2.4.13.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://www.percona.com/downloads/XtraBackup/Percona-XtraBackup-${PV}/s
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
DEPEND="
app-arch/lz4:0=
diff --git a/dev-libs/botan/botan-2.9.0.ebuild b/dev-libs/botan/botan-2.9.0.ebuild
index 8f92905d738a..4f995a89686a 100644
--- a/dev-libs/botan/botan-2.9.0.ebuild
+++ b/dev-libs/botan/botan-2.9.0.ebuild
@@ -34,6 +34,10 @@ RDEPEND="${DEPEND}
BDEPEND="dev-lang/python:*
doc? ( dev-python/sphinx )"
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
src_configure() {
local disable_modules=()
use boost || disable_modules+=( "boost" )
diff --git a/dev-libs/botan/files/botan-2.9.0-build.patch b/dev-libs/botan/files/botan-2.9.0-build.patch
new file mode 100755
index 000000000000..6208ffdbf0ad
--- /dev/null
+++ b/dev-libs/botan/files/botan-2.9.0-build.patch
@@ -0,0 +1,63 @@
+From 86df247e4f090f984e050962ed5a4a536ec63b33 Mon Sep 17 00:00:00 2001
+From: Ralf van der Enden <Ralf.vanderEnden@deltares.nl>
+Date: Fri, 5 Apr 2019 14:58:14 +0200
+Subject: [PATCH] boost 1.70 compatibility
+
+Fixes issue #82
+---
+ src/cli/tls_http_server.cpp | 8 +++++++-
+ src/cli/tls_proxy.cpp | 8 +++++++-
+ 2 files changed, 14 insertions(+), 2 deletions(-)
+
+diff --git a/src/cli/tls_http_server.cpp b/src/cli/tls_http_server.cpp
+index cc59a71c33..0a6428cd65 100644
+--- a/src/cli/tls_http_server.cpp
++++ b/src/cli/tls_http_server.cpp
+@@ -41,6 +41,12 @@
+
+ #include "credentials.h"
+
++#if BOOST_VERSION >= 107000
++#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
++#else
++#define GET_IO_SERVICE(s) ((s).get_io_service())
++#endif
++
+ namespace Botan_CLI {
+
+ namespace {
+@@ -435,7 +441,7 @@ class TLS_Asio_HTTP_Server final
+ session::pointer make_session()
+ {
+ return session::create(
+- m_acceptor.get_io_service(),
++ GET_IO_SERVICE(m_acceptor),
+ m_session_manager,
+ m_creds,
+ m_policy);
+diff --git a/src/cli/tls_proxy.cpp b/src/cli/tls_proxy.cpp
+index 49ffbe3766..42ce156b12 100644
+--- a/src/cli/tls_proxy.cpp
++++ b/src/cli/tls_proxy.cpp
+@@ -33,6 +33,12 @@
+
+ #include "credentials.h"
+
++#if BOOST_VERSION >= 107000
++#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
++#else
++#define GET_IO_SERVICE(s) ((s).get_io_service())
++#endif
++
+ namespace Botan_CLI {
+
+ namespace {
+@@ -370,7 +376,7 @@ class tls_proxy_server final
+ session::pointer make_session()
+ {
+ return session::create(
+- m_acceptor.get_io_service(),
++ GET_IO_SERVICE(m_acceptor),
+ m_session_manager,
+ m_creds,
+ m_policy,
diff --git a/dev-libs/xmlsec/Manifest b/dev-libs/xmlsec/Manifest
index 7b78da91ee14..e8c42b63e1d7 100644
--- a/dev-libs/xmlsec/Manifest
+++ b/dev-libs/xmlsec/Manifest
@@ -1,2 +1,3 @@
DIST xmlsec1-1.2.26.tar.gz 1922183 BLAKE2B 8cb8557a7d24df756655a7dfa45091445adc89cb67169a7620d9d1116f3fb3d982ea45199a53475e29300478c07e8e1168cec79cf9c3b5ff1dd6c840123b982b SHA512 1e3dc3c8c192eefee7b055787bef52ce3bcfafa786224f68af065aa45f4d7da93232da973359b3135615c5981ad4df7c124047d3934e552ab78439472685a7a4
DIST xmlsec1-1.2.27.tar.gz 2013651 BLAKE2B fa46a25e3aaef432134d1c98a0e7bf0aba83f2ef6d1aff3774d6d37c5f6f392d1c2c11a0fe433ee910c39b56400c96b74ab061577948622b14a1116fa1ec2947 SHA512 01f7231d7d7ac8037aecc1f922acc572cbfe0903abf5bd5879d836438c36684e23402b803d20806fff6b1cdc5ad9af114d1341b10b336f71c0bce28b4716f920
+DIST xmlsec1-1.2.28.tar.gz 1995599 BLAKE2B 5d90646d9a72024856da2638adb6d0d00d5142f8d3eaa5b12a993e2e6ae78ad49aab69822ebe331191bf1fc5b98431b85e113545aec84e2bb7d5c5add9028df0 SHA512 17fa59e4ffee5e024caa4895e8ed21d1435f14e3a37d0ed781b1dd216333ae3b6099c460efd45d4a8097d0202522150b7b0ad543b47c1596d8473b6922270480
diff --git a/dev-libs/xmlsec/files/xmlsec-1.2.28-test.patch b/dev-libs/xmlsec/files/xmlsec-1.2.28-test.patch
new file mode 100644
index 000000000000..fa1fa60a6df9
--- /dev/null
+++ b/dev-libs/xmlsec/files/xmlsec-1.2.28-test.patch
@@ -0,0 +1,121 @@
+From 9d5f2d172ab91fd9fb2c2eddaee86ba62eab2d67 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Tue, 16 Apr 2019 23:07:08 +0300
+Subject: [PATCH] tests: workout test --X509-skip-strict-checks
+
+The --X509-skip-strict-checks parameter is not accepted by all commands,
+result of skipping many tests.
+
+Reduce impact of the --X509-skip-strict-checks to a workaround to gnutls only.
+
+Filter double --X509-skip-strict-checks commands as cli does not accept
+multiple instances.
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ tests/testrun.sh | 37 ++++++++++++++++++++++---------------
+ 1 file changed, 22 insertions(+), 15 deletions(-)
+
+diff --git a/tests/testrun.sh b/tests/testrun.sh
+index ea65802b..35f4a780 100755
+--- a/tests/testrun.sh
++++ b/tests/testrun.sh
+@@ -59,7 +59,11 @@ if [ "z$XMLSEC_DEFAULT_CRYPTO" != "z" ] ; then
+ elif [ "z$crypto" != "z" ] ; then
+ xmlsec_params="$xmlsec_params --crypto $crypto"
+ fi
+-xmlsec_params="$xmlsec_params --X509-skip-strict-checks --crypto-config $crypto_config"
++xmlsec_params="$xmlsec_params --crypto-config $crypto_config"
++xmlsec_x509_params=
++if [ "z${crypto}" = zgnutls ]; then
++ xmlsec_x509_params="--X509-skip-strict-checks"
++fi
+
+ #
+ # Setup keys config
+@@ -218,8 +222,8 @@ execKeysTest() {
+ if [ -f $keysfile ] ; then
+ params="$params --keys-file $keysfile"
+ fi
+- echo "$VALGRIND $xmlsec_app keys $params $xmlsec_params $keysfile" >> $curlogfile
+- $VALGRIND $xmlsec_app keys $params $xmlsec_params $keysfile >> $curlogfile 2>> $curlogfile
++ echo "$VALGRIND $xmlsec_app keys $params $xmlsec_x509_params $xmlsec_params $keysfile" >> $curlogfile
++ $VALGRIND $xmlsec_app keys $params $xmlsec_x509_params $xmlsec_params $keysfile >> $curlogfile 2>> $curlogfile
+ printRes $expected_res $?
+ if [ $? != 0 ]; then
+ failures=`expr $failures + 1`
+@@ -307,9 +311,10 @@ execDSigTest() {
+
+ # run tests
+ if [ -n "$params1" ] ; then
++ echo "$params1" | grep -q -- "$xmlsec_x509_params" && _xmlsec_x509_params= || _xmlsec_x509_params="$xmlsec_x509_params"
+ printf " Verify existing signature "
+- echo "$VALGRIND $xmlsec_app verify $xmlsec_params $params1 $full_file.xml" >> $curlogfile
+- $VALGRIND $xmlsec_app verify $xmlsec_params $params1 $full_file.xml >> $curlogfile 2>> $curlogfile
++ echo "$VALGRIND $xmlsec_app verify $_xmlsec_x509_params $xmlsec_params $params1 $full_file.xml" >> $curlogfile
++ $VALGRIND $xmlsec_app verify $_xmlsec_x509_params $xmlsec_params $params1 $full_file.xml >> $curlogfile 2>> $curlogfile
+ printRes $expected_res $?
+ if [ $? != 0 ]; then
+ failures=`expr $failures + 1`
+@@ -317,9 +322,10 @@ execDSigTest() {
+ fi
+
+ if [ -n "$params2" -a -z "$PERF_TEST" ] ; then
++ echo "$params2" | grep -q -- "$xmlsec_x509_params" && _xmlsec_x509_params= || _xmlsec_x509_params="$xmlsec_x509_params"
+ printf " Create new signature "
+- echo "$VALGRIND $xmlsec_app sign $xmlsec_params $params2 --output $tmpfile $full_file.tmpl" >> $curlogfile
+- $VALGRIND $xmlsec_app sign $xmlsec_params $params2 --output $tmpfile $full_file.tmpl >> $curlogfile 2>> $curlogfile
++ echo "$VALGRIND $xmlsec_app sign $_xmlsec_x509_params $_xmlsec_params $params2 --output $tmpfile $full_file.tmpl" >> $curlogfile
++ $VALGRIND $xmlsec_app sign $_xmlsec_x509_params $_xmlsec_params $params2 --output $tmpfile $full_file.tmpl >> $curlogfile 2>> $curlogfile
+ printRes $res_success $?
+ if [ $? != 0 ]; then
+ failures=`expr $failures + 1`
+@@ -327,9 +333,10 @@ execDSigTest() {
+ fi
+
+ if [ -n "$params3" -a -z "$PERF_TEST" ] ; then
++ echo "$params3" | grep -q -- "$xmlsec_x509_params" && _xmlsec_x509_params= || _xmlsec_x509_params="$xmlsec_x509_params"
+ printf " Verify new signature "
+- echo "$VALGRIND $xmlsec_app verify $xmlsec_params $params3 $tmpfile" >> $curlogfile
+- $VALGRIND $xmlsec_app verify $xmlsec_params $params3 $tmpfile >> $curlogfile 2>> $curlogfile
++ echo "$VALGRIND $xmlsec_app verify $_xmlsec_x509_params $xmlsec_params $params3 $tmpfile" >> $curlogfile
++ $VALGRIND $xmlsec_app verify $_xmlsec_x509_params $xmlsec_params $params3 $tmpfile >> $curlogfile 2>> $curlogfile
+ printRes $res_success $?
+ if [ $? != 0 ]; then
+ failures=`expr $failures + 1`
+@@ -406,8 +413,8 @@ execEncTest() {
+ if [ -n "$params1" ] ; then
+ rm -f $tmpfile
+ printf " Decrypt existing document "
+- echo "$VALGRIND $xmlsec_app decrypt $xmlsec_params $params1 $full_file.xml" >> $curlogfile
+- $VALGRIND $xmlsec_app decrypt $xmlsec_params $params1 --output $tmpfile $full_file.xml >> $curlogfile 2>> $curlogfile
++ echo "$VALGRIND $xmlsec_app decrypt $xmlsec_x509_params $xmlsec_params $params1 $full_file.xml" >> $curlogfile
++ $VALGRIND $xmlsec_app decrypt $xmlsec_x509_params $xmlsec_params $params1 --output $tmpfile $full_file.xml >> $curlogfile 2>> $curlogfile
+ res=$?
+ echo "=== TEST RESULT: $res; expected: $expected_res" >> $curlogfile
+ if [ $res = 0 -a "$expected_res" = "$res_success" ]; then
+@@ -428,8 +435,8 @@ execEncTest() {
+ if [ -n "$params2" -a -z "$PERF_TEST" ] ; then
+ rm -f $tmpfile
+ printf " Encrypt document "
+- echo "$VALGRIND $xmlsec_app encrypt $xmlsec_params $params2 --output $tmpfile $full_file.tmpl" >> $curlogfile
+- $VALGRIND $xmlsec_app encrypt $xmlsec_params $params2 --output $tmpfile $full_file.tmpl >> $curlogfile 2>> $curlogfile
++ echo "$VALGRIND $xmlsec_app encrypt $xmlsec_x509_params $xmlsec_params $params2 --output $tmpfile $full_file.tmpl" >> $curlogfile
++ $VALGRIND $xmlsec_app encrypt $xmlsec_x509_params $xmlsec_params $params2 --output $tmpfile $full_file.tmpl >> $curlogfile 2>> $curlogfile
+ printRes $res_success $?
+ if [ $? != 0 ]; then
+ failures=`expr $failures + 1`
+@@ -439,8 +446,8 @@ execEncTest() {
+ if [ -n "$params3" -a -z "$PERF_TEST" ] ; then
+ rm -f $tmpfile.2
+ printf " Decrypt new document "
+- echo "$VALGRIND $xmlsec_app decrypt $xmlsec_params $params3 --output $tmpfile.2 $tmpfile" >> $curlogfile
+- $VALGRIND $xmlsec_app decrypt $xmlsec_params $params3 --output $tmpfile.2 $tmpfile >> $curlogfile 2>> $curlogfile
++ echo "$VALGRIND $xmlsec_app decrypt $xmlsec_x509_params $xmlsec_params $params3 --output $tmpfile.2 $tmpfile" >> $curlogfile
++ $VALGRIND $xmlsec_app decrypt $xmlsec_x509_params $xmlsec_params $params3 --output $tmpfile.2 $tmpfile >> $curlogfile 2>> $curlogfile
+ res=$?
+ if [ $res = 0 ]; then
+ if [ "z$outputTransform" != "z" ] ; then
+--
+2.21.0
+
diff --git a/dev-libs/xmlsec/xmlsec-1.2.26.ebuild b/dev-libs/xmlsec/xmlsec-1.2.26.ebuild
index f8f0ce257d51..16f8db947c10 100644
--- a/dev-libs/xmlsec/xmlsec-1.2.26.ebuild
+++ b/dev-libs/xmlsec/xmlsec-1.2.26.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
diff --git a/dev-libs/xmlsec/xmlsec-1.2.28.ebuild b/dev-libs/xmlsec/xmlsec-1.2.28.ebuild
new file mode 100644
index 000000000000..1e5834c6fbb1
--- /dev/null
+++ b/dev-libs/xmlsec/xmlsec-1.2.28.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Command line tool for signing, verifying, encrypting and decrypting XML"
+HOMEPAGE="https://www.aleksey.com/xmlsec"
+SRC_URI="https://www.aleksey.com/xmlsec/download/${PN}1-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gcrypt gnutls libressl nss +openssl static-libs test"
+REQUIRED_USE="|| ( gcrypt gnutls nss openssl )
+ gnutls? ( gcrypt )"
+
+RDEPEND=">=dev-libs/libxml2-2.7.4:=
+ >=dev-libs/libxslt-1.0.20:=
+ gcrypt? ( >=dev-libs/libgcrypt-1.4.0:0= )
+ gnutls? ( >=net-libs/gnutls-2.8.0:= )
+ nss? (
+ >=dev-libs/nspr-4.4.1:=
+ >=dev-libs/nss-3.9:=
+ )
+ openssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ test? (
+ nss? (
+ >=dev-libs/nss-3.9[utils]
+ )
+ )"
+
+S="${WORKDIR}/${PN}1-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-test.patch"
+)
+
+src_prepare() {
+ default
+ # conditionally install extra documentation
+ if ! use doc ; then
+ sed -i '/^SUBDIRS/s/docs//' Makefile.am || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-pkgconfig \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ $(use_enable static-libs static) \
+ $(use_with gcrypt) \
+ $(use_with gnutls) \
+ $(use_with nss) \
+ $(use_with nss nspr) \
+ $(use_with openssl) \
+ $(use_enable openssl aes)
+}
+
+src_test() {
+ emake TMPFOLDER="${T}" check
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/games-util/nml/Manifest b/games-util/nml/Manifest
index 32a52b50b610..ff784d437ac0 100644
--- a/games-util/nml/Manifest
+++ b/games-util/nml/Manifest
@@ -1,2 +1 @@
-DIST nml-0.4.4.tar.gz 377998 BLAKE2B a65df2c371c1b1dda2469a968372f21f9f27e9739c8d8a9a0f582c126169921ee3ffc9745f6ef4ac21aebdeea35fd26385d3149e84d50381c4796b71b378571f SHA512 fd7b8d7abfc8b5ea694eedf00bbc4069a82de942178a58ec05e9d3efe7c8663103ffb6b98f7614ce165eb7cba42cb4c7589f77fb67dd95eb6293f62b3179c7b0
DIST nml-0.4.5.tar.gz 378578 BLAKE2B 1283cdcabd4cbaf12dda926b89c88a3942e9e4469879812abe372facd2c41ff20af0df792bbdadf71d9d3ad8d72e98e293fd903c880e77d3e4ee8a1b73e36ca9 SHA512 64b2f46a1c2e37fce8f51231094e30334f368b0db39c6a3977a144a798d8034d1abbe7c14af3921eb81f4b7caa193e7e53ccb9e27acd113e0407926b109ca952
diff --git a/games-util/nml/nml-0.4.4-r1.ebuild b/games-util/nml/nml-0.4.4-r1.ebuild
deleted file mode 100644
index b50f0471e311..000000000000
--- a/games-util/nml/nml-0.4.4-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
-inherit distutils-r1
-
-DESCRIPTION="Compiler of NML files into grf/nfo files"
-HOMEPAGE="https://dev.openttdcoop.org/projects/nml"
-SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-RDEPEND="dev-python/pillow[zlib,${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DOCS=( docs/{changelog,readme}.txt )
-PATCHES=( "${FILESDIR}"/${P}-pillow3.patch )
-
-src_install() {
- distutils-r1_src_install
- doman docs/nmlc.1
-}
diff --git a/games-util/nml/nml-0.4.5.ebuild b/games-util/nml/nml-0.4.5.ebuild
index 0e8f0244e466..23ae3722e28b 100644
--- a/games-util/nml/nml-0.4.5.ebuild
+++ b/games-util/nml/nml-0.4.5.ebuild
@@ -13,7 +13,7 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-RDEPEND="dev-python/pillow[zlib,${PYTHON_USEDEP}]
+RDEPEND="<dev-python/pillow-6.0.0[zlib,${PYTHON_USEDEP}]
dev-python/ply[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"