aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/fortran-stdlib/fortran-stdlib-0.2.1-r1.ebuild10
-rw-r--r--dev-libs/fortran-stdlib/fortran-stdlib-0.3.0.ebuild10
-rw-r--r--dev-libs/fortran-stdlib/fortran-stdlib-9999.ebuild7
3 files changed, 13 insertions, 14 deletions
diff --git a/dev-libs/fortran-stdlib/fortran-stdlib-0.2.1-r1.ebuild b/dev-libs/fortran-stdlib/fortran-stdlib-0.2.1-r1.ebuild
index 943c09968..a08a118a5 100644
--- a/dev-libs/fortran-stdlib/fortran-stdlib-0.2.1-r1.ebuild
+++ b/dev-libs/fortran-stdlib/fortran-stdlib-0.2.1-r1.ebuild
@@ -1,18 +1,20 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
FORTRAN_STANDARD="2003"
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake fortran-2 python-any-r1
MY_PN="stdlib"
-SRC_URI="https://github.com/fortran-lang/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="A community driven standard library for (modern) Fortran"
HOMEPAGE="https://stdlib.fortran-lang.org/"
+SRC_URI="https://github.com/fortran-lang/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="MIT"
SLOT="0"
@@ -20,8 +22,6 @@ KEYWORDS="~amd64"
IUSE="doc test"
RESTRICT="mirror !test? ( test )"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
DEPEND="
${PYTHON_DEPS}
$(python_gen_any_dep '
diff --git a/dev-libs/fortran-stdlib/fortran-stdlib-0.3.0.ebuild b/dev-libs/fortran-stdlib/fortran-stdlib-0.3.0.ebuild
index 943c09968..a08a118a5 100644
--- a/dev-libs/fortran-stdlib/fortran-stdlib-0.3.0.ebuild
+++ b/dev-libs/fortran-stdlib/fortran-stdlib-0.3.0.ebuild
@@ -1,18 +1,20 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
FORTRAN_STANDARD="2003"
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake fortran-2 python-any-r1
MY_PN="stdlib"
-SRC_URI="https://github.com/fortran-lang/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="A community driven standard library for (modern) Fortran"
HOMEPAGE="https://stdlib.fortran-lang.org/"
+SRC_URI="https://github.com/fortran-lang/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="MIT"
SLOT="0"
@@ -20,8 +22,6 @@ KEYWORDS="~amd64"
IUSE="doc test"
RESTRICT="mirror !test? ( test )"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
DEPEND="
${PYTHON_DEPS}
$(python_gen_any_dep '
diff --git a/dev-libs/fortran-stdlib/fortran-stdlib-9999.ebuild b/dev-libs/fortran-stdlib/fortran-stdlib-9999.ebuild
index e26c6edf2..fc42774f9 100644
--- a/dev-libs/fortran-stdlib/fortran-stdlib-9999.ebuild
+++ b/dev-libs/fortran-stdlib/fortran-stdlib-9999.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
FORTRAN_STANDARD="2003"
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake fortran-2 git-r3 python-any-r1
-EGIT_REPO_URI="https://github.com/fortran-lang/stdlib.git"
-
DESCRIPTION="A community driven standard library for (modern) Fortran"
HOMEPAGE="https://stdlib.fortran-lang.org/"
+EGIT_REPO_URI="https://github.com/fortran-lang/stdlib.git"
LICENSE="MIT"
SLOT="0"