aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/cc65/cc65-2.19-r3.ebuild5
-rw-r--r--dev-lang/cc65/cc65-9999-r1.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-lang/cc65/cc65-2.19-r3.ebuild b/dev-lang/cc65/cc65-2.19-r3.ebuild
index 101856cdd..c365d5163 100644
--- a/dev-lang/cc65/cc65-2.19-r3.ebuild
+++ b/dev-lang/cc65/cc65-2.19-r3.ebuild
@@ -14,6 +14,11 @@ SLOT="0"
KEYWORDS="~amd64"
src_compile() {
+ ewarn "According to an upstream maintainer, cc65 has a tendency to"
+ ewarn "\"fail randomly\" when using \`make -j' to build in parallel."
+ ewarn "If compiling this package fails, and you have parallel jobs"
+ ewarn "enabled, try again with \`MAKEOPTS+=-j1' to disable them."
+
emake CC="$(tc-getCC)" AR="$(tc-getAR)" PREFIX="${EPREFIX}/usr"
}
diff --git a/dev-lang/cc65/cc65-9999-r1.ebuild b/dev-lang/cc65/cc65-9999-r1.ebuild
index dc3fbf25f..32270f99b 100644
--- a/dev-lang/cc65/cc65-9999-r1.ebuild
+++ b/dev-lang/cc65/cc65-9999-r1.ebuild
@@ -13,6 +13,11 @@ LICENSE="ZLIB"
SLOT="0"
src_compile() {
+ ewarn "According to an upstream maintainer, cc65 has a tendency to"
+ ewarn "\"fail randomly\" when using \`make -j' to build in parallel."
+ ewarn "If compiling this package fails, and you have parallel jobs"
+ ewarn "enabled, try again with \`MAKEOPTS+=-j1' to disable them."
+
emake CC="$(tc-getCC)" AR="$(tc-getAR)" PREFIX="${EPREFIX}/usr"
}