aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-crystal')
-rw-r--r--dev-crystal/selenium/Manifest1
-rw-r--r--dev-crystal/selenium/metadata.xml8
-rw-r--r--dev-crystal/selenium/selenium-0.9.1.ebuild37
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-crystal/selenium/Manifest b/dev-crystal/selenium/Manifest
new file mode 100644
index 000000000..d3ffb910d
--- /dev/null
+++ b/dev-crystal/selenium/Manifest
@@ -0,0 +1 @@
+DIST selenium-0.9.1.tar.gz 15955 BLAKE2B 3a2a7d60ad4e9eb41d3e75484dbce38c66209971506c79266fed08261019839555fbc4e82b4ad80eab37acef8374ce9b700754d2190bb8c56f76120aefafd3f5 SHA512 e9b7940816ade0e159c377e1a7026bdec4719afbb83df6773a72fa911d54c57eb9fb7a5bb0a154f154ad38876b0916f187a2f50a404dc1810f8215bc2fee6c19
diff --git a/dev-crystal/selenium/metadata.xml b/dev-crystal/selenium/metadata.xml
new file mode 100644
index 000000000..7ebbd0334
--- /dev/null
+++ b/dev-crystal/selenium/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-crystal/selenium/selenium-0.9.1.ebuild b/dev-crystal/selenium/selenium-0.9.1.ebuild
new file mode 100644
index 000000000..e41d7f1cf
--- /dev/null
+++ b/dev-crystal/selenium/selenium-0.9.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit shards
+
+MY_PN="${PN}.cr"
+DESCRIPTION="Selenium library for Crystal"
+HOMEPAGE="
+ https://matthewmcgarvey.github.io/selenium.cr/
+ https://github.com/matthewmcgarvey/selenium.cr
+"
+SRC_URI="https://github.com/matthewmcgarvey/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+BDEPEND="
+ test? (
+ dev-crystal/webdrivers
+ || (
+ www-client/firefox
+ www-client/firefox-bin
+ )
+ )
+"
+
+src_test() {
+ local -x SELENIUM_BROWSER=firefox
+ ecrystal spec --tag "~firefox"
+}