aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/afetch')
-rw-r--r--app-misc/afetch/Manifest1
-rw-r--r--app-misc/afetch/afetch-2.0.1.ebuild25
-rw-r--r--app-misc/afetch/metadata.xml15
3 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/afetch/Manifest b/app-misc/afetch/Manifest
new file mode 100644
index 000000000..7d5cbe56d
--- /dev/null
+++ b/app-misc/afetch/Manifest
@@ -0,0 +1 @@
+DIST afetch-2.0.1.tar.gz 80707 BLAKE2B ef3f0331e276b3a4451e704beb90e31f5540581bc262033016d292a85091cbdbda5624658f40a0be3bb0374caae2e54c6301c10f062840a9bc55e04efe259439 SHA512 82b04591189abcc2b4587b0f119c5832a829539d12a099c712ace533cc2612ec6f135b62c72e9515e43235790c087f765f6ba470ee99b1ed71ac1a5f158796cc
diff --git a/app-misc/afetch/afetch-2.0.1.ebuild b/app-misc/afetch/afetch-2.0.1.ebuild
new file mode 100644
index 000000000..166978dbf
--- /dev/null
+++ b/app-misc/afetch/afetch-2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig
+
+DESCRIPTION="Simple system info written in C"
+HOMEPAGE="https://github.com/13-CF/afetch/"
+SRC_URI="https://github.com/13-CF/afetch/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="savedconfig"
+
+src_prepare() {
+ default
+ restore_config src/config.h
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX="${EPREFIX}"/usr install
+ save_config src/config.h
+}
diff --git a/app-misc/afetch/metadata.xml b/app-misc/afetch/metadata.xml
new file mode 100644
index 000000000..54be64b95
--- /dev/null
+++ b/app-misc/afetch/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mathieu.tortuyaux@gmail.com</email>
+ <name>Mathieu Tortuyaux</name>
+ </maintainer>
+ <longdescription lang="en">
+Simple system info written in C
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/13-CF/afetch/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
+