aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/mbdyn/files/mbdyn-find-bullet.patch22
-rw-r--r--sci-physics/mbdyn/mbdyn-1.7.3_p20210925.ebuild5
2 files changed, 25 insertions, 2 deletions
diff --git a/sci-physics/mbdyn/files/mbdyn-find-bullet.patch b/sci-physics/mbdyn/files/mbdyn-find-bullet.patch
new file mode 100644
index 000000000..129976181
--- /dev/null
+++ b/sci-physics/mbdyn/files/mbdyn-find-bullet.patch
@@ -0,0 +1,22 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1889,15 +1889,15 @@
+ if test "$ol_with_bullet" != "no" ; then
+ AC_LANG_CPLUSPLUS
+ have_libbullet=no
+- AC_CHECK_HEADER(BulletCollision/CollisionShapes/btCollisionShape.h,[have_bullet_h=yes],[have_bullet_h=no])
++ AC_CHECK_HEADER(bullet/BulletCollision/CollisionShapes/btCollisionShape.h,[have_bullet_h=yes],[have_bullet_h=no])
+ if test "$have_bullet_h" = "yes" ; then
+ SAVE_LIBS="$LIBS"
+- try_BULLET_LIBS="-lbulletcollision -lbulletmath"
++ try_BULLET_LIBS="-lBulletCollision"
+ LIBS="$try_BULLET_LIBS $LIBS"
+- AC_CHECK_LIB(bulletcollision,btBulletCollisionProbe,[
++ AC_CHECK_LIB(BulletCollision,btBulletCollisionProbe,[
+ have_libbullet=yes
+ BULLET_LIBS="$try_BULLET_LIBS"
+- ],[have_libbullet=no],[-lbulletmath])
++ ],[have_libbullet=no],[])
+ LIBS="$save_LIBS"
+ fi
+
diff --git a/sci-physics/mbdyn/mbdyn-1.7.3_p20210925.ebuild b/sci-physics/mbdyn/mbdyn-1.7.3_p20210925.ebuild
index 6fecb6acb..5a7971737 100644
--- a/sci-physics/mbdyn/mbdyn-1.7.3_p20210925.ebuild
+++ b/sci-physics/mbdyn/mbdyn-1.7.3_p20210925.ebuild
@@ -7,7 +7,7 @@ COMMIT="ae57618c4e7b030b59707b8c156a6e2a94a6efd0"
MYP="${PN}-${COMMIT}"
PYTHON_COMPAT=( python3_{8..10} )
-inherit autotools fortran-2 pam python-single-r1
+inherit autotools flag-o-matic fortran-2 pam python-single-r1
DESCRIPTION="A general purpose Multibody Dynamics analysis software"
HOMEPAGE="https://www.mbdyn.org"
@@ -138,6 +138,7 @@ DEPEND="
BDEPEND="python? ( dev-lang/swig )"
PATCHES=(
+ "${FILESDIR}/${PN}-find-bullet.patch"
"${FILESDIR}/${PN}-octave-no-global-install.patch"
)
# "${FILESDIR}/${PN}-respect-libtool.patch"
@@ -176,7 +177,7 @@ src_prepare() {
src_configure() {
python_setup
-# append-cxxflags "-I/usr/include/openmpi/ompi/mpi/cxx/"
+ append-cxxflags "-I/usr/include/bullet"
local myconf=(
--disable-static
--disable-Werror