aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-02-14 19:57:59 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-02-18 02:11:14 +0500
commitdae04355f9cd42e61c16a61a27e49e2f2f0b718e (patch)
tree303da1d55c228f871ad92e4f436b5a67d00dc69b /net-client
parentgames-server/among-sus: export CC, update service (diff)
downloadguru-dae04355f9cd42e61c16a61a27e49e2f2f0b718e.tar.gz
guru-dae04355f9cd42e61c16a61a27e49e2f2f0b718e.tar.bz2
guru-dae04355f9cd42e61c16a61a27e49e2f2f0b718e.zip
net-client/offpunk: add 0.3
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'net-client')
-rw-r--r--net-client/offpunk/Manifest1
-rw-r--r--net-client/offpunk/offpunk-0.3.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-client/offpunk/Manifest b/net-client/offpunk/Manifest
index 9864b4366..5cbd2dbfb 100644
--- a/net-client/offpunk/Manifest
+++ b/net-client/offpunk/Manifest
@@ -1 +1,2 @@
DIST offpunk-0.1.tar.gz 25356 BLAKE2B 45169fae6f566dfab0b8416442f220e62c49cd32ed020bb516f2474ebe7736fca413a68ecf3ec9d609897b02b9092dfe6c7d03dc403c52eaaf63541e4ce16a88 SHA512 5592a314bf3ebd91be083c5a8b43db483f80138113825cdfe0d141cecf0ca9482011eab1a05a7212323c2c1b5a95eb1dbdad4363a281e8229287d433552b6fd5
+DIST offpunk-0.3.tar.gz 37000 BLAKE2B b47fd241acef4155337a336d5a25b4a727849a28d2b1a9a9f3c2475960f472e238f5bc50ac59f582daf5ed3b1ec69edc1c6b4c6e5eebe64fd2c962eb7dbe00a2 SHA512 1336e7f0aab177a786c114143b5b8fa4eaa3a4b675581d2ec38d55268f8a006158a181b659732a89cf000f8be550ae38e222bbae827abaea2bc7a2875397acc9
diff --git a/net-client/offpunk/offpunk-0.3.ebuild b/net-client/offpunk/offpunk-0.3.ebuild
new file mode 100644
index 000000000..87e9e775a
--- /dev/null
+++ b/net-client/offpunk/offpunk-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1 optfeature
+
+MY_PN="av-98-offline"
+DESCRIPTION="A command-line, text-based and offline-first Gemini browser"
+HOMEPAGE="https://tildegit.org/ploum/AV-98-offline"
+SRC_URI="https://tildegit.org/ploum/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( CHANGELOG README.md )
+
+pkg_postinst() {
+ optfeature "better TOFU certificate validation" dev-python/cryptography
+ #optfeature "ANSI escape codes support" dev-python/ansiwrap
+ optfeature "MIME type detection support" dev-python/python-magic
+ optfeature "clipboard support" x11-misc/xsel
+}