aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-04-28 01:18:34 +0200
committerJulien Roy <julien@jroy.ca>2024-05-13 18:18:20 -0400
commitd6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc (patch)
tree33de9196b9bf108bf4da7606b99327ba2c5f1af9 /games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild
parentdev-vcs/*: fix variable order (diff)
downloadguru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.tar.gz
guru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.tar.bz2
guru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.zip
games-*/*: fix variable order
I manually went through some entries for `pkgcheck scan -c VariableOrderCheck`. Misc updates: UnusedEclassesCheck RESTRICT+=" .." -> RESTRICT=".." Signed-off-by: Lucio Sauer <watermanpaint@posteo.net> Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild')
-rw-r--r--games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild b/games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild
index 25bbae463..3e3d66864 100644
--- a/games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild
+++ b/games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-_app_id=net.davidotek.pupgui2
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=(python3_{9..12})
@@ -11,12 +10,15 @@ EPYTHON=python3
inherit distutils-r1 desktop xdg-utils
-SRC_URI="https://github.com/DavidoTek/ProtonUp-Qt/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+_app_id=net.davidotek.pupgui2
+
DESCRIPTION="Install and manage GE-Proton, Luxtorpeda & more for Steam Lutris and Heroic."
HOMEPAGE="https://davidotek.github.io/protonup-qt"
+SRC_URI="https://github.com/DavidoTek/ProtonUp-Qt/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
+KEYWORDS="~amd64"
RDEPEND="dev-python/steam
dev-python/requests
@@ -26,14 +28,11 @@ RDEPEND="dev-python/steam
dev-python/pyaml
dev-python/zstandard
"
-
DEPEND="${RDEPEND}
dev-util/desktop-file-utils
dev-libs/appstream-glib
"
-KEYWORDS="~amd64"
-
src_compile() {
appstream-util validate-relax --nonet "share/metainfo/$_app_id.appdata.xml"
desktop-file-validate "share/applications/$_app_id.desktop"