aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Zapparov <alexey@zapparov.com>2021-12-26 03:10:39 +0100
committerAlexey Zapparov <alexey@zapparov.com>2021-12-26 03:10:39 +0100
commitdc5b4410bff004c578587b5eaa11138de52a6c6f (patch)
tree9518d79ffdf215fe716a6d9c25019462441a665c /dev-ruby
parentdev-ruby/rbspy: add v0.10.0 (diff)
downloadguru-dc5b4410bff004c578587b5eaa11138de52a6c6f.tar.gz
guru-dc5b4410bff004c578587b5eaa11138de52a6c6f.tar.bz2
guru-dc5b4410bff004c578587b5eaa11138de52a6c6f.zip
dev-ruby/ruby-install: add v0.8.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alexey Zapparov <alexey@zapparov.com>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-install/Manifest1
-rw-r--r--dev-ruby/ruby-install/metadata.xml13
-rw-r--r--dev-ruby/ruby-install/ruby-install-0.8.3.ebuild26
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/ruby-install/Manifest b/dev-ruby/ruby-install/Manifest
new file mode 100644
index 000000000..0a6371c85
--- /dev/null
+++ b/dev-ruby/ruby-install/Manifest
@@ -0,0 +1 @@
+DIST ruby-install-0.8.3.tar.gz 32381 BLAKE2B fd2c15333e571881d9a6be67c2b968f81bd8b2d2025972dd502df35b4ce1b2a5dbfbac29327d2dfa83b779f923342c23c30423455c202a0978581ab71291ce22 SHA512 1fdd44b709a7d2eaae4b1ebf7a08381c565d7656d52cf69b98b0e00d383b39c7776848f7acd5f5f79f1a9ad935907e230c256b7cdf46714fddd9a8cfac418c9a
diff --git a/dev-ruby/ruby-install/metadata.xml b/dev-ruby/ruby-install/metadata.xml
new file mode 100644
index 000000000..172ff1966
--- /dev/null
+++ b/dev-ruby/ruby-install/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexey@zapparov.com</email>
+ <name>Alexey Zapparov</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/postmodern/ruby-install/issues</bugs-to>
+ <changelog>https://github.com/postmodern/ruby-install/blob/master/ChangeLog.md</changelog>
+ <remote-id type="github">postmodern/ruby-install</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-install/ruby-install-0.8.3.ebuild b/dev-ruby/ruby-install/ruby-install-0.8.3.ebuild
new file mode 100644
index 000000000..90514191e
--- /dev/null
+++ b/dev-ruby/ruby-install/ruby-install-0.8.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Installs Ruby, JRuby, Rubinius, TruffleRuby (native / GraalVM), or mruby."
+HOMEPAGE="https://github.com/postmodern/ruby-install"
+SRC_URI="https://github.com/postmodern/ruby-install/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=app-shells/bash-3.0:*"
+RDEPEND="${DEPEND}
+ sys-apps/grep
+ || ( >net-misc/wget-1.12 net-misc/curl )
+ dev-libs/openssl
+ app-arch/tar
+ app-arch/bzip2
+ sys-devel/patch
+ || ( >=sys-devel/gcc-4.2 sys-devel/clang )"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}