aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2021-07-28 10:46:47 +0200
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2021-07-28 10:47:04 +0200
commit62f75ba4b54d232156ae5850e6555c26d4f6f16c (patch)
treebc2a203e2f3fe96e70546e08fe538113c0a84784 /dev-python/pydub
parentprofiles: also mask extrae[clustering] (diff)
downloadguru-62f75ba4b54d232156ae5850e6555c26d4f6f16c.tar.gz
guru-62f75ba4b54d232156ae5850e6555c26d4f6f16c.tar.bz2
guru-62f75ba4b54d232156ae5850e6555c26d4f6f16c.zip
dev-python/pydub: add 0.25.1 test dep and optfeature
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
Diffstat (limited to 'dev-python/pydub')
-rw-r--r--dev-python/pydub/pydub-0.25.1.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/dev-python/pydub/pydub-0.25.1.ebuild b/dev-python/pydub/pydub-0.25.1.ebuild
index 613b9b83c..cf4e8d002 100644
--- a/dev-python/pydub/pydub-0.25.1.ebuild
+++ b/dev-python/pydub/pydub-0.25.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=8
+EAPI=7
PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
+inherit distutils-r1 optfeature
DESCRIPTION="Manipulate audio with an simple and easy high level interface"
HOMEPAGE="http://pydub.com/"
@@ -17,6 +17,18 @@ KEYWORDS="~amd64"
distutils_enable_tests unittest
+BDEPEND="
+ test? (
+ media-video/ffmpeg
+ )
+ "
+
python_test() {
eunittest test/
}
+
+pkg_postinst() {
+ optfeature "opening and saving non-wav files - like mp3" media-video/ffmpeg
+ #optfeature "playing audio" dev-python/simpleaudio # upstream suggests this, not available in gentoo or guru
+ optfeature "playing audio" dev-python/pyaudio
+}