aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-12-22 03:47:57 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2022-12-22 03:49:13 +0300
commit9d1a34f48d520040c4bc8c091ee37555dfea19dc (patch)
treee106d2291fe1484283e6254d655a41001537eeb8 /dev-libs
parentgames-emulation/dosbox-x: Backport upstream LTO ODR fix to 2022.08.0 (diff)
downloadguru-9d1a34f48d520040c4bc8c091ee37555dfea19dc.tar.gz
guru-9d1a34f48d520040c4bc8c091ee37555dfea19dc.tar.bz2
guru-9d1a34f48d520040c4bc8c091ee37555dfea19dc.zip
dev-libs/m_cli2: fix compler setup flag typo
Closes: https://bugs.gentoo.org/886033 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/m_cli2/m_cli2-1.0.0_p20221116.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-libs/m_cli2/m_cli2-1.0.0_p20221116.ebuild b/dev-libs/m_cli2/m_cli2-1.0.0_p20221116.ebuild
index 7b8c93452..4097351e9 100644
--- a/dev-libs/m_cli2/m_cli2-1.0.0_p20221116.ebuild
+++ b/dev-libs/m_cli2/m_cli2-1.0.0_p20221116.ebuild
@@ -26,14 +26,14 @@ src_prepare() {
default
# # Set Fortran FLAGS
- sed -i -e "s/F90FLAGS := .*$/F90FLAGS := ${FCFLAGS} -fPIC/" Makefile || die
+ sed -i -e 's/F90FLAGS := .*$/F90FLAGS := '"${FCFLAGS}"' -fPIC/' Makefile || die
}
src_compile() {
case $(tc-getFC) in
*gfortran* )
emake clean
- emake FC90=$(tc-getFC) gfortran
+ emake F90=$(tc-getFC) gfortran
$(tc-getFC) -Wl,-soname,lib"${PN}".so.1 ${LDFLAGS} -shared -o lib"${PN}".so.1 M_CLI2.o;;
* )
die "Sorry, only GNU gfortran is currently supported in the ebuild" ;;