aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-10-15 23:52:49 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-10-15 23:52:49 +0900
commit7593ae53f051d731a252b1e41b735327f3238012 (patch)
tree52b0ac992568f83746ffb583a4f4eebfeabd2a87 /dev-libs
parentdev-libs/libdatrie: add USE=doc (diff)
downloadguru-7593ae53f051d731a252b1e41b735327f3238012.tar.gz
guru-7593ae53f051d731a252b1e41b735327f3238012.tar.bz2
guru-7593ae53f051d731a252b1e41b735327f3238012.zip
dev-libs/libthai: add USE=doc
Closes: https://bugs.gentoo.org/807911 Closes: https://bugs.gentoo.org/839864 Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libthai/libthai-0.1.29.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/dev-libs/libthai/libthai-0.1.29.ebuild b/dev-libs/libthai/libthai-0.1.29.ebuild
index a57b377df..f93fc2011 100644
--- a/dev-libs/libthai/libthai-0.1.29.ebuild
+++ b/dev-libs/libthai/libthai-0.1.29.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,25 +16,28 @@ else
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
fi
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+"
SLOT="0"
+IUSE="doc"
RDEPEND="dev-libs/libdatrie"
DEPEND="${RDEPEND}"
-BDEPEND="dev-vcs/git"
+BDEPEND="doc? ( app-text/doxygen )"
src_prepare() {
default
# Fixed version if in non git project
echo ${PV} > VERSION
- # From upstreams autogen.sh, to make it utilize the autotools eclass
- # Here translate the autogen.sh, equivalent to the following code
- # > sh autogen.sh
- # Fix html doc path
- sed -i -e "s|share/doc/libthai/html|share/doc/libthai-${PV}/html|g" configure.ac || die
- _elibtoolize --force
- eaclocal
- eautomake --add-missing
- # Not allow git-version-gen does refresh
- eautoconf
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc doxygen-doc) \
+ --with-html-docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
}