aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-04-06 03:13:09 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-04-06 03:13:09 +0200
commit23dd59a1749efbd60b540dbe2c6fe72f695f05eb (patch)
treebd8dd2bb72de1296d3139b1ada402bbf63de3d33 /app-shells
parentapp-shells/zsh-async: Add newline between SRC_URI and LICENSE (diff)
downloadguru-23dd59a1749efbd60b540dbe2c6fe72f695f05eb.tar.gz
guru-23dd59a1749efbd60b540dbe2c6fe72f695f05eb.tar.bz2
guru-23dd59a1749efbd60b540dbe2c6fe72f695f05eb.zip
app-shells/zsh-autosuggestions: add 0.7.0
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-autosuggestions/Manifest1
-rw-r--r--app-shells/zsh-autosuggestions/zsh-autosuggestions-0.7.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-shells/zsh-autosuggestions/Manifest b/app-shells/zsh-autosuggestions/Manifest
index 249800d81..9483341be 100644
--- a/app-shells/zsh-autosuggestions/Manifest
+++ b/app-shells/zsh-autosuggestions/Manifest
@@ -1 +1,2 @@
DIST zsh-autosuggestions-0.6.4.tar.gz 29154 BLAKE2B 73bef916e4abb53f6bd7d8daa67040a78e30aaaf3d71ed04e2f32d4fbbbc35bda1fa8cbcb8957324b52c39bf7ed454132ede657b2caee03798a41a2c330df0d9 SHA512 226b99048577ecdbe198501e6e4b3156c3d849994f0a2f7e15687cd244d4cac472cbcf746aaa32b2886652f6962852a475777b5f2bfcb3a6d0279be98a6020bb
+DIST zsh-autosuggestions-0.7.0.tar.gz 27953 BLAKE2B b12c387a7a6424f1e3e2bc76a4d9f11a3bddb4bc1d69236249722a829c53f3136ff0cbf8aaf02faff54f49f7b7363fcd06576a2dc6c8026c62951da2d0ebc2c2 SHA512 b1a0a11a89095e4f142061525f92836588561e3bfab015bb96eabe3f1f68d0cfcd7483014dac8c5b2911e65640e9182c5fc4cb4fb53e3a05ef7997c006ff76a6
diff --git a/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.7.0.ebuild b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.7.0.ebuild
new file mode 100644
index 000000000..924f2c04d
--- /dev/null
+++ b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.7.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+USE_RUBY="ruby26 ruby27 ruby30"
+
+inherit readme.gentoo-r1 ruby-fakegem
+
+DESCRIPTION="Fish-like autosuggestions for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-autosuggestions"
+SRC_URI="https://github.com/zsh-users/zsh-autosuggestions/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/all/${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=app-shells/zsh-4.3.11"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ app-misc/tmux
+ dev-ruby/bundler
+ dev-ruby/pry
+ dev-ruby/pry-byebug
+ dev-ruby/rspec-wait
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-functions/${PN}.zsh
+at the end of your ~/.zshrc"
+
+src_prepare() {
+ # FIXME: Disable failing tests
+ rm "spec/options/buffer_max_size_spec.rb" \
+ || die "Could not remove tests"
+ ruby-ng_src_prepare
+}
+
+src_install() {
+ insinto "/usr/share/zsh/site-functions/"
+ doins "${PN}.zsh"
+
+ readme.gentoo_create_doc
+ einstalldocs
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}