aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-07-14 18:57:00 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-07-14 18:57:00 +0200
commit10774d21b18d158e7d903d590e10ac04dd7b75b6 (patch)
tree0f853509d267983ba508f689ad2f745c43be60fb /app-emulation
parentdev-util/pmbootstrap: migrate to python-single-r1 (diff)
downloadguru-10774d21b18d158e7d903d590e10ac04dd7b75b6.tar.gz
guru-10774d21b18d158e7d903d590e10ac04dd7b75b6.tar.bz2
guru-10774d21b18d158e7d903d590e10ac04dd7b75b6.zip
app-emulation/dxvk-bin: add 1.10.2
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dxvk-bin/Manifest1
-rw-r--r--app-emulation/dxvk-bin/dxvk-bin-1.10.2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/app-emulation/dxvk-bin/Manifest b/app-emulation/dxvk-bin/Manifest
index 187bb2621..5a4452377 100644
--- a/app-emulation/dxvk-bin/Manifest
+++ b/app-emulation/dxvk-bin/Manifest
@@ -1,2 +1,3 @@
DIST dxvk-bin-1.10.1.tar.gz 8328595 BLAKE2B 28b7ba7190b44800d5656600fdc50d9d2c89669b1ec3053e4dd45bd5859271262e53c2016d0736611ce5904126b5a71a2f9dbee2c33feaea5d3dc986fef7f3a0 SHA512 5be4b34ec5f535a7ef6347b440fd7619a4bb6359919f4257dc71c84585d87362dbbce3c033c8b0eda0cbd6b6d08184aba0a2a1a12e195c82d776166536440e60
+DIST dxvk-bin-1.10.2.tar.gz 8449051 BLAKE2B b90cf6b1a4f088e13166f111c4a7b7a780f01bccf5851e02119185a6d10eb230b62027c06f0d06f4f97ba45788c3c8c839a1b720aa429cebdfddb6472fa025ee SHA512 9fff03e1c884ffe860650b6d37de640e483efe83437451587c11a76ff78ca6b0183c27620c2992cff8335a1a92ddd956a6b2edfd1d50e44652f6eb818c1b8054
DIST dxvk-bin-1.10.tar.gz 8271267 BLAKE2B d8d17e95871462a0f39af903fc13b9e8f24e4f819e6427153ef26b1150f22a0fe5fba58fa1cfedca6db71f3b384c106ea92bf5e39bd3c92ed282b859e9095a06 SHA512 5bbdc2d05868f41cfa073d2ad3e57ca01dc570109b8513b4b8e04a198d44b75128a62e2029ef2b57edd1ebf286661072c34d741a78cf456cddf97dd2a60afc03
diff --git a/app-emulation/dxvk-bin/dxvk-bin-1.10.2.ebuild b/app-emulation/dxvk-bin/dxvk-bin-1.10.2.ebuild
new file mode 100644
index 000000000..72f920257
--- /dev/null
+++ b/app-emulation/dxvk-bin/dxvk-bin-1.10.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+inherit multilib-minimal
+
+MY_P="dxvk-${PV}"
+DESCRIPTION="Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine"
+HOMEPAGE="https://github.com/doitsujin/dxvk"
+SRC_URI="https://github.com/doitsujin/dxvk/releases/download/v${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="video_cards_nvidia"
+
+DEPEND=""
+RDEPEND="
+ || (
+ video_cards_nvidia? ( >=x11-drivers/nvidia-drivers-440.31 )
+ >=media-libs/mesa-20.2
+ )
+ || (
+ >=app-emulation/wine-staging-4.5[${MULTILIB_USEDEP},vulkan]
+ >=app-emulation/wine-vanilla-4.5[${MULTILIB_USEDEP},vulkan]
+ )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+# NOTE: Various repos contain dxvk ebuilds that install into …/dxvk.
+# To not clash with them, this ebuild installs into …/dxvk-bin.
+
+src_prepare() {
+ default
+
+ sed -i "s|^basedir=.*$|basedir=\"${EPREFIX}\"|" setup_dxvk.sh || die
+
+ # Delete installation instructions for unused ABIs.
+ if ! use abi_x86_64; then
+ sed -i '/installFile "$win64_sys_path"/d' setup_dxvk.sh || die
+ fi
+ if ! use abi_x86_32; then
+ sed -i '/installFile "$win32_sys_path"/d' setup_dxvk.sh || die
+ fi
+
+ fix_install_dir() {
+ local bits="${MULTILIB_ABI_FLAG:8:2}"
+ # Fix installation directory.
+ sed -i "s|\"x${bits}\"|\"usr/$(get_libdir)/dxvk-bin\"|" \
+ setup_dxvk.sh || die
+ }
+ multilib_foreach_abi fix_install_dir
+}
+
+multilib_src_install() {
+ local bits="${MULTILIB_ABI_FLAG:8:2}"
+ insinto "usr/$(get_libdir)/dxvk-bin"
+ insopts --mode=755
+ doins "${S}/x${bits}/"*.dll
+}
+
+multilib_src_install_all() {
+ newbin setup_dxvk.sh setup_dxvk-bin.sh
+}
+
+pkg_postinst() {
+ elog "dxvk-bin is installed, but not activated. You have to create DLL overrides"
+ elog "in order to make use of it. To do so, set WINEPREFIX and execute"
+ elog "setup_dxvk-bin.sh install --symlink."
+}