aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2024-10-10 13:28:44 +0800
committerHuang Rui <vowstar@gmail.com>2024-10-10 13:28:44 +0800
commitacf94ee297a02f85b7e8ba23b15dd23f00ebc023 (patch)
tree26976d0404eecfa36fdc201f318c13657d84cd1f
parentsci-electronics/verilator: enable py3.13 (diff)
downloadguru-acf94ee297a02f85b7e8ba23b15dd23f00ebc023.tar.gz
guru-acf94ee297a02f85b7e8ba23b15dd23f00ebc023.tar.bz2
guru-acf94ee297a02f85b7e8ba23b15dd23f00ebc023.zip
sci-electronics/verilator: drop 5.022, 5.024
Signed-off-by: Huang Rui <vowstar@gmail.com>
-rw-r--r--sci-electronics/verilator/Manifest2
-rw-r--r--sci-electronics/verilator/verilator-5.022.ebuild69
-rw-r--r--sci-electronics/verilator/verilator-5.024.ebuild69
3 files changed, 0 insertions, 140 deletions
diff --git a/sci-electronics/verilator/Manifest b/sci-electronics/verilator/Manifest
index 437ae19a4..720079762 100644
--- a/sci-electronics/verilator/Manifest
+++ b/sci-electronics/verilator/Manifest
@@ -1,4 +1,2 @@
-DIST verilator-5.022.tar.gz 3761782 BLAKE2B 49713ce89f101eb6f6165ee316fc018936ccb21fd6ceccce343684ff3cca10285f851172549843078801e69828f0069877ec68a8ac39a1fbce4a2426d3e4b44d SHA512 5b919ed5d4cf863434f10f39bbb3a5155d63f79765f5f1d5ae543023b0e350e0996507d250fbfb2e5129bbdf9a51cc5fd0b7154962747c89435648897525bc84
-DIST verilator-5.024.tar.gz 3879481 BLAKE2B 5f25b4ab0b477fc58f3d052d49d3e13bf1fd5326a20873e2d85d0f2a8702f08dd47d93fc1db6eb3c5cef00d4a5e56c4636c381ca16985c8d7ccbe56bcad89e46 SHA512 34184f4c08bcbecf563b424c4c0fdcaf0c04d60e19887c4df5161b48db256dd7cbe960c71f854bd3dad073c193bbc0c576f171f84b634da58259b81e1afaf622
DIST verilator-5.026.tar.gz 3931397 BLAKE2B 0c9bb9582dd170e4d4170eaf9353672a3b5f35ebeccf0669cbae6ab0b5060ed4aab07a1ebba616264354f5fddd85d9013440e4ff83b658602f6ec086c0e2a920 SHA512 95660da60c6f5fac9ce3c7298edfc5ee71beeb2aafe2908b31c83802a22bc4529389d687c3a51eb9370cc6bd1ae9e74e11cdab0de69fa278b1da0d664a393a68
DIST verilator-5.028.tar.gz 32547892 BLAKE2B fed3fc8bb4e60a271e63ee137abdd3b0939cc6d775e1d85e75a3daf5915ccdef40fae120907e8bda5bbfc38561cc44d0929c5a4b433d08beedce0cdef7709205 SHA512 d3d8d107029afbbcdd9f7a06e7fb17de7c74b4334f6eb5316719550ceec64264d6c95fad9e03214a4ae39ce2e8f2c4bb650c755acf35f4cd656fb1b71300070b
diff --git a/sci-electronics/verilator/verilator-5.022.ebuild b/sci-electronics/verilator/verilator-5.022.ebuild
deleted file mode 100644
index 4b1fd5ff8..000000000
--- a/sci-electronics/verilator/verilator-5.022.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit autotools python-single-r1
-
-DESCRIPTION="The fast free Verilog/SystemVerilog simulator"
-HOMEPAGE="
- https://verilator.org
- https://github.com/verilator/verilator
-"
-
-if [[ "${PV}" == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-LICENSE="|| ( Artistic-2 LGPL-3 )"
-SLOT="0"
-IUSE="debug test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="
- ${PYTHON_DEPS}
- dev-lang/perl
- sys-libs/zlib
-"
-
-DEPEND="
- ${RDEPEND}
-"
-
-BDEPEND="
- sys-devel/bison
- sys-devel/flex
- test? (
- dev-build/cmake
- )
-"
-
-src_prepare() {
- default
- if [[ ! "${PV}" == "9999" ]] ; then
- # https://github.com/verilator/verilator/issues/3352
- sed -i "s/UNKNOWN_REV/(Gentoo ${PVR})/g" "${S}"/src/config_rev || die
- fi
- # https://bugs.gentoo.org/785151
- sed -i "s/python3/${EPYTHON}/g" "${S}"/configure.ac || die
- find . -name "Makefile" -exec sed -i "s/python3/${EPYTHON}/g" {} + || die
- find test_regress -type f -exec sed -i "s/python3/${EPYTHON}/g" {} + || die
- python_fix_shebang .
- # https://bugs.gentoo.org/887917
- if ! use debug; then
- sed -i '/AC_SUBST(CFG_CXXFLAGS_DEBUG)/i CFG_CXXFLAGS_DEBUG=""' "${S}"/configure.ac || die
- sed -i '/AC_SUBST(CFG_LDFLAGS_DEBUG)/i CFG_LDFLAGS_DEBUG=""' "${S}"/configure.ac || die
- fi
- eautoconf --force
-}
-
-src_test() {
- emake test
-}
diff --git a/sci-electronics/verilator/verilator-5.024.ebuild b/sci-electronics/verilator/verilator-5.024.ebuild
deleted file mode 100644
index 4b1fd5ff8..000000000
--- a/sci-electronics/verilator/verilator-5.024.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit autotools python-single-r1
-
-DESCRIPTION="The fast free Verilog/SystemVerilog simulator"
-HOMEPAGE="
- https://verilator.org
- https://github.com/verilator/verilator
-"
-
-if [[ "${PV}" == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-LICENSE="|| ( Artistic-2 LGPL-3 )"
-SLOT="0"
-IUSE="debug test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="
- ${PYTHON_DEPS}
- dev-lang/perl
- sys-libs/zlib
-"
-
-DEPEND="
- ${RDEPEND}
-"
-
-BDEPEND="
- sys-devel/bison
- sys-devel/flex
- test? (
- dev-build/cmake
- )
-"
-
-src_prepare() {
- default
- if [[ ! "${PV}" == "9999" ]] ; then
- # https://github.com/verilator/verilator/issues/3352
- sed -i "s/UNKNOWN_REV/(Gentoo ${PVR})/g" "${S}"/src/config_rev || die
- fi
- # https://bugs.gentoo.org/785151
- sed -i "s/python3/${EPYTHON}/g" "${S}"/configure.ac || die
- find . -name "Makefile" -exec sed -i "s/python3/${EPYTHON}/g" {} + || die
- find test_regress -type f -exec sed -i "s/python3/${EPYTHON}/g" {} + || die
- python_fix_shebang .
- # https://bugs.gentoo.org/887917
- if ! use debug; then
- sed -i '/AC_SUBST(CFG_CXXFLAGS_DEBUG)/i CFG_CXXFLAGS_DEBUG=""' "${S}"/configure.ac || die
- sed -i '/AC_SUBST(CFG_LDFLAGS_DEBUG)/i CFG_LDFLAGS_DEBUG=""' "${S}"/configure.ac || die
- fi
- eautoconf --force
-}
-
-src_test() {
- emake test
-}