summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.6.16.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.16.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.16.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.16.ebuild
index 37265ad36261..d106729a5eab 100644
--- a/sys-kernel/linux-headers/linux-headers-2.6.16.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.6.16.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.16.ebuild,v 1.1 2006/03/25 22:05:29 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.16.ebuild,v 1.2 2006/04/18 15:39:32 plasmaroo Exp $
ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arm hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
inherit eutils kernel-2 multilib
detect_version
-PATCHES_V='1'
+PATCHES_V='2'
SRC_URI="${KERNEL_URI} mirror://gentoo/linux-2.6.11-m68k-headers.patch.bz2
http://dev.gentoo.org/~plasmaroo/patches/kernel/gentoo-headers/gentoo-headers-${PV}-${PATCHES_V}.tar.bz2"
-KEYWORDS="-*" # -ppc -ppc64
+KEYWORDS="-*"
DEPEND="ppc? ( gcc64? ( sys-devel/gcc-powerpc64 ) )
sparc? ( gcc64? ( sys-devel/gcc-sparc64 ) )"
@@ -23,7 +23,7 @@ wrap_headers_fix() {
do
echo -n " $1/"
cd ${S}/include/$1
- headers___fix $(find . -mindepth 1 -type f -print)
+ headers___fix $(find . -type f -print)
shift
done
echo
@@ -38,16 +38,15 @@ src_unpack() {
# m68k for now (dont want to break other arches)
[[ $(tc-arch) == "m68k" ]] && epatch "${DISTDIR}"/linux-2.6.11-m68k-headers.patch.bz2
- # Fixes ... all the mv magic is to keep sed from dumping
+ # Get headers to bootstrap on PPC
+ if use ppc; then
+ cp arch/powerpc/configs/pmac32_defconfig arch/powerpc/configs/ppc_defconfig
+ fi
+
+ # Fixes ... all the wrapper magic is to keep sed from dumping
# ugly warnings about how it can't work on a directory.
cd "${S}"/include
einfo "Applying automated fixes:"
wrap_headers_fix asm-* linux
einfo "... done"
-
- # Apply patch for spinlick.h only with 32bit userland on ppc64.
- # Will add to the main patchball when plasmaroo returns.
- if use ppc && [[ ${PROFILE_ARCH} == "ppc64" ]]; then
- epatch ${FILESDIR}/2.6.11-ppc64-32ul-spinlock.patch
- fi
}