summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/quickplot/ChangeLog35
-rw-r--r--sci-visualization/quickplot/Manifest4
-rw-r--r--sci-visualization/quickplot/files/digest-quickplot-0.8.51
-rw-r--r--sci-visualization/quickplot/metadata.xml16
-rw-r--r--sci-visualization/quickplot/quickplot-0.8.5.ebuild50
5 files changed, 106 insertions, 0 deletions
diff --git a/sci-visualization/quickplot/ChangeLog b/sci-visualization/quickplot/ChangeLog
new file mode 100644
index 000000000000..edcf113266b7
--- /dev/null
+++ b/sci-visualization/quickplot/ChangeLog
@@ -0,0 +1,35 @@
+# ChangeLog for media-gfx/quickplot
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.1 2006/01/29 20:16:16 cryos Exp $
+
+ 29 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org> +metadata.xml,
+ +quickplot-0.8.5.ebuild:
+ Moved from media-gfx/quickplot to sci-visualization/quickplot.
+
+ 25 Jul 2005; David Holm <dholm@gentoo.org> quickplot-0.8.5.ebuild:
+ Added to ~ppc.
+
+ 17 Mar 2005; Marcus D. Hanwell <cryos@gentoo.org> quickplot-0.8.5.ebuild:
+ Marked stable on amd64 and x86.
+
+ 09 Jan 2005; Marcus Hanwell <cryos@gentoo.org> quickplot-0.8.5.ebuild:
+ Corrected paths in the help files, added a .desktop entry.
+
+ 07 Jan 2005; Marcus Hanwell <cryos@gentoo.org> quickplot-0.8.5.ebuild:
+ Added sndfile USE flag, and tidied up documentation files.
+
+*quickplot-0.8.5 (06 Jan 2005)
+
+ 06 Jan 2005; Marcus Hanwell <cryos@gentoo.org>
+ -files/quickplot-0.8.2-gcc-3.4.patch, -quickplot-0.8.2.ebuild,
+ +quickplot-0.8.5.ebuild:
+ Version bump, patch integrated upstream. Removed obsolete version.
+
+*quickplot-0.8.2 (05 Jan 2005)
+
+ 05 Jan 2005; Marcus Hanwell <cryos@gentoo.org> +metadata.xml,
+ +files/quickplot-0.8.2-gcc-3.4.patch, +quickplot-0.8.2.ebuild:
+ Initial import - thanks to Michael Labhard <m.labhard@comcast.net> bug 49103,
+ and Lance Arenault <lanceman@bev.net> bug 49725 for the initial ebuilds. I
+ added the gcc patch to fix compilation problems with GCC 3.4.
+
diff --git a/sci-visualization/quickplot/Manifest b/sci-visualization/quickplot/Manifest
new file mode 100644
index 000000000000..f7e4f6e33f70
--- /dev/null
+++ b/sci-visualization/quickplot/Manifest
@@ -0,0 +1,4 @@
+MD5 d1b060ad1d63952a89493f3a47b9e002 ChangeLog 1304
+MD5 f7ccf447ef7110a72f7c987c517942bd metadata.xml 689
+MD5 c6a4f1c68783336f056e24f21d7730ff quickplot-0.8.5.ebuild 1657
+MD5 161b412e414642dbef003cb31c9584b0 files/digest-quickplot-0.8.5 68
diff --git a/sci-visualization/quickplot/files/digest-quickplot-0.8.5 b/sci-visualization/quickplot/files/digest-quickplot-0.8.5
new file mode 100644
index 000000000000..226cb64c5a6d
--- /dev/null
+++ b/sci-visualization/quickplot/files/digest-quickplot-0.8.5
@@ -0,0 +1 @@
+MD5 55b90fd8e26b89574f2f9de98e85f10f quickplot-0.8.5.tar.bz2 394128
diff --git a/sci-visualization/quickplot/metadata.xml b/sci-visualization/quickplot/metadata.xml
new file mode 100644
index 000000000000..b17447c11e6d
--- /dev/null
+++ b/sci-visualization/quickplot/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>cryos@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Quickplot is a fast interactive 2D plotter with infinite zooming, value
+ picking, pipe input, and unlimited plots displayed. Quickplot is meant for
+ looking at your data quickly and of secondary importance is making static
+ pictures of your data. It's a data viewer, not a plot editor. It reads
+ ASCII text and sound files. It has lots of command line options, making it
+ very shell script friendly.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-visualization/quickplot/quickplot-0.8.5.ebuild b/sci-visualization/quickplot/quickplot-0.8.5.ebuild
new file mode 100644
index 000000000000..6d5f8c984ad5
--- /dev/null
+++ b/sci-visualization/quickplot/quickplot-0.8.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.8.5.ebuild,v 1.1 2006/01/29 20:16:16 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="A fast interactive 2D plotter."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://quickplot.sourceforge.net/"
+
+IUSE="sndfile"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc x86"
+
+RDEPEND=">=dev-cpp/gtkmm-2.4.5
+ sndfile? ( >=media-libs/libsndfile-1.0.5 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Some files have been moved around to more appropriate locations
+ sed -i -e 's|quickplot_icon.png|/usr/share/pixmaps/quickplot.png|' \
+ index.html.in
+ sed -i -e 's|href="ChangeLog"|href="../ChangeLog.gz"|' index.html.in
+ sed -i -e 's|href="COPYING"|href="/usr/portage/licenses/GPL-2"|' \
+ about.html.in
+}
+
+src_compile() {
+ econf `use_with sndfile libsndfile` || die "econf step failed."
+ emake htmldir=/usr/share/doc/${PF}/html || die "emake step failed."
+}
+
+src_install () {
+ make install DESTDIR=${D} htmldir=/usr/share/doc/${PF}/html \
+ || die "make install step failed."
+ dodoc AUTHORS ChangeLog README README.devel TODO
+ # Remove COPYING as it is specified in LICENCE. Move other stuff.
+ cd ${D}/usr/share/doc/${PF}/html
+ rm COPYING quickplot_icon.png ChangeLog
+ mv ${D}/usr/share/pixmaps/quickplot_icon.png \
+ ${D}/usr/share/pixmaps/quickplot.png
+ make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot.png Graphics
+ mv ${D}/usr/share/applications/quickplot\ --no-pipe.desktop \
+ ${D}/usr/share/applications/quickplot.desktop
+}