summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/grass/grass-6.0.1.ebuild')
-rw-r--r--sci-geosciences/grass/grass-6.0.1.ebuild44
1 files changed, 30 insertions, 14 deletions
diff --git a/sci-geosciences/grass/grass-6.0.1.ebuild b/sci-geosciences/grass/grass-6.0.1.ebuild
index ecb661a62653..67f4f9c84168 100644
--- a/sci-geosciences/grass/grass-6.0.1.ebuild
+++ b/sci-geosciences/grass/grass-6.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.0.1.ebuild,v 1.2 2005/10/13 06:38:35 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.0.1.ebuild,v 1.3 2006/03/18 22:28:45 nerdboy Exp $
inherit eutils
@@ -12,15 +12,15 @@ SRC_URI="http://grass.itc.it/grass60/source/${P}.tar.gz
LICENSE="GPL-2"
SLOT="6"
-KEYWORDS="x86 ~amd64 ~ppc sparc"
+KEYWORDS="~amd64 ~ppc sparc x86"
# To-do: get ppc64 gdal deps fixed up
# add gdal back to use flags once grass is fixed
-IUSE="blas fftw jpeg lapack motif mysql nls odbc opengl png postgres readline tiff truetype"
+IUSE="fftw jpeg motif mysql nls odbc opengl png postgres readline tcltk tiff truetype"
RESTRICT="nostrip"
-DEPEND=">=sys-devel/make-3.80
+RDEPEND=">=sys-devel/make-3.80
>=sys-libs/zlib-1.1.4
>=sys-devel/flex-2.5.4a
>=sys-devel/bison-1.35
@@ -30,11 +30,8 @@ DEPEND=">=sys-devel/make-3.80
sys-apps/man
>=sci-libs/proj-4.4.7
sci-libs/gdal
- blas? ( virtual/blas )
fftw? ( =sci-libs/fftw-2* )
jpeg? ( media-libs/jpeg )
- lapack? ( virtual/lapack )
- motif? ( x11-libs/openmotif )
postgres? ( >=dev-db/postgresql-7.3 )
mysql? ( dev-db/mysql )
odbc? ( >=dev-db/unixODBC-2.0.6 )
@@ -44,15 +41,36 @@ DEPEND=">=sys-devel/make-3.80
truetype? ( >=media-libs/freetype-2.0 )
nls? ( x11-terms/mlterm )
opengl? ( virtual/opengl )
- >=dev-lang/tcl-8.3.4
- >=dev-lang/tk-8.3.4
- virtual/x11"
+ tcltk? ( >=dev-lang/tcl-8.3.4
+ >=dev-lang/tk-8.3.4 )
+ motif? ( x11-libs/openmotif )
+ || (
+ ( x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libXp
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXpm
+ x11-libs/libXaw )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}
+ X? ( || (
+ ( x11-proto/xproto x11-proto/xextproto )
+ virtual/x11
+ )
+ )"
+
src_unpack() {
unpack ${A}
cd ${S}
epatch rpm/fedora/grass-readline.patch
+ sed -i -e "s/relid'/relid/" "${S}"/configure || die "sed blew chunks"
}
src_compile() {
@@ -82,11 +100,8 @@ src_compile() {
export LD_LIBRARY_PATH="/${WORKDIR}/image/usr/grass60/$(get_libdir):${LD_LIBRARY_PATH}"
./configure \
- `use_with tcltk` \
`use_with postgres` \
`use_with motif` \
- `use_with blas` \
- `use_with lapack` \
`use_with fftw` \
`use_with truetype freetype` \
`use_with jpeg` \
@@ -96,6 +111,7 @@ src_compile() {
`use_enable amd64 64bit` \
`use_with opengl` \
`use_with readline` \
+ `use_with tcltk` \
${MYCONF} || die "Error: configure failed!"
emake -j1 || die "Error: emake failed!"
}