summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/cuyo/ChangeLog7
-rw-r--r--games-puzzle/cuyo/cuyo-1.8.1.ebuild49
-rw-r--r--games-puzzle/cuyo/files/digest-cuyo-1.8.11
3 files changed, 56 insertions, 1 deletions
diff --git a/games-puzzle/cuyo/ChangeLog b/games-puzzle/cuyo/ChangeLog
index fbd4c34bdfd2..35b6048f8d38 100644
--- a/games-puzzle/cuyo/ChangeLog
+++ b/games-puzzle/cuyo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/cuyo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/ChangeLog,v 1.2 2003/09/10 15:45:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/ChangeLog,v 1.3 2003/09/14 03:41:30 vapier Exp $
+
+*cuyo-1.8.1 (13 Sep 2003)
+
+ 13 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Set QT to work with any version again.
*cuyo-1.6.1 (27 Dec 2002)
diff --git a/games-puzzle/cuyo/cuyo-1.8.1.ebuild b/games-puzzle/cuyo/cuyo-1.8.1.ebuild
new file mode 100644
index 000000000000..542ac30f8426
--- /dev/null
+++ b/games-puzzle/cuyo/cuyo-1.8.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/cuyo-1.8.1.ebuild,v 1.1 2003/09/14 03:41:30 vapier Exp $
+
+inherit games
+
+S=${WORKDIR}/${P/_}
+DESCRIPTION="highly addictive and remotely related to tetris"
+HOMEPAGE="http://www.karimmi.de/cuyo/"
+SRC_URI="http://savannah.nongnu.org/download/cuyo/${P//_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ x11-libs/qt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's:-O2:@CXXFLAGS@:' src/Makefile.in
+}
+
+src_compile() {
+ local qtver=
+ has_version =x11-libs/qt-3* \
+ && qtver=3 \
+ || qtver=2
+ egamesconf \
+ --with-qt \
+ --with-qt-dir=/usr/qt/${qtver} \
+ --with-x \
+ || die
+ emake || die
+}
+
+src_install() {
+ sed -i \
+ 's: $(pkgdatadir: $(DESTDIR)$(pkgdatadir:' \
+ data/Makefile
+ make install DESTDIR=${D} || die
+ dogamesbin ${D}/${GAMES_PREFIX}/games/cuyo
+ rm -rf ${D}/${GAMES_PREFIX}/games
+ dodoc AUTHORS COPYING INSTALL NEWS README TODO ChangeLog
+
+ prepgamesdirs
+}
diff --git a/games-puzzle/cuyo/files/digest-cuyo-1.8.1 b/games-puzzle/cuyo/files/digest-cuyo-1.8.1
new file mode 100644
index 000000000000..6cd594d82c32
--- /dev/null
+++ b/games-puzzle/cuyo/files/digest-cuyo-1.8.1
@@ -0,0 +1 @@
+MD5 f9cf9126df8edbf0b3885d59d835f241 cuyo-1.8.1.tar.gz 994816