summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/i2c-tools')
-rw-r--r--sys-apps/i2c-tools/Manifest1
-rw-r--r--sys-apps/i2c-tools/i2c-tools-3.0.2.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/sys-apps/i2c-tools/Manifest b/sys-apps/i2c-tools/Manifest
index 49521827a551..162e04697a5e 100644
--- a/sys-apps/i2c-tools/Manifest
+++ b/sys-apps/i2c-tools/Manifest
@@ -1,2 +1 @@
-DIST i2c-tools-3.0.2.tar.bz2 62523 SHA256 0b4d6455a30a3264a60b4d3be55855d996d52ea4f162a2f04ffff378e24f98a2 SHA512 7e21660c83328a1f60cb4aa3dcc15ed0c745a426582afb48b09dca86cba0aa8e879eec59f6a029b36932c338395c10a3a88856a712f1680eba88643e6fbacf04 WHIRLPOOL c550374e8dad9d0005da9d16b50b793782dba79963fb2dfc2ca953a61af51af9d91fce227fd7b889a8c36b15352d2da904a8a8c313ddb577b5a7e0b4dc4fcf71
DIST i2c-tools-3.1.1.tar.bz2 71789 SHA256 14d4d7d60d1c12e43f2befe239c682a5c44c27682f153d4b58c1e392d2db1700 SHA512 b91f89b803e5558d49ce63f42f6542438f4f47927e4ce420cd9df989cab14a5c55d971befed73e8f793b0cf4aa41936c0ef519e5a407dceb2c08964461e803c5 WHIRLPOOL 5d68236a7c6e5075625420d1e9cb0a075e8e064babbb73163a2bf2a5cf2b0b169e1420ab1ef495533c88f53497767f6256b817c49b5d9f1799f3bde6d7e26b24
diff --git a/sys-apps/i2c-tools/i2c-tools-3.0.2.ebuild b/sys-apps/i2c-tools/i2c-tools-3.0.2.ebuild
deleted file mode 100644
index 491419c74ddc..000000000000
--- a/sys-apps/i2c-tools/i2c-tools-3.0.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit flag-o-matic toolchain-funcs distutils
-
-DESCRIPTION="I2C tools for bus probing, chip dumping, register-level access helpers, EEPROM decoding, and more"
-HOMEPAGE="http://www.lm-sensors.org/wiki/I2CTools"
-SRC_URI="http://dl.lm-sensors.org/i2c-tools/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~sparc x86"
-IUSE="python"
-
-DEPEND="!<sys-apps/lm_sensors-3"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- use python && python_pkg_setup
-}
-
-src_compile() {
- emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" || die
- if use python ; then
- cd py-smbus
- append-cppflags -I../include
- distutils_src_compile
- fi
-}
-
-src_install() {
- emake install prefix="${D}"/usr || die
- rm -rf "${D}"/usr/include # part of linux-headers
- dodoc CHANGES README
- local d
- for d in eeprom eepromer ; do
- docinto ${d}
- dodoc ${d}/README*
- done
-
- if use python ; then
- cd py-smbus
- docinto py-smbus
- dodoc README*
- distutils_src_install
- fi
-}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}