summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/slrn/Manifest1
-rw-r--r--net-nntp/slrn/files/slrn-1.0.3-make.patch36
-rw-r--r--net-nntp/slrn/slrn-1.0.3.ebuild39
3 files changed, 76 insertions, 0 deletions
diff --git a/net-nntp/slrn/Manifest b/net-nntp/slrn/Manifest
index 909c1822ec3c..e2f5112a5f12 100644
--- a/net-nntp/slrn/Manifest
+++ b/net-nntp/slrn/Manifest
@@ -1 +1,2 @@
DIST slrn-1.0.2.tar.bz2 995433 BLAKE2B e2812826252918547d5cfb810233b8e0d19bb7df44577cb118ff51064648579f90132c88b5872400cac70cca5b91731d1ede39c4e0521d75d989a5d4417d78c6 SHA512 264dce88622e544356782c483f3639252ba57408d79775b2cd3ea06962ea3ebc568bc45ed19f1690c66b5b71d82eadeebd62a0bad656b1339ab7b80eb3f3cc5f
+DIST slrn-1.0.3a.tar.bz2 997138 BLAKE2B a349783edae24e0269ab1b8ddc328e578340e40e72285bbf070237b3724f475450f08bbc655d3b212684b8fffc495129008bde71a481fb3d2f4326bf396e5981 SHA512 11cef2dfe41f441af15acc22fb675cf607e932f0dd6d4a998e51ecda05c9a50d7abf10a3e693ffc857ad77e09634f460404e4d5b289169e7bbffdaf5d6d565a3
diff --git a/net-nntp/slrn/files/slrn-1.0.3-make.patch b/net-nntp/slrn/files/slrn-1.0.3-make.patch
new file mode 100644
index 000000000000..e03fbb472c36
--- /dev/null
+++ b/net-nntp/slrn/files/slrn-1.0.3-make.patch
@@ -0,0 +1,36 @@
+--- slrn-1.0.2/src/Makefile.in
++++ slrn-1.0.2/src/Makefile.in
+@@ -153,7 +153,7 @@
+ $(MKINSDIR) $(DEST_SLRN_LIB_DIR)
+ $(MKINSDIR) $(DEST_SLRN_SLANG_DIR)
+ # $(MKINSDIR) $(DEST_CONFDIR)
+-installdocs:
++installdocs: installdirs
+ @for i in $(MAN_FILES); \
+ do \
+ echo $(INSTALL_DATA) $$i $(DEST_MANDIR)/man1/; \
+@@ -186,7 +186,7 @@
+ exit 1; \
+ fi; \
+ done
+-installslang:
++installslang: installdirs
+ @files=$(CONF_FILES); \
+ for i in $$files; \
+ do \
+@@ -204,11 +204,11 @@
+ exit 1; \
+ fi; \
+ done
+-installlocales:
++installlocales: installdirs
+ -cd ../po; $(MAKE) DESTDIR=$(DESTDIR) LOCALEDIR=$(LOCALEDIR) install
+-installbin:
+- $(INSTALL) -m 755 -s $(OBJDIR)/slrn $(DEST_BINDIR)
+- -$(INSTALL) -m 755 -s $(OBJDIR)/slrnpull $(DEST_BINDIR)
++installbin: installdirs
++ $(INSTALL) -m 755 $(OBJDIR)/slrn $(DEST_BINDIR)
++ -$(INSTALL) -m 755 $(OBJDIR)/slrnpull $(DEST_BINDIR)
+ install: all installdirs installbin installdocs installslang installlocales
+
+ # The symlinks target is for my own private use. It simply creates the object
diff --git a/net-nntp/slrn/slrn-1.0.3.ebuild b/net-nntp/slrn/slrn-1.0.3.ebuild
new file mode 100644
index 000000000000..6ea1761884d4
--- /dev/null
+++ b/net-nntp/slrn/slrn-1.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P}a"
+
+DESCRIPTION="A s-lang based newsreader"
+HOMEPAGE="http://slrn.sourceforge.net/"
+SRC_URI="http://jedsoft.org/releases/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="canlock libressl nls ssl uudeview"
+
+RDEPEND="app-arch/sharutils
+ >=sys-libs/slang-2.2.3
+ virtual/mta
+ canlock? ( net-libs/canlock )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ uudeview? ( dev-libs/uulib )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${P}-make.patch )
+
+src_configure() {
+ econf \
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --with-slrnpull \
+ $(use_with canlock) \
+ $(use_enable nls) \
+ $(use_with ssl) \
+ $(use_with uudeview uu)
+}