summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/scanssh/scanssh-2.1.ebuild')
-rw-r--r--net-analyzer/scanssh/scanssh-2.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/scanssh/scanssh-2.1.ebuild b/net-analyzer/scanssh/scanssh-2.1.ebuild
new file mode 100644
index 000000000000..09086e75c906
--- /dev/null
+++ b/net-analyzer/scanssh/scanssh-2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="network scanner that gathers info on SSH protocols and versions"
+HOMEPAGE="http://monkey.org/~provos/scanssh/"
+SRC_URI="http://monkey.org/~provos/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ~ppc64 sparc x86"
+
+DEPEND="
+ dev-libs/libdnet
+ dev-libs/libevent
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0-fix-warnings.diff
+ touch configure
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin scanssh
+ doman scanssh.1
+}