summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/depthimage_to_laserscan')
-rw-r--r--dev-ros/depthimage_to_laserscan/Manifest1
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild28
-rw-r--r--dev-ros/depthimage_to_laserscan/files/pluginlib.patch11
3 files changed, 0 insertions, 40 deletions
diff --git a/dev-ros/depthimage_to_laserscan/Manifest b/dev-ros/depthimage_to_laserscan/Manifest
index 07324772c72f..47a860a3877e 100644
--- a/dev-ros/depthimage_to_laserscan/Manifest
+++ b/dev-ros/depthimage_to_laserscan/Manifest
@@ -1,2 +1 @@
-DIST depthimage_to_laserscan-1.0.7.tar.gz 12121 BLAKE2B f8b69ce10311e39eaf963c42fd6ea653c8b0fe1c2381ab128d575d490d236b03d8667a213e8e9eb9423c4a9244697fb9746ebe8385ac0142776e47063fe9e5bf SHA512 4da5fa446d574dbb44c2924dd760f160e527e68d7df119e5d9e74d85efd3473ee31845e8565b0d023d2cf22c945b3b5c56b12a04facd4e38dc3dd1235dad73e9
DIST depthimage_to_laserscan-1.0.8.tar.gz 12189 BLAKE2B 78668e8768bf9f402b5d94af71045677ce35b9b680c1b298f48a8a0c55f3920880eef24d0ab334150b967fd1378b9e4ada8069965057238e59116adb2f803d32 SHA512 50472016630d10b5a8544c7a2391c215de307dc5b0d8445cdc05d8e2f251651221bf18b18e389d000adacf79324569bb6ad7a23c6c6cce901d5ae1c966b4533d
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
deleted file mode 100644
index 2e621e904b7b..000000000000
--- a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
-KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin
-
-DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/roscpp
- media-libs/opencv:=
- dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
- dev-ros/image_geometry
- dev-ros/image_transport
- dev-ros/nodelet
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-libs/boost:=
- dev-libs/console_bridge:=
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/isnan.patch" "${FILESDIR}/pluginlib.patch" )
diff --git a/dev-ros/depthimage_to_laserscan/files/pluginlib.patch b/dev-ros/depthimage_to_laserscan/files/pluginlib.patch
deleted file mode 100644
index a367cd40c5f6..000000000000
--- a/dev-ros/depthimage_to_laserscan/files/pluginlib.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-Index: depthimage_to_laserscan-1.0.7/src/DepthImageToLaserScanNodelet.cpp
-===================================================================
---- depthimage_to_laserscan-1.0.7.orig/src/DepthImageToLaserScanNodelet.cpp
-+++ depthimage_to_laserscan-1.0.7/src/DepthImageToLaserScanNodelet.cpp
-@@ -57,5 +57,5 @@ private:
- }
-
- #include <pluginlib/class_list_macros.h>
--PLUGINLIB_DECLARE_CLASS(depthimage_to_laserscan, DepthImageToLaserScanNodelet, depthimage_to_laserscan::DepthImageToLaserScanNodelet, nodelet::Nodelet);
-+PLUGINLIB_EXPORT_CLASS(depthimage_to_laserscan::DepthImageToLaserScanNodelet, nodelet::Nodelet)
-