summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-slip')
-rw-r--r--dev-python/python-slip/python-slip-0.6.5.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/python-slip/python-slip-0.6.5.ebuild b/dev-python/python-slip/python-slip-0.6.5.ebuild
deleted file mode 100644
index 5c28912e855e..000000000000
--- a/dev-python/python-slip/python-slip-0.6.5.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_REQ_USE="xml"
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Miscellaneous convenience, extension and workaround code for Python"
-HOMEPAGE="https://github.com/nphilipp/python-slip"
-SRC_URI="https://github.com/nphilipp/${PN}/releases/download/${P}/${P}.tar.bz2"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
-IUSE="dbus selinux"
-
-RDEPEND="
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- sys-auth/polkit )
-"
-DEPEND=""
-
-python_prepare_all() {
- use selinux || epatch "${FILESDIR}"/${PN}-0.6.5-no-selinux.patch
-
- # hard-disable slip.gtk since it did not get ported to gtk3+ and the only user
- # of slip (firewalld) does not use it (upstream disables it for py3 already)
- sed \
- -e 's|sys.version_info.major == 2|False|' \
- -e "s:@VERSION@:${PV}:" setup.py.in > setup.py || die "sed failed"
-
- if ! use dbus; then
- sed -e '/name="slip.dbus"/ s/\(.*\)/if 0:\n \1/' \
- -i setup.py || die "sed 2 failed"
- fi
-
- distutils-r1_python_prepare_all
-}