summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-toolbox')
-rw-r--r--dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild21
1 files changed, 18 insertions, 3 deletions
diff --git a/dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild b/dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild
index ce2e4fb6ecb3..d7caff404050 100644
--- a/dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild
+++ b/dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild
@@ -4,12 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Numerous useful plugins for pytest"
-HOMEPAGE="https://pypi.org/project/pytest-toolbox/ https://github.com/samuelcolvin/pytest-toolbox/"
+HOMEPAGE="
+ https://github.com/samuelcolvin/pytest-toolbox/
+ https://pypi.org/project/pytest-toolbox/
+"
SRC_URI="
https://github.com/samuelcolvin/pytest-toolbox/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
@@ -21,7 +24,10 @@ KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x
BDEPEND="
test? (
- dev-python/pydantic[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ ' pypy3 python3_{8..10} # TODO: python3_11
+ )
)
"
@@ -31,3 +37,12 @@ src_prepare() {
sed -e '/addopts/d' -i setup.cfg || die
distutils-r1_src_prepare
}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/pydantic[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_comparison.py::test_close_to_now_{false,true}
+ )
+ fi
+}