summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-3.10.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index d7da619fbded..29cc03477a43 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,2 +1,3 @@
DIST cliff-3.10.0.tar.gz 82636 BLAKE2B bb0031a96cca3bd6f7c806c394133ca81e0fad56c65361c3643a32d96d4136228972af2b1567489b4cbb669f9008f0b1dd9eecede73b294097ab3a781ea64443 SHA512 52064ca1144cbf5e76b3654924e00a6e12c70707a3d4f7cd9c0bcee514a29c47626152cfb558d46837a967f5e0f827a2af291b4532e383fc7fc3abb616b01803
+DIST cliff-3.10.1.tar.gz 82764 BLAKE2B 88e8481d23f6ad35acac9fd17b1e4930f31ebc13211ad5bf1db441dbe4ad99faec023b6a46640d0fa3dbac4d76f4fd9d9fd3cd1e6c319cab390d502c9adff53c SHA512 2a1eb1f5311eb92ac481b35e0f703bb37171c9c7eee68a3d8322786a802d562d990ea8e3e52e924215b2ff8c3f14614f99ea403d94bfa2ea3794ab3556baa0c9
DIST cliff-3.8.0.tar.gz 81862 BLAKE2B 3a8219f822fdf14e1de56204b0f536a92d27be5a99fb628f3aed5b569a1e703d4711bdded28fa42c0692316454847ba3338baac8efae873540652e46d155227a SHA512 002e3ddfb254c5369582cc28572856a8b4ad05d598a7f8aa690add69f49cabb12ef2ef17b6c1553792aaee785b7c1703b05dd9d4889271cd5eba5629fad3d09b
diff --git a/dev-python/cliff/cliff-3.10.1.ebuild b/dev-python/cliff/cliff-3.10.1.ebuild
new file mode 100644
index 000000000000..2a06faab3f16
--- /dev/null
+++ b/dev-python/cliff/cliff-3.10.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/openstack/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest