summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/lablgl')
-rw-r--r--dev-ml/lablgl/Manifest2
-rw-r--r--dev-ml/lablgl/lablgl-1.04-r1.ebuild93
-rw-r--r--dev-ml/lablgl/lablgl-1.05.ebuild95
-rw-r--r--dev-ml/lablgl/metadata.xml5
4 files changed, 195 insertions, 0 deletions
diff --git a/dev-ml/lablgl/Manifest b/dev-ml/lablgl/Manifest
new file mode 100644
index 000000000000..be08e81d0afe
--- /dev/null
+++ b/dev-ml/lablgl/Manifest
@@ -0,0 +1,2 @@
+DIST lablgl-1.04.tar.gz 410525 SHA256 3fedf5537069481b95836e8495380c742af7b87cfecd105fff1b98e40cac3b3e SHA512 6ae9ed365c390e06bba45214e62ad1479f96cec8087672d543fb18bd20643be0adf52c53e3b19031976eb833880be1f30c3c705d87dea5f7ed4488b57781e084 WHIRLPOOL efb03beeb18277d374c7fbbdf32aa2be4d7f2e23c31322de2b2e37d6b636e44bb4432bdca08c401af326abc4f729c21df2551e63a90193a5bbea95d7018d05d0
+DIST lablgl-1.05.tar.gz 296597 SHA256 d8ff03e35b970d2b23a942f9e6ed65da5a6c123986bd0ecf5424a6205af34b61 SHA512 e8bf7d993610912d50ec3a6c18a24d2ff7d0727a41fe102e745050bb83ee02a9995e8b1b8c7dbd94f6b2a8363145f22e9772e36253dced762a63ec3c6c54379d WHIRLPOOL 74e9b15b2085d82c90f73cdf1d5330ced5cdc484d9775fe83c1cfdae6784e113d21ef53bdbb88ea02615bda0cc824f730fc0772dba3b486b2298c8dedcd9476f
diff --git a/dev-ml/lablgl/lablgl-1.04-r1.ebuild b/dev-ml/lablgl/lablgl-1.04-r1.ebuild
new file mode 100644
index 000000000000..ffab37249a0c
--- /dev/null
+++ b/dev-ml/lablgl/lablgl-1.04-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib eutils toolchain-funcs
+
+IUSE="doc glut +ocamlopt"
+#tk"
+
+DESCRIPTION="Objective CAML interface for OpenGL"
+HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgl.html"
+LICENSE="BSD"
+
+# >=dev-lang/ocaml-3.10.2:=[tk?,ocamlopt?]
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libX11
+ virtual/opengl
+ virtual/glu
+ glut? ( media-libs/freeglut )
+ "
+# tk? ( >=dev-lang/tcl-8.3:0= >=dev-lang/tk-8.3:0= )
+
+DEPEND="${RDEPEND}"
+
+SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/${P}.tar.gz"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86 ~x86-fbsd"
+S=${WORKDIR}/lablGL-${PV}
+
+src_configure() {
+ # make configuration file
+ echo "BINDIR=/usr/bin" > Makefile.config
+ echo "GLLIBS = -lGL -lGLU" >> Makefile.config
+ if use glut; then
+ echo "GLUTLIBS = -lglut" >> Makefile.config
+ else
+ echo "GLUTLIBS = " >> Makefile.config
+ fi
+ echo "XLIBS = -lXext -lXmu -lX11" >> Makefile.config
+ echo "RANLIB = $(tc-getRANLIB)" >> Makefile.config
+ echo 'COPTS = -c -O $(CFLAGS)' >> Makefile.config
+ echo 'INCLUDES = $(TKINCLUDES) $(GLINCLUDES) $(XINCLUDES)' >> Makefile.config
+}
+
+src_compile() {
+ #if use tk; then
+ # emake -j1 togl || die "failed to build togl"
+ # if use ocamlopt; then
+ # emake -j1 toglopt || die "failed to build native code togl"
+ # fi
+ #fi
+
+ emake -j1 lib || die "failed to build the library"
+ if use ocamlopt; then
+ emake -j1 libopt || die "failed to build native code library"
+ fi
+
+ if use glut; then
+ emake -j1 glut || die "failed to build glut"
+ if use ocamlopt; then
+ emake -j1 glutopt || die "failed to build native code glutopt"
+ fi
+ fi
+}
+
+src_install () {
+ # Makefile do not use mkdir so the library is not installed
+ # but copied as a 'stublibs' file.
+ dodir /usr/$(get_libdir)/ocaml/stublibs
+
+ # Same for lablglut's toplevel
+ dodir /usr/bin
+
+ BINDIR=${ED}/usr/bin
+ BASE=${ED}/usr/$(get_libdir)/ocaml
+ emake BINDIR="${BINDIR}" INSTALLDIR="${BASE}/lablGL" DLLDIR="${BASE}/stublibs" install || die "make install failed"
+
+ dodoc README CHANGES
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ mv Togl/examples{,.togl}
+ doins -r Togl/examples.togl
+
+ mv LablGlut/examples{,.glut}
+ doins -r LablGlut/examples.glut
+ fi
+}
diff --git a/dev-ml/lablgl/lablgl-1.05.ebuild b/dev-ml/lablgl/lablgl-1.05.ebuild
new file mode 100644
index 000000000000..bb69c5d38aef
--- /dev/null
+++ b/dev-ml/lablgl/lablgl-1.05.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib eutils toolchain-funcs
+
+IUSE="doc glut +ocamlopt tk"
+
+DESCRIPTION="Objective CAML interface for OpenGL"
+HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgl.html"
+LICENSE="BSD"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libX11
+ virtual/opengl
+ virtual/glu
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+ glut? ( media-libs/freeglut )
+ tk? (
+ >=dev-lang/tcl-8.3:0=
+ >=dev-lang/tk-8.3:0=
+ || ( dev-ml/labltk:= <dev-lang/ocaml-4.02[tk] )
+ )
+ "
+
+DEPEND="${RDEPEND}"
+
+SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/${P}.tar.gz"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+src_configure() {
+ # make configuration file
+ echo "BINDIR=/usr/bin" > Makefile.config
+ echo "GLLIBS = -lGL -lGLU" >> Makefile.config
+ if use glut; then
+ echo "GLUTLIBS = -lglut" >> Makefile.config
+ else
+ echo "GLUTLIBS = " >> Makefile.config
+ fi
+ echo "XLIBS = -lXext -lXmu -lX11" >> Makefile.config
+ echo "RANLIB = $(tc-getRANLIB)" >> Makefile.config
+ echo 'COPTS = -c -O $(CFLAGS)' >> Makefile.config
+ echo 'INCLUDES = $(TKINCLUDES) $(GLINCLUDES) $(XINCLUDES)' >> Makefile.config
+}
+
+src_compile() {
+ if use tk; then
+ emake togl
+ if use ocamlopt; then
+ emake toglopt
+ fi
+ fi
+
+ emake lib
+ if use ocamlopt; then
+ emake libopt
+ fi
+
+ if use glut; then
+ emake glut
+ if use ocamlopt; then
+ emake glutopt
+ fi
+ fi
+}
+
+src_install () {
+ # Makefile do not use mkdir so the library is not installed
+ # but copied as a 'stublibs' file.
+ dodir /usr/$(get_libdir)/ocaml/stublibs
+
+ # Same for lablglut's toplevel
+ dodir /usr/bin
+
+ BINDIR=${ED}/usr/bin
+ BASE=${ED}/usr/$(get_libdir)/ocaml
+ emake BINDIR="${BINDIR}" INSTALLDIR="${BASE}/lablGL" DLLDIR="${BASE}/stublibs" install
+
+ dodoc README CHANGES
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ mv Togl/examples{,.togl}
+ doins -r Togl/examples.togl
+
+ mv LablGlut/examples{,.glut}
+ doins -r LablGlut/examples.glut
+ fi
+}
diff --git a/dev-ml/lablgl/metadata.xml b/dev-ml/lablgl/metadata.xml
new file mode 100644
index 000000000000..849ed8ebf13d
--- /dev/null
+++ b/dev-ml/lablgl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+</pkgmetadata>