summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rakudo/rakudo-2015.06.ebuild')
-rw-r--r--dev-lang/rakudo/rakudo-2015.06.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-lang/rakudo/rakudo-2015.06.ebuild b/dev-lang/rakudo/rakudo-2015.06.ebuild
deleted file mode 100644
index 744a9057d317..000000000000
--- a/dev-lang/rakudo/rakudo-2015.06.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils multilib
-
-DESCRIPTION="A Perl 6 implementation built on the Parrot virtual machine"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://rakudo.org/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc java +moar"
-
-RDEPEND=">=dev-lang/nqp-${PV}[java?,moar?]"
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-src_configure() {
- use java && myconf+="jvm,"
- use moar && myconf+="moar,"
- perl Configure.pl --backends=${myconf} --prefix=/usr || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.md docs/ChangeLog docs/ROADMAP || die
-
- if use doc; then
- dohtml -A svg docs/architecture.html docs/architecture.svg || die
- dodoc docs/*.pod || die
- docinto announce
- dodoc docs/announce/* || die
- fi
-}