summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/cglib')
-rw-r--r--dev-java/cglib/Manifest2
-rw-r--r--dev-java/cglib/cglib-3.0.ebuild51
-rw-r--r--dev-java/cglib/cglib-3.1.ebuild59
-rw-r--r--dev-java/cglib/files/cglib-2.0.2-asm-1.4.3.patch12
-rw-r--r--dev-java/cglib/files/cglib-2.2-build.patch47
-rw-r--r--dev-java/cglib/files/cglib-2.2-no-leak-test.patch11
-rw-r--r--dev-java/cglib/files/cglib-2.2.3-build.patch44
-rw-r--r--dev-java/cglib/files/cglib-3.0-build.xml.patch36
-rw-r--r--dev-java/cglib/files/cglib-3.1-build.xml.patch36
-rw-r--r--dev-java/cglib/files/words.txt50
-rw-r--r--dev-java/cglib/metadata.xml14
11 files changed, 362 insertions, 0 deletions
diff --git a/dev-java/cglib/Manifest b/dev-java/cglib/Manifest
new file mode 100644
index 000000000000..fa4a7fb9dd4d
--- /dev/null
+++ b/dev-java/cglib/Manifest
@@ -0,0 +1,2 @@
+DIST cglib-src-3.0.jar 1537863 SHA256 40f8cc721f80b820207f0061b10ad51151f577b2d7d94d93f19a85aa2551e674 SHA512 7791c36ed1908ddbc35a0bf1f4f54c3554b0fe4f707b318d7d24189fb513d8712335f2e41f90065e8eb102657d53699cc709a1b9f7a12a8f924c6a755969a829 WHIRLPOOL d9e4f80e7cbe1bc39aad654e437347551e13c66bcc3139f8991e870c123bdd83603a26b9d5a07a902c2fa668ba7cb42285417578b836e195f5660b691c6ddc79
+DIST cglib-src-3.1.jar 1541525 SHA256 386f9a55ae8fed3cf8014f2c20344ce9ce05cd2e4fa467e5e4d8027abb3d62eb SHA512 3b246b37f1c90acaefd4ba64f1f1db0b4d1fa64025f0e4e216ae7955e05701671bf8dc01d19c754286966cc5f8c06d78d02cb4f4500542f4448656768109c13f WHIRLPOOL e3a865296790e1de31889e7624797418392466f7756567382fa9c0b1108d386ee848be2e6b4e96db206101cde8d0320293e58d0b83e0a5a7633afc46b3a37e22
diff --git a/dev-java/cglib/cglib-3.0.ebuild b/dev-java/cglib/cglib-3.0.ebuild
new file mode 100644
index 000000000000..09b8dfa07466
--- /dev/null
+++ b/dev-java/cglib/cglib-3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="cglib is a powerful, high performance and quality Code Generation Library"
+HOMEPAGE="http://cglib.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.jar"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+# Fails some tests on ppc(64) due to memory-related issues that are
+# probably VM-specific but harmless enough.
+RESTRICT="ppc? ( test ) ppc64? ( test )"
+
+COMMON_DEP="dev-java/asm:4
+ dev-java/ant-core:0"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.6
+ test? ( dev-java/junit:4 )
+ ${COMMON_DEP}"
+
+S="${WORKDIR}"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_GENTOO_CLASSPATH="asm-4 ant-core"
+
+java_prepare() {
+ find . -iname '*.jar' -delete || die
+ epatch "${FILESDIR}"/${P}-build.xml.patch
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc src/proxy/net
+ use examples && java-pkg_doexamples --subdir samples src/proxy/samples
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
diff --git a/dev-java/cglib/cglib-3.1.ebuild b/dev-java/cglib/cglib-3.1.ebuild
new file mode 100644
index 000000000000..7318c56cf756
--- /dev/null
+++ b/dev-java/cglib/cglib-3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="cglib is a powerful, high performance and quality Code Generation Library"
+HOMEPAGE="https://github.com/cglib/cglib"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.jar"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64"
+
+IUSE=""
+
+COMMON_DEP="dev-java/asm:4
+ dev-java/ant-core:0"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.6
+ test? ( dev-java/junit:4 )
+ ${COMMON_DEP}"
+
+S="${WORKDIR}"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_GENTOO_CLASSPATH="asm-4 ant-core"
+
+java_prepare() {
+ find . -iname '*.jar' -delete || die
+
+ # Get rid of some parts in XML.
+ epatch "${FILESDIR}"/${P}-build.xml.patch
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+
+ if use doc; then
+ java-pkg_dojavadoc docs
+ fi
+
+ if use source; then
+ java-pkg_dosrc src/proxy/net
+ fi
+
+ if use examples; then
+ java-pkg_doexamples --subdir samples src/proxy/samples
+ fi
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
diff --git a/dev-java/cglib/files/cglib-2.0.2-asm-1.4.3.patch b/dev-java/cglib/files/cglib-2.0.2-asm-1.4.3.patch
new file mode 100644
index 000000000000..f9d47e914d3e
--- /dev/null
+++ b/dev-java/cglib/files/cglib-2.0.2-asm-1.4.3.patch
@@ -0,0 +1,12 @@
+diff -uprN src.orig/test/net/sf/cglib/reflect/TestFastClass.java src/test/net/sf/cglib/reflect/TestFastClass.java
+--- src.orig/test/net/sf/cglib/reflect/TestFastClass.java 2005-01-05 19:33:15.945618576 +0100
++++ src/test/net/sf/cglib/reflect/TestFastClass.java 2005-01-05 19:34:21.957583232 +0100
+@@ -26,7 +26,7 @@ import net.sf.cglib.core.DefaultGenerato
+ import net.sf.cglib.transform.ClassTransformerTee;
+ import net.sf.cglib.transform.NullClassVisitor;
+ import net.sf.cglib.transform.TransformingClassGenerator;
+-import org.objectweb.asm.util.DumpClassVisitor;
++import org.objectweb.asm.util.ASMifierClassVisitor;
+
+ public class TestFastClass extends net.sf.cglib.CodeGenTestCase {
+ public static class Simple {
diff --git a/dev-java/cglib/files/cglib-2.2-build.patch b/dev-java/cglib/files/cglib-2.2-build.patch
new file mode 100644
index 000000000000..c1c572dd0c74
--- /dev/null
+++ b/dev-java/cglib/files/cglib-2.2-build.patch
@@ -0,0 +1,47 @@
+--- build.xml.orig 2009-09-02 16:27:55.000000000 +0200
++++ build.xml 2009-09-03 17:24:23.000000000 +0200
+@@ -73,7 +73,7 @@
+ <target depends="prepare" description="Compile shareable components"
+ name="compile">
+ <javac debug="${compile.debug}" deprecation="${compile.deprecation}" destdir="${build.home}/classes" optimize="${compile.optimize}" srcdir="${source.home}"
+- target="${compile.target}" bootclasspath="${compile.bootclasspath}" extdirs="${compile.extdirs}" source="${compile.source}">
++ target="${compile.target}" extdirs="${compile.extdirs}" source="${compile.source}">
+ <classpath refid="compile.classpath"/>
+ <compilerarg compiler="jikes" value="-nowarn"/>
+ </javac>
+@@ -122,16 +122,7 @@
+ <jar basedir="${build.home}/classes" jarfile="${dist.home}/${component.name}-${component.version}.jar" >
+ <include name="**/*"/>
+ <exclude name="samples/**" />
+- </jar>
+-
+- <taskdef name="jarjar" classname="com.tonicsystems.jarjar.JarJarTask" classpathref="compile.classpath"/>
+- <jarjar basedir="${build.home}/classes" jarfile="${dist.home}/${component.name}-nodep-${component.version}.jar" >
+- <zipfileset dir="lib" includes="asm*.txt"/>
+- <zipfileset src="lib/asm-3.1.jar" excludes="META-INF"/>
+- <rule pattern="org.objectweb.asm.**" result="net.sf.cglib.asm.@1"/>
+- <include name="**/*"/>
+- <exclude name="samples/**"/>
+- </jarjar>
++ </jar>
+ </target>
+
+ <target depends="compile,javadoc" description="Create docs and source distribution" name="srcjar">
+@@ -239,16 +230,7 @@
+ failonerror="${test.failonerror}"
+ fork="yes"
+ >
+-
+- <!-- jvmarg value="-Xrunhprof:heap=all,file=debug.txt"/ -->
+- <!-- <jvmarg value="-verbose:gc"/> -->
+- <!-- <jvmarg value="-verbose:class"/> -->
+- <!-- <jvmarg value="-Xprof"/> -->
+- <!-- <jvmarg value="-server"/> -->
+- <!-- <sysproperty key="cglib.debugLocation" value="debug"/> -->
+- <!-- <jvmarg value="-Djava.security.policy==java.policy" /> -->
+- <!-- <jvmarg value="-Djava.security.manager" /> -->
+-
++ <sysproperty key="cglib.debugLocation" value="${debugLocation}"/>
+ <arg value="${test.entry}"/>
+ <classpath>
+ <pathelement path="${build.home}/classes"/>
diff --git a/dev-java/cglib/files/cglib-2.2-no-leak-test.patch b/dev-java/cglib/files/cglib-2.2-no-leak-test.patch
new file mode 100644
index 000000000000..416672a5498e
--- /dev/null
+++ b/dev-java/cglib/files/cglib-2.2-no-leak-test.patch
@@ -0,0 +1,11 @@
+--- src/test/net/sf/cglib/CodeGenTestCase.java.orig 2009-11-20 11:49:04.000000000 +0100
++++ src/test/net/sf/cglib/CodeGenTestCase.java 2009-11-20 11:49:18.000000000 +0100
+@@ -135,7 +135,7 @@
+
+ }
+
+- return true;
++ return false;
+
+
+ }
diff --git a/dev-java/cglib/files/cglib-2.2.3-build.patch b/dev-java/cglib/files/cglib-2.2.3-build.patch
new file mode 100644
index 000000000000..15aa07dfa987
--- /dev/null
+++ b/dev-java/cglib/files/cglib-2.2.3-build.patch
@@ -0,0 +1,44 @@
+--- cglib.2.2.3/build.xml
++++ cglib.2.2.3/build.xml
+@@ -73,7 +73,7 @@
+ <target depends="prepare" description="Compile shareable components"
+ name="compile">
+ <javac debug="${compile.debug}" deprecation="${compile.deprecation}" destdir="${build.home}/classes" optimize="${compile.optimize}" srcdir="${source.home}"
+- target="${compile.target}" bootclasspath="${compile.bootclasspath}" extdirs="${compile.extdirs}" source="${compile.source}">
++ target="${compile.target}" extdirs="${compile.extdirs}" source="${compile.source}">
+ <classpath refid="compile.classpath"/>
+ <compilerarg compiler="jikes" value="-nowarn"/>
+ </javac>
+@@ -123,15 +123,6 @@
+ <include name="**/*"/>
+ <exclude name="samples/**" />
+ </jar>
+-
+- <taskdef name="jarjar" classname="com.tonicsystems.jarjar.JarJarTask" classpathref="compile.classpath"/>
+- <jarjar basedir="${build.home}/classes" jarfile="${dist.home}/${component.name}-nodep-${component.version}.jar" >
+- <zipfileset dir="lib" includes="asm*.txt"/>
+- <zipfileset src="lib/asm-3.1.jar" excludes="META-INF"/>
+- <rule pattern="org.objectweb.asm.**" result="net.sf.cglib.asm.@1"/>
+- <include name="**/*"/>
+- <exclude name="samples/**"/>
+- </jarjar>
+ </target>
+
+ <target depends="compile,javadoc" description="Create docs and source distribution" name="srcjar">
+@@ -240,15 +231,7 @@
+ fork="yes"
+ >
+
+- <!-- jvmarg value="-Xrunhprof:heap=all,file=debug.txt"/ -->
+- <!-- <jvmarg value="-verbose:gc"/> -->
+- <!-- <jvmarg value="-verbose:class"/> -->
+- <!-- <jvmarg value="-Xprof"/> -->
+- <!-- <jvmarg value="-server"/> -->
+- <!-- <sysproperty key="cglib.debugLocation" value="debug"/> -->
+- <!-- <jvmarg value="-Djava.security.policy==java.policy" /> -->
+- <!-- <jvmarg value="-Djava.security.manager" /> -->
+-
++ <sysproperty key="cglib.debugLocation" value="${debugLocation}"/>
+ <arg value="${test.entry}"/>
+ <classpath>
+ <pathelement path="${build.home}/classes"/>
diff --git a/dev-java/cglib/files/cglib-3.0-build.xml.patch b/dev-java/cglib/files/cglib-3.0-build.xml.patch
new file mode 100644
index 000000000000..a40c169d8016
--- /dev/null
+++ b/dev-java/cglib/files/cglib-3.0-build.xml.patch
@@ -0,0 +1,36 @@
+diff -Nru /tmp/cglib-3.0.orig/build.xml ./build.xml
+--- /tmp/cglib-3.0.orig/build.xml 2012-08-17 19:21:37.387574672 +0300
++++ ./build.xml 2012-08-17 19:26:58.982564260 +0300
+@@ -73,7 +73,7 @@
+ <target depends="prepare" description="Compile shareable components"
+ name="compile">
+ <javac debug="${compile.debug}" deprecation="${compile.deprecation}" destdir="${build.home}/classes" optimize="${compile.optimize}" srcdir="${source.home}"
+- target="${compile.target}" bootclasspath="${compile.bootclasspath}" extdirs="${compile.extdirs}" source="${compile.source}">
++ target="${compile.target}" extdirs="${compile.extdirs}" source="${compile.source}">
+ <classpath refid="compile.classpath"/>
+ <compilerarg compiler="jikes" value="-nowarn"/>
+ </javac>
+@@ -124,14 +124,6 @@
+ <exclude name="samples/**" />
+ </jar>
+
+- <taskdef name="jarjar" classname="com.tonicsystems.jarjar.JarJarTask" classpathref="compile.classpath"/>
+- <jarjar basedir="${build.home}/classes" jarfile="${dist.home}/${component.name}-nodep-${component.version}.jar" >
+- <zipfileset dir="lib" includes="asm*.txt"/>
+- <zipfileset src="lib/asm-4.0.jar" excludes="META-INF"/>
+- <rule pattern="org.objectweb.asm.**" result="net.sf.cglib.asm.@1"/>
+- <include name="**/*"/>
+- <exclude name="samples/**"/>
+- </jarjar>
+ </target>
+
+ <target depends="compile,javadoc" description="Create docs and source distribution" name="srcjar">
+@@ -246,7 +238,7 @@
+ <!-- <jvmarg value="-verbose:class"/> -->
+ <!-- <jvmarg value="-Xprof"/> -->
+ <!-- <jvmarg value="-server"/> -->
+- <!-- <sysproperty key="cglib.debugLocation" value="debug"/> -->
++ <sysproperty key="cglib.debugLocation" value="${cglib.debugLocation}"/>
+ <!-- <jvmarg value="-Djava.security.policy==java.policy" /> -->
+ <!-- <jvmarg value="-Djava.security.manager" /> -->
+
diff --git a/dev-java/cglib/files/cglib-3.1-build.xml.patch b/dev-java/cglib/files/cglib-3.1-build.xml.patch
new file mode 100644
index 000000000000..0bf60be7b014
--- /dev/null
+++ b/dev-java/cglib/files/cglib-3.1-build.xml.patch
@@ -0,0 +1,36 @@
+--- build.xml.orig 2015-04-11 20:26:25.459688628 +0200
++++ build.xml 2015-04-11 20:28:41.930026892 +0200
+@@ -73,7 +73,7 @@
+ <target depends="prepare" description="Compile shareable components"
+ name="compile">
+ <javac debug="${compile.debug}" deprecation="${compile.deprecation}" destdir="${build.home}/classes" optimize="${compile.optimize}" srcdir="${source.home}"
+- target="${compile.target}" bootclasspath="${compile.bootclasspath}" extdirs="${compile.extdirs}" source="${compile.source}">
++ target="${compile.target}" extdirs="${compile.extdirs}" source="${compile.source}">
+ <classpath refid="compile.classpath"/>
+ <compilerarg compiler="jikes" value="-nowarn"/>
+ </javac>
+@@ -123,15 +123,6 @@
+ <include name="**/*"/>
+ <exclude name="samples/**" />
+ </jar>
+-
+- <taskdef name="jarjar" classname="com.tonicsystems.jarjar.JarJarTask" classpathref="compile.classpath"/>
+- <jarjar basedir="${build.home}/classes" jarfile="${dist.home}/${component.name}-nodep-${component.version}.jar" >
+- <zipfileset dir="lib" includes="asm*.txt"/>
+- <zipfileset src="lib/asm-4.2.jar" excludes="META-INF"/>
+- <rule pattern="org.objectweb.asm.**" result="net.sf.cglib.asm.@1"/>
+- <include name="**/*"/>
+- <exclude name="samples/**"/>
+- </jarjar>
+ </target>
+
+ <target depends="compile,javadoc" description="Create docs and source distribution" name="srcjar">
+@@ -246,7 +237,7 @@
+ <!-- <jvmarg value="-verbose:class"/> -->
+ <!-- <jvmarg value="-Xprof"/> -->
+ <!-- <jvmarg value="-server"/> -->
+- <!-- <sysproperty key="cglib.debugLocation" value="debug"/> -->
++ <sysproperty key="cglib.debugLocation" value="debug"/>
+ <!-- <jvmarg value="-Djava.security.policy==java.policy" /> -->
+ <!-- <jvmarg value="-Djava.security.manager" /> -->
+
diff --git a/dev-java/cglib/files/words.txt b/dev-java/cglib/files/words.txt
new file mode 100644
index 000000000000..263a4396d4ca
--- /dev/null
+++ b/dev-java/cglib/files/words.txt
@@ -0,0 +1,50 @@
+Casuarinaceae
+hylomorphic
+granitize
+biddably
+repulsive
+amphimictical
+trio
+toxodont
+nonreigning
+dragbar
+Moronidae
+unlanguishing
+metabolizable
+Osmerus
+goran
+spiritfulness
+tetrachloromethane
+baobab
+caroline
+radioconductor
+imband
+crinoline
+circummundane
+incontractile
+forerank
+modernization
+meal
+fishman
+underbuy
+pertain
+equiped
+cockal
+unshrined
+Harb
+heterotaxis
+commensurableness
+baggy
+sarcophilous
+tankard
+acervuline
+unverifiably
+premidnight
+strangles
+vitellus
+Socratean
+flock
+scourage
+feverlike
+citharist
+harn
diff --git a/dev-java/cglib/metadata.xml b/dev-java/cglib/metadata.xml
new file mode 100644
index 000000000000..80d7a322ef6b
--- /dev/null
+++ b/dev-java/cglib/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ cglib is a powerful, high performance and quality Code Generation
+ Library, It is used to extend JAVA classes and implements interfaces
+ at runtime.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">cglib/cglib</remote-id>
+ <remote-id type="sourceforge">cglib</remote-id>
+ </upstream>
+</pkgmetadata>