summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/xml-conduit')
-rw-r--r--dev-haskell/xml-conduit/Manifest1
-rw-r--r--dev-haskell/xml-conduit/xml-conduit-1.9.0.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/xml-conduit/Manifest b/dev-haskell/xml-conduit/Manifest
index aecaef43db50..98ff2af95f20 100644
--- a/dev-haskell/xml-conduit/Manifest
+++ b/dev-haskell/xml-conduit/Manifest
@@ -3,3 +3,4 @@ DIST xml-conduit-1.2.3.3.tar.gz 31240 BLAKE2B a5ae1399be53d483a38ffe7570bd422a3e
DIST xml-conduit-1.3.1.tar.gz 33304 BLAKE2B 3ee7e88de9ffc583dfb801e318304f17dbf79b0eb3c06d38fad748c8c8508aa05187f007b2aac1885fcab9211fdc1eed03518d50c1f5024beb453f4bb7478be4 SHA512 939a891304647a8643bbf186269edb3a59930bf825dfa9e5f96382259ecc1c0787fbeb826ba0e5ec2105b263c8a639fc6079e8e3918b271f0e6ab9640133d1a5
DIST xml-conduit-1.3.3.tar.gz 33965 BLAKE2B e6bea7a2b7cec94758ffe6d624eae81eef1bcff7de6732f30a3c367367614a474768ac792f7aee5347358af0c86da6d9651257c0ce4696f49f39fd7bf6d2449d SHA512 1be43bafbdd3e0b0ca778741a42d81e95ee4f02f38dd61b06fd371f1314ff809223d0a6a269124191df8887ab82a85ff280d3a95d82c37038b04e86da12ee2b2
DIST xml-conduit-1.3.4.2.tar.gz 34828 BLAKE2B 24514ea18adb396e66792631fb58949fa94a90980e0ab712e17175ee33152a2f68ac7b462cf92d1eeb5eac8b80ce4e7963d0dfe996fbcac4d1f64a0e908b3f90 SHA512 c4b505189edc39f80c1ae842516c2a2ca15f486465fab94864259b094f9f23dc1dfcab73f1754096fd323f0ab0bcd9a87f801d775295c99e208e9c7fa688b65a
+DIST xml-conduit-1.9.0.0.tar.gz 40139 BLAKE2B b82fc11cc1ff1e63dc8638eb5da3506cf2ca755d94aa98fa0c5db16d17c676396e1d3e747037ba846e959b9883465d090bdb036809cb542453980c52ecb4ada9 SHA512 a6348233d99db2987289448c7320820abb9ed897b389d0a275e92c4a1e8055e9fa60a422b306f2bb1289b85f83545effe00d07c9ca1ecc7f2893d74b812cca23
diff --git a/dev-haskell/xml-conduit/xml-conduit-1.9.0.0.ebuild b/dev-haskell/xml-conduit/xml-conduit-1.9.0.0.ebuild
new file mode 100644
index 000000000000..043022e12e7a
--- /dev/null
+++ b/dev-haskell/xml-conduit/xml-conduit-1.9.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure-Haskell utilities for dealing with XML with the conduit package"
+HOMEPAGE="https://github.com/snoyberg/xml"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
+ >=dev-haskell/conduit-extra-1.3:=[profile?] <dev-haskell/conduit-extra-1.4:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/xml-types-0.3.4:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/doctest-0.8
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit )
+"