summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-chewing')
-rw-r--r--app-i18n/fcitx-chewing/Manifest1
-rw-r--r--app-i18n/fcitx-chewing/fcitx-chewing-5.1.6.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chewing/Manifest b/app-i18n/fcitx-chewing/Manifest
index 2c5750184098..ddc5dd742ca4 100644
--- a/app-i18n/fcitx-chewing/Manifest
+++ b/app-i18n/fcitx-chewing/Manifest
@@ -1,2 +1,3 @@
DIST fcitx-chewing-0.2.3.tar.xz 19804 BLAKE2B 0a83ae9a17eb74898e41471450a9054bb05e504a60d05bda91fa53f90cb4328b0db4bd5e1d662c81c9322268660e57a7f2cb9c547593913206a00394883341b1 SHA512 3492ad6ecaf00bb1ea07b76c9c23da075615597c1a68434a2da003cbe410d12172510d4306379777a1d04a359b017c49d278c002a7230b030693b668b6030bfd
DIST fcitx-chewing-5.1.1.tar.xz 23948 BLAKE2B 1894de696d735b469431c5fa0689c88948d34091f0a396b05a076cce4201cf605e00b45e864a65d9c40d42091842ca0efdf55bef2c66ebe65ed40367d7fd7f12 SHA512 48aeb1755c917fe931165f3f41cc175a22a76cf8a6d4be05e7eb6bbb0908225b2f6a99529943f773e7d0ed674dcdbf138e56e7b5962566a0f1219c3919039553
+DIST fcitx-chewing-5.1.6.tar.zst 34497 BLAKE2B 3d237f962bd2dbf8ea21afef7d41a11ffedf73b36b3198f02678019a6c5b04aecde46cf436f238911fa75b1c0111fb8f9eae8aebca8607d85558080dabcd15f3 SHA512 90468081948c217a44e69a8c9dd11ff07a1e09589b9ae9cf019ed7f6dba31af0ce5d4361b883fd3bae1dd03d090a4c60dc582caa9a80bfbcba260ea2178a64b2
diff --git a/app-i18n/fcitx-chewing/fcitx-chewing-5.1.6.ebuild b/app-i18n/fcitx-chewing/fcitx-chewing-5.1.6.ebuild
new file mode 100644
index 000000000000..e99975fd47da
--- /dev/null
+++ b/app-i18n/fcitx-chewing/fcitx-chewing-5.1.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-chewing"
+
+inherit cmake unpacker xdg
+
+DESCRIPTION="Chewing Wrapper for Fcitx."
+HOMEPAGE="https://github.com/fcitx/fcitx5-chewing"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.zst -> ${P}.tar.zst"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ !app-i18n/fcitx-chewing:4
+ >=app-i18n/fcitx-5.1.9:5
+ >=app-i18n/libchewing-0.5.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}-${PV}"