summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/burp')
-rw-r--r--app-backup/burp/Manifest1
-rw-r--r--app-backup/burp/burp-3.1.4.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index f9f24666294c..5a59f512d0dc 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -1,2 +1,3 @@
DIST burp-2.4.0.tar.gz 624032 BLAKE2B 4a1ff48236dc631dd6d545480a33af3cdf8020c3088f1ca09ab66ac5cec8128d262b9b991bf9e3229c80f75a4746d338073a0a43fdb67a2fe21a0fd4f243469d SHA512 ea81a12e54c6d88b702dd09dc4fa5a724d1e322bdfba2643c9312a9077c9edc63f6ca0f6cb3a6ebecb6ad9feb1cc26c114277b2308d9903f4abb0442a9be7c19
DIST burp-3.1.2.tar.gz 549260 BLAKE2B a8767d9ac2188e7a44fa2e8e4ba08dd3a5edeac268afcf196db5cae06e8bcc1faae1a48ba1873ef43fdbb9764946384233a755779e09984217b4334781529024 SHA512 a832502f617b66b87feeff032002bc25827809a165e3fb6ef85a9f3d847e308e9fa69f138b7e80662366fa3de09b39f7ef209b529d82c3d487dca11fe3ebcddf
+DIST burp-3.1.4.tar.gz 549879 BLAKE2B bf70051a658700fab60182b97b7ce8540fbd85ad1264ee09c9fa5b5a99046f391b91cd8673097ef869c6b762aea6d8fecdedb38425dca9e6bcbb1f2c2afa96fb SHA512 3aa9fb1512f985fa99e7cb9a45502bbdbf513935e0c62fa4327f0e6cb68d3840f59bfe1b38a7c2419b3e69bc04aef36c223313897c2e45e94f3be3f9d41714db
diff --git a/app-backup/burp/burp-3.1.4.ebuild b/app-backup/burp/burp-3.1.4.ebuild
new file mode 100644
index 000000000000..1efa9828e50c
--- /dev/null
+++ b/app-backup/burp/burp-3.1.4.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="https://burp.grke.org/"
+SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl test xattr"
+
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="acct-group/burp
+ acct-user/burp
+ dev-libs/uthash
+ dev-libs/openssl:0=
+ net-libs/librsync:=
+ sys-libs/ncurses:0=
+ sys-libs/libcap
+ sys-libs/zlib
+ virtual/libcrypt:=
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )"
+DEPEND="${COMMON_DEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )
+ test? ( dev-libs/check )"
+BDEPEND=">=sys-devel/autoconf-2.71
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ virtual/logger"
+
+PATCHES=(
+ "${FILESDIR}"/"${PN}"-2.1.20-no_mkdir_run.patch
+ "${FILESDIR}"/"${PN}"-2.0.54-server_user.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --sysconfdir=/etc/burp
+ --enable-largefile
+ --runstatedir=/run
+ "$(use_enable acl)"
+ "$(use_enable xattr)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # See https://github.com/grke/burp/issues/869
+ local -x CK_DEFAULT_TIMEOUT=10
+ default
+}
+
+src_install() {
+ default
+ keepdir /var/spool/burp
+ fowners -R root:"${PN}" /var/spool/burp
+ fperms 0770 /var/spool/burp
+
+ emake DESTDIR="${D}" install-configs
+ fowners -R root:"${PN}" /etc/burp
+ fperms 0750 /etc/burp
+ fperms 0640 /etc/burp/burp-server.conf
+ fperms 0750 /etc/burp/clientconfdir
+
+ newinitd "${FILESDIR}"/"${PN}".initd "${PN}"
+ systemd_dounit "${FILESDIR}"/"${PN}".service
+}
+
+pkg_postinst() {
+ elog "Burp ebuilds now support the autoupgrade mechanism in both"
+ elog "client and server mode. In both cases it is disabled by"
+ elog "default. You almost certainly do NOT want to enable it in"
+ elog "client mode because upgrades obtained this way will not be"
+ elog "managed by Portage."
+
+ if [[ ! -e "${EROOT}"/etc/burp/CA/index.txt ]]; then
+ elog ""
+ elog "At first run burp server will generate DH parameters and SSL"
+ elog "certificates. You should adjust configuration before."
+ elog "Server configuration is located at"
+ elog ""
+ elog " ${EROOT}/etc/burp/burp-server.conf"
+ elog ""
+ fi
+
+ # According to PMS this can be a space-separated list of version
+ # numbers, even though in practice it is typically just one.
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 "${oldver}") -lt 2 ]]; then
+ ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
+ ewarn "the server config file by default. If you use bedup, please"
+ ewarn "update your scripts to invoke it as"
+ ewarn ""
+ ewarn " bedup -c ${EROOT}/etc/burp/burp-server.conf"
+ ewarn ""
+ ewarn "Otherwise deduplication will not work!"
+ break
+ fi
+ done
+}