summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/netcdf/netcdf-4.7.4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-libs/netcdf/netcdf-4.7.4.ebuild b/sci-libs/netcdf/netcdf-4.7.4.ebuild
index a537ce445a22..793ea43ad586 100644
--- a/sci-libs/netcdf/netcdf-4.7.4.ebuild
+++ b/sci-libs/netcdf/netcdf-4.7.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Scientific library and interface for array oriented data access"
HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
@@ -49,6 +49,11 @@ src_prepare() {
src_configure() {
use mpi && export CC=mpicc
+ # Temporary workaround for test breakage
+ # https://github.com/Unidata/netcdf-c/issues/1983
+ # bug #827042
+ append-flags -fno-strict-aliasing
+
local mycmakeargs=(
-DENABLE_DAP_REMOTE_TESTS=OFF
-DBUILD_UTILITIES=$(usex tools)