summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/rust/rust-1.71.1-r100.ebuild2
-rw-r--r--dev-lang/rust/rust-1.74.1-r100.ebuild2
-rw-r--r--dev-lang/rust/rust-1.75.0-r100.ebuild2
-rw-r--r--dev-lang/rust/rust-1.77.1-r100.ebuild2
-rw-r--r--dev-lang/rust/rust-1.79.0-r100.ebuild2
-rw-r--r--dev-lang/rust/rust-1.80.1-r100.ebuild2
-rw-r--r--dev-lang/rust/rust-1.81.0-r100.ebuild2
-rw-r--r--dev-lang/rust/rust-1.82.0-r100.ebuild2
8 files changed, 8 insertions, 8 deletions
diff --git a/dev-lang/rust/rust-1.71.1-r100.ebuild b/dev-lang/rust/rust-1.71.1-r100.ebuild
index 1e492b6e396d..1dd8144286e1 100644
--- a/dev-lang/rust/rust-1.71.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.71.1-r100.ebuild
@@ -241,7 +241,7 @@ pkg_setup() {
if use system-llvm; then
llvm-r1_pkg_setup
- local llvm_config="$(get_llvm_prefix "${LLVM_SLOT}")/bin/llvm-config"
+ local llvm_config="$(get_llvm_prefix)/bin/llvm-config"
export LLVM_LINK_SHARED=1
export RUSTFLAGS="${RUSTFLAGS} -Lnative=$("${llvm_config}" --libdir)"
fi
diff --git a/dev-lang/rust/rust-1.74.1-r100.ebuild b/dev-lang/rust/rust-1.74.1-r100.ebuild
index 868d55df002d..6ad4459a98cb 100644
--- a/dev-lang/rust/rust-1.74.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.74.1-r100.ebuild
@@ -259,7 +259,7 @@ pkg_setup() {
if use system-llvm; then
llvm-r1_pkg_setup
- local llvm_config="$(get_llvm_prefix "${LLVM_SLOT}")/bin/llvm-config"
+ local llvm_config="$(get_llvm_prefix)/bin/llvm-config"
export LLVM_LINK_SHARED=1
export RUSTFLAGS="${RUSTFLAGS} -Lnative=$("${llvm_config}" --libdir)"
fi
diff --git a/dev-lang/rust/rust-1.75.0-r100.ebuild b/dev-lang/rust/rust-1.75.0-r100.ebuild
index c03951b18f39..0514e26ddc1c 100644
--- a/dev-lang/rust/rust-1.75.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.75.0-r100.ebuild
@@ -262,7 +262,7 @@ pkg_setup() {
if use system-llvm; then
llvm-r1_pkg_setup
- local llvm_config="$(get_llvm_prefix "${LLVM_SLOT}")/bin/llvm-config"
+ local llvm_config="$(get_llvm_prefix)/bin/llvm-config"
export LLVM_LINK_SHARED=1
export RUSTFLAGS="${RUSTFLAGS} -Lnative=$("${llvm_config}" --libdir)"
fi
diff --git a/dev-lang/rust/rust-1.77.1-r100.ebuild b/dev-lang/rust/rust-1.77.1-r100.ebuild
index 46219423ed47..7130cd28295e 100644
--- a/dev-lang/rust/rust-1.77.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.77.1-r100.ebuild
@@ -259,7 +259,7 @@ pkg_setup() {
if use system-llvm; then
llvm-r1_pkg_setup
- local llvm_config="$(get_llvm_prefix "${LLVM_SLOT}")/bin/llvm-config"
+ local llvm_config="$(get_llvm_prefix)/bin/llvm-config"
export LLVM_LINK_SHARED=1
export RUSTFLAGS="${RUSTFLAGS} -Lnative=$("${llvm_config}" --libdir)"
fi
diff --git a/dev-lang/rust/rust-1.79.0-r100.ebuild b/dev-lang/rust/rust-1.79.0-r100.ebuild
index d8b34fc1cad8..69a23d29789d 100644
--- a/dev-lang/rust/rust-1.79.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.79.0-r100.ebuild
@@ -259,7 +259,7 @@ pkg_setup() {
if use system-llvm; then
llvm-r1_pkg_setup
- local llvm_config="$(get_llvm_prefix "${LLVM_SLOT}")/bin/llvm-config"
+ local llvm_config="$(get_llvm_prefix)/bin/llvm-config"
export LLVM_LINK_SHARED=1
export RUSTFLAGS="${RUSTFLAGS} -Lnative=$("${llvm_config}" --libdir)"
fi
diff --git a/dev-lang/rust/rust-1.80.1-r100.ebuild b/dev-lang/rust/rust-1.80.1-r100.ebuild
index 05009a26cac5..929b1bb3f7e6 100644
--- a/dev-lang/rust/rust-1.80.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.80.1-r100.ebuild
@@ -258,7 +258,7 @@ pkg_setup() {
if use system-llvm; then
llvm-r1_pkg_setup
- local llvm_config="$(get_llvm_prefix "${LLVM_SLOT}")/bin/llvm-config"
+ local llvm_config="$(get_llvm_prefix)/bin/llvm-config"
export LLVM_LINK_SHARED=1
export RUSTFLAGS="${RUSTFLAGS} -Lnative=$("${llvm_config}" --libdir)"
fi
diff --git a/dev-lang/rust/rust-1.81.0-r100.ebuild b/dev-lang/rust/rust-1.81.0-r100.ebuild
index eed1ec834afb..9bfbb20a7334 100644
--- a/dev-lang/rust/rust-1.81.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.81.0-r100.ebuild
@@ -261,7 +261,7 @@ pkg_setup() {
if use system-llvm; then
llvm-r1_pkg_setup
- local llvm_config="$(get_llvm_prefix "${LLVM_SLOT}")/bin/llvm-config"
+ local llvm_config="$(get_llvm_prefix)/bin/llvm-config"
export LLVM_LINK_SHARED=1
export RUSTFLAGS="${RUSTFLAGS} -Lnative=$("${llvm_config}" --libdir)"
fi
diff --git a/dev-lang/rust/rust-1.82.0-r100.ebuild b/dev-lang/rust/rust-1.82.0-r100.ebuild
index 84929410da4a..515a57c614b2 100644
--- a/dev-lang/rust/rust-1.82.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.82.0-r100.ebuild
@@ -258,7 +258,7 @@ pkg_setup() {
if use system-llvm; then
llvm-r1_pkg_setup
- local llvm_config="$(get_llvm_prefix "${LLVM_SLOT}")/bin/llvm-config"
+ local llvm_config="$(get_llvm_prefix)/bin/llvm-config"
export LLVM_LINK_SHARED=1
export RUSTFLAGS="${RUSTFLAGS} -Lnative=$("${llvm_config}" --libdir)"
fi