summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/pyzmq-17.1.0.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 82421bd57a3f..3f67bbfe820a 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,3 +1,2 @@
DIST pyzmq-16.0.2.tar.gz 1026531 BLAKE2B b276fea116d56595ff2aca8a00b2b8918c0170cf1522c4bb457f6bb0d44a13e63de18e4d4f53238a1a5b515986e029ffebdded269f191d62eb36d988b328b402 SHA512 40eaf8ce39db86ab3866890d74b92bd6f20d4ae827828a8772003656d899d10ffcfc222d21f344d9daba390824e6c43b9f34e31beb604ec5ee1ec199165f4b96
-DIST pyzmq-17.1.0.tar.gz 1082716 BLAKE2B eed059cad8cc37e9315d16a43768f531ada1274b46bdf91d2ebe83cd0b4c269ea99a8532e3db6d0ea68be31600cf7d29ea4c4e894aa6d04c61534b11fb816d54 SHA512 7f1975c4d02e7d47577049da8df84753905d01672d5a244cef2e5b05e0b6fdb22e88cbb36f2e59831e95a8224819183d9a82baf1f9d7f599da61bcbfe2fc23d3
DIST pyzmq-19.0.0.tar.gz 1150320 BLAKE2B a2af57b1cb809ab72aff1bbee17a7fff5eeeff90805884542579c7cb58c235f8b257a8724c64f55cc8e8eda4a943ec2f54490d546a74bc1532557c46b420e6d2 SHA512 06a395fee62c78f806c43b07362fe2d4b7ac05813d75d4b983f8eefffbe0ca36f64db1591ead719b2866fcfe0867c919033eca0063ca32529e649cd9790461b1
diff --git a/dev-python/pyzmq/pyzmq-17.1.0.ebuild b/dev-python/pyzmq/pyzmq-17.1.0.ebuild
deleted file mode 100644
index 1e918eb84bc5..000000000000
--- a/dev-python/pyzmq/pyzmq-17.1.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit flag-o-matic distutils-r1 toolchain-funcs
-
-DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="https://www.zeromq.org/bindings:python https://pypi.org/project/pyzmq/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=net-libs/zeromq-4.2.2-r2:=[drafts]
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/cffi:=[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/sphinx-1.3[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- )"
-
-PATCHES=( "${FILESDIR}"/${P}-test_message.patch )
-
-python_prepare_all() {
- # Prevent un-needed download during build
- sed -e "/'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- tc-export CC
- append-cppflags -DZMQ_BUILD_DRAFT_API=1
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_compile() {
- esetup.py cython --force
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- ${EPYTHON} -m pytest -v "${BUILD_DIR}/lib" || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}