summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild9
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9999.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild b/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
index 9b135a41b328..d60c84ee2d67 100644
--- a/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -77,6 +77,13 @@ src_configure() {
-DCOMPILER_RT_BUILD_XRAY=OFF
)
+ if use prefix && [[ "${CHOST}" == *-darwin* ]] ; then
+ mycmakeargs+=(
+ # disable use of SDK for the system itself
+ -DDARWIN_macosx_CACHED_SYSROOT=/
+ )
+ fi
+
if use test; then
mycmakeargs+=(
-DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
diff --git a/sys-libs/compiler-rt/compiler-rt-9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
index 4dd44182ae9b..7c6eb6db761e 100644
--- a/sys-libs/compiler-rt/compiler-rt-9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -81,6 +81,13 @@ src_configure() {
-DCOMPILER_RT_BUILD_XRAY=OFF
)
+ if use prefix && [[ "${CHOST}" == *-darwin* ]] ; then
+ mycmakeargs+=(
+ # disable use of SDK for the system itself
+ -DDARWIN_macosx_CACHED_SYSROOT=/
+ )
+ fi
+
if use test; then
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"