summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/watchgod/Manifest1
-rw-r--r--dev-python/watchgod/metadata.xml11
-rw-r--r--dev-python/watchgod/watchgod-0.8.2-r1.ebuild59
-rw-r--r--profiles/features/wd40/package.mask1
4 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/watchgod/Manifest b/dev-python/watchgod/Manifest
deleted file mode 100644
index 5d3210f07978..000000000000
--- a/dev-python/watchgod/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST watchfiles-0.8.2.gh.tar.gz 15515 BLAKE2B 97c17737c6970c8b799707547cef760c307cd000d09cf3a338e47c0735d537e0321643066eab592f7f7e6ccc25272ea1e7e0bbc02f6274864f7cc39a177b83ba SHA512 a44b831352ace03c450781bc815b1813c44c386d666a9b724b562ff69228705651bfc23e81b7344d0f79c62577d4f910b323c734298e2a609f85bbc4a0f0498e
diff --git a/dev-python/watchgod/metadata.xml b/dev-python/watchgod/metadata.xml
deleted file mode 100644
index f8df5d7b0948..000000000000
--- a/dev-python/watchgod/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="github">samuelcolvin/watchfiles</remote-id>
- <remote-id type="pypi">watchgod</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/watchgod/watchgod-0.8.2-r1.ebuild b/dev-python/watchgod/watchgod-0.8.2-r1.ebuild
deleted file mode 100644
index a19fe1d0b4f5..000000000000
--- a/dev-python/watchgod/watchgod-0.8.2-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=watchfiles-${PV}
-DESCRIPTION="Simple, modern file watching and code reload in Python"
-HOMEPAGE="
- https://pypi.org/project/watchgod/
- https://github.com/samuelcolvin/watchfiles/
-"
-SRC_URI="
- https://github.com/samuelcolvin/watchfiles/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- =dev-python/anyio-3*[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-toolbox[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # increase timeout
- sed -i -e '/sleep/s/0.01/1.0/' tests/test_watch.py || die
- # fix version number in metadata
- sed -i -e "s:0\.0\.dev0:${PV}:" watchgod/version.py || die
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # flaky test on slow systems, https://github.com/samuelcolvin/watchgod/issues/84
- tests/test_watch.py::test_awatch_log
- )
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- tests/test_watch.py::test_does_not_exist
- )
- epytest
-}
diff --git a/profiles/features/wd40/package.mask b/profiles/features/wd40/package.mask
index 6e9cb209a80f..025e4b1885c5 100644
--- a/profiles/features/wd40/package.mask
+++ b/profiles/features/wd40/package.mask
@@ -57,7 +57,6 @@ dev-python/trustme
dev-python/trio
dev-python/twine
dev-python/watchfiles
-dev-python/watchgod
dev-ros/roswtf
dev-util/cargo-c
dev-util/cbindgen