summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmlpq
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmlpq')
-rw-r--r--x11-plugins/wmlpq/Manifest1
-rw-r--r--x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch30
-rw-r--r--x11-plugins/wmlpq/files/wmlpq-makefile.patch30
-rw-r--r--x11-plugins/wmlpq/files/wmlpq.desktop8
-rw-r--r--x11-plugins/wmlpq/metadata.xml5
-rw-r--r--x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild37
-rw-r--r--x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild43
7 files changed, 154 insertions, 0 deletions
diff --git a/x11-plugins/wmlpq/Manifest b/x11-plugins/wmlpq/Manifest
new file mode 100644
index 000000000000..0a81bce5f30e
--- /dev/null
+++ b/x11-plugins/wmlpq/Manifest
@@ -0,0 +1 @@
+DIST wmlpq_0.2.1.tar.gz 15180 SHA256 6dba6ed7b61baa6060f4646a230477970dec2fd06d01dab7dbdf064bed348e83
diff --git a/x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch b/x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch
new file mode 100644
index 000000000000..308e7f4e687e
--- /dev/null
+++ b/x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch
@@ -0,0 +1,30 @@
+--- /Makefile.orig 2009-01-16 17:01:47.000000000 +0100
++++ /Makefile 2009-01-16 17:04:18.000000000 +0100
+@@ -2,11 +2,11 @@
+ CPPFLAGS = -I/usr/X11R6/include -I/usr/local/include
+ LIBS = -lXpm -lX11 -ldockapp
+ LDFLAGS = -L/usr/X11R6/lib -L/usr/local/lib
+-CFLAGS = -O2 -Wall
++CFLAGS = -Wall
+ DFLAGS = -ggdb3 -Wall
++DESTDIR = /usr/bin/
+
+ wmlpq: wmlpq.c wmlpq-master.xpm
+- cc $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) -o wmlpq $(LIBS) wmlpq.c
++ $(CC) $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) wmlpq.c -o wmlpq $(LIBS)
+- strip wmlpq
+
+ debug: wmlpq.c wmlpq-master.xpm
+@@ -18,10 +19,8 @@
+ rm -f wmlpq
+
+ install: wmlpq
+- cp -f wmlpq /usr/local/bin/
+- chmod 755 /usr/local/bin/wmlpq
+- cp -f wmlpq.1x /usr/local/man/man1/
+- chmod 644 /usr/local/man/man1/wmlpq.1x
++ cp -f wmlpq ${DESTDIR}
++ chmod 755 ${DESTDIR}/wmlpq
+
+ install-debian: wmlpq
+ cp -f wmlpq $(prefix)/usr/X11R6/bin/
diff --git a/x11-plugins/wmlpq/files/wmlpq-makefile.patch b/x11-plugins/wmlpq/files/wmlpq-makefile.patch
new file mode 100644
index 000000000000..4dc00bd97cdb
--- /dev/null
+++ b/x11-plugins/wmlpq/files/wmlpq-makefile.patch
@@ -0,0 +1,30 @@
+--- /Makefile.orig 2009-01-16 17:01:47.000000000 +0100
++++ /Makefile 2009-01-16 17:04:18.000000000 +0100
+@@ -2,11 +2,11 @@
+ CPPFLAGS = -I/usr/X11R6/include -I/usr/local/include
+ LIBS = -lXpm -lX11 -ldockapp
+ LDFLAGS = -L/usr/X11R6/lib -L/usr/local/lib
+-CFLAGS = -O2 -Wall
++CFLAGS = -Wall
+ DFLAGS = -ggdb3 -Wall
++DESTDIR = /usr/bin/
+
+ wmlpq: wmlpq.c wmlpq-master.xpm
+- cc $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) -o wmlpq $(LIBS) wmlpq.c
++ cc $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) wmlpq.c -o wmlpq $(LIBS)
+- strip wmlpq
+
+ debug: wmlpq.c wmlpq-master.xpm
+@@ -18,10 +19,8 @@
+ rm -f wmlpq
+
+ install: wmlpq
+- cp -f wmlpq /usr/local/bin/
+- chmod 755 /usr/local/bin/wmlpq
+- cp -f wmlpq.1x /usr/local/man/man1/
+- chmod 644 /usr/local/man/man1/wmlpq.1x
++ cp -f wmlpq ${DESTDIR}
++ chmod 755 ${DESTDIR}/wmlpq
+
+ install-debian: wmlpq
+ cp -f wmlpq $(prefix)/usr/X11R6/bin/
diff --git a/x11-plugins/wmlpq/files/wmlpq.desktop b/x11-plugins/wmlpq/files/wmlpq.desktop
new file mode 100644
index 000000000000..3939b0c85aa0
--- /dev/null
+++ b/x11-plugins/wmlpq/files/wmlpq.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=WmLpq
+Comment=Printqueues monitor
+Comment[pl]=Monitor kolejki drukarek
+Exec=wmlpq
+Type=Application
+Terminal=false
+Categories=System;
diff --git a/x11-plugins/wmlpq/metadata.xml b/x11-plugins/wmlpq/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmlpq/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild b/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..c081a49b95d2
--- /dev/null
+++ b/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Windowmaker dockapp which monitors up to 5 printqueues"
+SRC_URI="http://www.ur.uklinux.net/wmlpq/dl/wmlpq_0.2.1.tar.gz"
+HOMEPAGE="http://www.ur.uklinux.net/wmlpq/"
+
+DEPEND="x11-libs/libdockapp"
+
+RDEPEND=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+src_unpack()
+{
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+}
+
+src_install()
+{
+ dodir /usr/bin/
+ einstall DESTDIR="${D}/usr/bin/" CFLAGS="${CFLAGS} -Wall" || die "Installation failed"
+
+ dodoc README sample.wmlpqrc
+ newman wmlpq.1x wmlpq.1
+
+ domenu "${FILESDIR}/${PN}.desktop"
+}
diff --git a/x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild b/x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..25aba7a574f8
--- /dev/null
+++ b/x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic toolchain-funcs
+
+IUSE=""
+
+DESCRIPTION="Windowmaker dockapp which monitors up to 5 printqueues"
+SRC_URI="http://www.ur.uklinux.net/wmlpq/dl/wmlpq_0.2.1.tar.gz"
+HOMEPAGE="http://www.ur.uklinux.net/wmlpq/"
+
+DEPEND="x11-libs/libdockapp"
+
+RDEPEND=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86"
+
+src_unpack()
+{
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-makefile-ldflags.patch"
+}
+
+src_compile()
+{
+ append-ldflags "-L/usr/X11R6/lib -L/usr/local/lib"
+ emake CC=$(tc-getCC) LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install()
+{
+ dodir /usr/bin || die
+ emake DESTDIR="${D}/usr/bin" install || die "Installation failed"
+
+ dodoc README sample.wmlpqrc || die
+ newman wmlpq.1x wmlpq.1 || die
+
+ domenu "${FILESDIR}/${PN}.desktop" || die
+}