summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-01-28 23:53:22 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2022-01-28 23:53:22 +0100
commitd9b4c977f636cbce4577413e2bc7390154852139 (patch)
tree0878ce7ef300a40e0f1b8971de54dce7ea066646 /x11-misc
parentx11-misc/picom: drop old (diff)
downloadgentoo-d9b4c977f636cbce4577413e2bc7390154852139.tar.gz
gentoo-d9b4c977f636cbce4577413e2bc7390154852139.tar.bz2
gentoo-d9b4c977f636cbce4577413e2bc7390154852139.zip
x11-misc/picom: update python versions
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/picom/picom-8.2-r3.ebuild68
-rw-r--r--x11-misc/picom/picom-9999.ebuild8
2 files changed, 72 insertions, 4 deletions
diff --git a/x11-misc/picom/picom-8.2-r3.ebuild b/x11-misc/picom/picom-8.2-r3.ebuild
new file mode 100644
index 000000000000..c26adc87f474
--- /dev/null
+++ b/x11-misc/picom/picom-8.2-r3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1 virtualx xdg
+
+DESCRIPTION="A lightweight compositor for X11 (previously a compton fork)"
+HOMEPAGE="https://github.com/yshui/picom"
+SRC_URI="https://github.com/yshui/picom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+config-file dbus +doc +drm opengl pcre test"
+
+REQUIRED_USE="test? ( dbus )" # avoid "DBus support not compiled in!"
+RESTRICT="test" # but tests require dbus_next
+
+RDEPEND="dev-libs/libev
+ dev-libs/uthash
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXext
+ x11-libs/pixman
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-renderutil
+ config-file? (
+ dev-libs/libconfig:=
+ )
+ dbus? ( sys-apps/dbus )
+ drm? ( x11-libs/libdrm )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre )
+ !x11-misc/compton"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-text/asciidoc )
+ test? ( $(python_gen_any_dep 'dev-python/xcffib[${PYTHON_USEDEP}]') )
+"
+
+DOCS=( README.md picom.sample.conf )
+
+python_check_deps() {
+ has_version -b "dev-python/xcffib[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use config-file config_file)
+ $(meson_use dbus)
+ $(meson_use doc with_docs)
+ $(meson_use opengl)
+ $(meson_use pcre regex)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ virtx "${S}/tests/run_tests.sh" "${BUILD_DIR}/src/${PN}"
+}
diff --git a/x11-misc/picom/picom-9999.ebuild b/x11-misc/picom/picom-9999.ebuild
index 7551a069f44f..3e335b945325 100644
--- a/x11-misc/picom/picom-9999.ebuild
+++ b/x11-misc/picom/picom-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit git-r3 python-any-r1 meson virtualx xdg
+PYTHON_COMPAT=( python3_{8..10} )
+inherit git-r3 meson python-any-r1 virtualx xdg
DESCRIPTION="A lightweight compositor for X11 (previously a compton fork)"
HOMEPAGE="https://github.com/yshui/picom"