summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2023-06-26 14:47:04 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-06-26 14:48:31 -0700
commit53366135da68474145082a890652a35da9890206 (patch)
treef738b374db6b365b563a97f09e3fa8854e25d7c0 /www-client/firefox
parentdev-java/openjdk: add 17.0.7_p7 (diff)
downloadgentoo-53366135da68474145082a890652a35da9890206.tar.gz
gentoo-53366135da68474145082a890652a35da9890206.tar.bz2
gentoo-53366135da68474145082a890652a35da9890206.zip
www-client/firefox: fix linking of 114 on ppc64
Patch-source: https://phabricator.services.mozilla.com/D181042 Bug: https://bugs.gentoo.org/908297 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/files/firefox-114-ppc64-profiler.patch29
-rw-r--r--www-client/firefox/firefox-114.0.ebuild5
2 files changed, 33 insertions, 1 deletions
diff --git a/www-client/firefox/files/firefox-114-ppc64-profiler.patch b/www-client/firefox/files/firefox-114-ppc64-profiler.patch
new file mode 100644
index 000000000000..5a2bfa4e3bd5
--- /dev/null
+++ b/www-client/firefox/files/firefox-114-ppc64-profiler.patch
@@ -0,0 +1,29 @@
+#from: https://phabricator.services.mozilla.com/D181042
+
+diff --git a/tools/profiler/gecko/ProfilerParent.cpp b/tools/profiler/gecko/ProfilerParent.cpp
+--- a/tools/profiler/gecko/ProfilerParent.cpp
++++ b/tools/profiler/gecko/ProfilerParent.cpp
+@@ -722,18 +722,22 @@
+ }
+ }
+
+ Unused << SendStop();
+ }
++#endif // MOZ_GECKO_PROFILER
+
+ ProfilerParent::~ProfilerParent() {
+ MOZ_COUNT_DTOR(ProfilerParent);
+
+ MOZ_RELEASE_ASSERT(NS_IsMainThread());
++#ifdef MOZ_GECKO_PROFILER
+ ProfilerParentTracker::StopTracking(this);
++#endif
+ }
+
++#ifdef MOZ_GECKO_PROFILER
+ /* static */
+ nsTArray<ProfilerParent::SingleProcessProfilePromiseAndChildPid>
+ ProfilerParent::GatherProfiles() {
+ nsTArray<SingleProcessProfilePromiseAndChildPid> results;
+ if (!NS_IsMainThread()) {
+
diff --git a/www-client/firefox/firefox-114.0.ebuild b/www-client/firefox/firefox-114.0.ebuild
index 9e1a2f0ae932..915a32ecc24d 100644
--- a/www-client/firefox/firefox-114.0.ebuild
+++ b/www-client/firefox/firefox-114.0.ebuild
@@ -651,7 +651,10 @@ src_prepare() {
# temp workaround for https://bugs.gentoo.org/908297 until patch added to tarball
rm -v "${WORKDIR}"/firefox-patches/*bmo-1775202-ppc64*.patch
- use ppc64 && eapply "${FILESDIR}"/firefox-114-ppc64-webrtc.patch
+ if use ppc64; then
+ eapply "${FILESDIR}"/firefox-114-ppc64-webrtc.patch
+ eapply "${FILESDIR}"/firefox-114-ppc64-profiler.patch
+ fi
# end temp workaround
eapply "${WORKDIR}/firefox-patches"