summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-02-12 14:29:18 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-02-12 14:29:18 +0200
commit2a83c2d5033665a4974b398874f16bfa3dbae8ca (patch)
treed368227cd67975eb2c6f9f8cf7e9e633a792f01a /www-apps
parentwww-apps/dokuwiki: add 20240206a (diff)
downloadgentoo-2a83c2d5033665a4974b398874f16bfa3dbae8ca.tar.gz
gentoo-2a83c2d5033665a4974b398874f16bfa3dbae8ca.tar.bz2
gentoo-2a83c2d5033665a4974b398874f16bfa3dbae8ca.zip
www-apps/dokuwiki: drop 20240206
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/dokuwiki/Manifest1
-rw-r--r--www-apps/dokuwiki/dokuwiki-20240206.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/www-apps/dokuwiki/Manifest b/www-apps/dokuwiki/Manifest
index 1bc52d491e88..d8f9e704ea1a 100644
--- a/www-apps/dokuwiki/Manifest
+++ b/www-apps/dokuwiki/Manifest
@@ -1,3 +1,2 @@
DIST dokuwiki-2023-04-04a.tgz 4043928 BLAKE2B a18372b04bd10760236ec4f976a87fed800601a541ebb6aaa07b302c8462286da3094aa102194a101c59ceacde99d0c865f938b8eb732cf09e8e7f0b5f40ea8e SHA512 748af27b2d226437f87461522254fca5e65c7572fdc20e75259944b388e3888a85f61120d1c22c671d3a302ac6791e463a0d3418f2fcf23bf046116107b11ab8
-DIST dokuwiki-2024-02-06.tgz 4191147 BLAKE2B fc379c06b31ce8a6ac307743a096728c39dc2098dbb787af7d21e673e8e9f34e8bf7a1e0d7c4c875bd8c80fded2603f32ef8c0a78beee12efcbffc5faa1eb823 SHA512 8584712371ab3901e7dc0e8c039004b6fbe1698db0431108a4683d3b90ba64ba920d386426bcaaea5a2576742f831b4e708b63e5f8cb2c26c827ab84adb54db9
DIST dokuwiki-2024-02-06a.tgz 4201385 BLAKE2B 3e4541f7e13e400e791af57a3caf7274b5ec7f4608396f7ff91c60f2991f7aea0db2b142a7425d1057a9fb2297200b8b85cbe55af592105927f333dfa228ba44 SHA512 280e450f47237f834256a3a6cd81efe74c82b24b06033d09485bba640d4fd5de72d4fa62129323a6a5f37796357cbe8d3dd1f31b658ca85819e4c9fc47665e2c
diff --git a/www-apps/dokuwiki/dokuwiki-20240206.ebuild b/www-apps/dokuwiki/dokuwiki-20240206.ebuild
deleted file mode 100644
index 80ace2977efa..000000000000
--- a/www-apps/dokuwiki/dokuwiki-20240206.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit webapp
-
-# upstream uses dashes in the datestamp
-MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-
-if [[ ${PV} == *rc* ]]; then
- MY_PV="${MY_BASE_PV}${PV:8:4}"
- MY_P="${PN}-rc-${MY_BASE_PV}"
- S="${WORKDIR}/${MY_P}"
- SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-rc.tgz -> ${PN}-${PV}.tgz"
-else
- MY_PV="${MY_BASE_PV}${PV:8:4}"
- SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs"
-HOMEPAGE="https://wiki.dokuwiki.org"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~sparc ~x86"
-IUSE="gd"
-
-RDEPEND="
- >=dev-lang/php-8.0[xml]
- virtual/httpd-php:*
- gd? ( ||
- (
- dev-lang/php[gd]
- media-gfx/imagemagick
- )
- )
-"
-
-need_httpd_cgi
-
-src_prepare() {
- # create initial changes file
- touch data/changes.log
-
- default
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc README
- rm -f README COPYING
-
- docinto scripts
- dodoc bin/*
- rm -rf bin
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- # Copy custom .htaccess that works with both apache 2.2 and 2.4
- for dir in "conf" "data" "inc" "inc/lang"; do
- insinto "${MY_HTDOCSDIR}/${dir}"
- newins "${FILESDIR}/htaccess" ".htaccess"
- done
-
- # Use custom .htaccess.dist that works with both apache 2.2 and 2.4
- insinto "${MY_HTDOCSDIR}/"
- newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
-
- for x in $(find data/ -not -name '.htaccess'); do
- webapp_serverowned "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
- webapp_configfile "${MY_HTDOCSDIR}"/conf
-
- for x in $(find conf/ -not -name 'msg'); do
- webapp_configfile "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_src_install
-}