summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-04-04 10:55:33 -0400
committerMike Gilbert <floppym@gentoo.org>2024-04-04 10:55:33 -0400
commite04245bf04088e9f3e035496d648141313e5a57b (patch)
tree42c76c95b9001f2086374227de66a54e8ba294cd /sys-process/procps
parentapp-portage/command-not-found: add 0.0.5 (diff)
downloadgentoo-e04245bf04088e9f3e035496d648141313e5a57b.tar.gz
gentoo-e04245bf04088e9f3e035496d648141313e5a57b.tar.bz2
gentoo-e04245bf04088e9f3e035496d648141313e5a57b.zip
sys-process/procps: drop REQUIRED_USE="unicode? ( ncurses )"
Instead, ignore the 'unicode' flag when 'ncurses' is disabled. This option only affects the 'watch' command, which is only built with ncurses support. Closes: https://bugs.gentoo.org/928534 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-process/procps')
-rw-r--r--sys-process/procps/procps-4.0.4-r1.ebuild7
-rw-r--r--sys-process/procps/procps-4.0.4.ebuild9
2 files changed, 11 insertions, 5 deletions
diff --git a/sys-process/procps/procps-4.0.4-r1.ebuild b/sys-process/procps/procps-4.0.4-r1.ebuild
index f522ae5f965a..0534445b36e9 100644
--- a/sys-process/procps/procps-4.0.4-r1.ebuild
+++ b/sys-process/procps/procps-4.0.4-r1.ebuild
@@ -17,7 +17,6 @@ LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+"
SLOT="0/0-ng"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="elogind +kill modern-top +ncurses nls selinux static-libs systemd test unicode"
-REQUIRED_USE="unicode? ( ncurses )"
RESTRICT="!test? ( test )"
DEPEND="
@@ -74,13 +73,17 @@ multilib_src_configure() {
$(multilib_native_use_with ncurses)
# bug #794997
$(multilib_native_use_enable !elibc_musl w)
- $(multilib_native_use_enable unicode watch8bit)
$(use_enable nls)
$(use_enable selinux libselinux)
$(use_enable static-libs static)
$(use_with systemd)
)
+ if use ncurses; then
+ # Only pass whis when we are building the 'watch' command
+ myeconfargs+=( $(multilib_native_use_enable unicode watch8bit) )
+ fi
+
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
diff --git a/sys-process/procps/procps-4.0.4.ebuild b/sys-process/procps/procps-4.0.4.ebuild
index 2ddcefdad321..4e85c2be48ab 100644
--- a/sys-process/procps/procps-4.0.4.ebuild
+++ b/sys-process/procps/procps-4.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,7 +17,6 @@ LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+"
SLOT="0/0-ng"
KEYWORDS="~alpha ~amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ~ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="elogind +kill modern-top +ncurses nls selinux static-libs systemd test unicode"
-REQUIRED_USE="unicode? ( ncurses )"
RESTRICT="!test? ( test )"
DEPEND="
@@ -74,13 +73,17 @@ multilib_src_configure() {
$(multilib_native_use_with ncurses)
# bug #794997
$(multilib_native_use_enable !elibc_musl w)
- $(multilib_native_use_enable unicode watch8bit)
$(use_enable nls)
$(use_enable selinux libselinux)
$(use_enable static-libs static)
$(use_with systemd)
)
+ if use ncurses; then
+ # Only pass whis when we are building the 'watch' command
+ myeconfargs+=( $(multilib_native_use_enable unicode watch8bit) )
+ fi
+
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}