summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-29 02:59:47 +0100
committerSam James <sam@gentoo.org>2022-03-29 03:00:40 +0100
commitcd0a0f16ebdc4cf2d18378213d8476aeb42ff810 (patch)
tree31034dcb4b91ce43161b0f45c6fee7edadb56709 /sys-libs/zlib
parentsys-block/gparted: Version bump to 1.4.0 (diff)
downloadgentoo-cd0a0f16ebdc4cf2d18378213d8476aeb42ff810.tar.gz
gentoo-cd0a0f16ebdc4cf2d18378213d8476aeb42ff810.tar.bz2
gentoo-cd0a0f16ebdc4cf2d18378213d8476aeb42ff810.zip
sys-libs/zlib: keyword 1.2.12-r1
Issues are fixed now. Nothing else has come up other than the now-fixed CC-configure issue. Bug: https://bugs.gentoo.org/835958 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/zlib')
-rw-r--r--sys-libs/zlib/files/zlib-1.2.12-fix-CC-logic-in-configure.patch6
-rw-r--r--sys-libs/zlib/zlib-1.2.12-r1.ebuild2
2 files changed, 5 insertions, 3 deletions
diff --git a/sys-libs/zlib/files/zlib-1.2.12-fix-CC-logic-in-configure.patch b/sys-libs/zlib/files/zlib-1.2.12-fix-CC-logic-in-configure.patch
index 8b6c5e26a766..7fb13325b114 100644
--- a/sys-libs/zlib/files/zlib-1.2.12-fix-CC-logic-in-configure.patch
+++ b/sys-libs/zlib/files/zlib-1.2.12-fix-CC-logic-in-configure.patch
@@ -1,6 +1,6 @@
https://github.com/madler/zlib/pull/607
-From c9b7587ff947638412a69df5ea820c563b8b1c1b Mon Sep 17 00:00:00 2001
+From 80d086357a55b94a13e43756cf3e131f25eef0e4 Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Mon, 28 Mar 2022 08:40:45 +0100
Subject: [PATCH] Fix CC logic in configure
@@ -10,6 +10,9 @@ the logic was changed to try check harder for GCC, but it dropped
the default setting of cc=${CC}. It was throwing away any pre-set CC value as
a result.
+The rest of the script then cascades down a bad path because it's convinced
+it's not GCC or a GCC-like compiler.
+
This led to e.g. misdetection of inability to build shared libs
for say, multilib cases (w/ CC being one thing from the environment being used
for one test (e.g. x86_64-unknown-linux-gnu-gcc -m32 and then 'cc' used for
@@ -40,4 +43,3 @@ index 52ff4a04e..3fa3e8618 100755
cflags=${CFLAGS-"-O3"}
# to force the asm version use: CFLAGS="-O3 -DASMV" ./configure
case "$cc" in
-
diff --git a/sys-libs/zlib/zlib-1.2.12-r1.ebuild b/sys-libs/zlib/zlib-1.2.12-r1.ebuild
index 1a031b3c2526..267b24c0d148 100644
--- a/sys-libs/zlib/zlib-1.2.12-r1.ebuild
+++ b/sys-libs/zlib/zlib-1.2.12-r1.ebuild
@@ -22,7 +22,7 @@ SRC_URI="https://zlib.net/${P}.tar.gz
LICENSE="ZLIB"
SLOT="0/1" # subslot = SONAME
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
IUSE="minizip static-libs"
RDEPEND="!sys-libs/zlib-ng[compat]"