summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-08-22 17:42:32 -0400
committerMike Pagano <mpagano@gentoo.org>2021-08-22 17:42:39 -0400
commit03492fa7bd267b5f54f0ae4d4f4d2bf47414ed3b (patch)
treeed1403855e61d2d6c55302ec76481261ce33d614 /sys-kernel
parentdev-python/pydyf: Bump to 0.1.1 (diff)
downloadgentoo-03492fa7bd267b5f54f0ae4d4f4d2bf47414ed3b.tar.gz
gentoo-03492fa7bd267b5f54f0ae4d4f4d2bf47414ed3b.tar.bz2
gentoo-03492fa7bd267b5f54f0ae4d4f4d2bf47414ed3b.zip
sys-kernel/git-sources: Linux patch 5.14-rc7
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.14_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 80bd4cfc7439..09a4516b00a3 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-5.14-rc3.patch 69715862 BLAKE2B bf826bfaf1968b2da2f074bb16ac82237c41d
DIST patch-5.14-rc4.patch 69955713 BLAKE2B b4e3051cbba62cf937072205c29116362578be25dec7d5b25d020ffb4e634855be2771c152a36b1d40249692aceed0e70edc25479aad1ac99399dbec878fd97b SHA512 0d62ef70193c4bcb2b13637878e5c6d163d59cdcf00ec1447fe356e86853735e460706aba783a1942de0f32dc5b3fc8d95a012ff6cdcb6ab0d398556a2aa3bf4
DIST patch-5.14-rc5.patch 70193505 BLAKE2B 3439ab433227c4daca6b4c8dc4f357fce38689f6af669554559294bba3491566ae1bdd4c703bafb96c84f5a2028926b35f253c4f379dff37d9899a0436e0424d SHA512 1752aa29cefbce5baa3e89307c0b87d09a0db29330dab58ad33e9866bc31e2378a9a6cdcb0fd4b05b9794f934c30353a558420527d853907266f8bfb535f30a5
DIST patch-5.14-rc6.patch 70415935 BLAKE2B d1c1777b24e3a99b8acf7a79d5490e5f5222e77ea9bba525677fdeac22f5143d45f8cc04b78f6f800c924a39965e21871dd9a7b3d8cbc36331bcc914f5b8f9d2 SHA512 4f4544b2dda82e1b556bf1c24de27965eba9ec6875ff4950b87775cafa893cb629c5e25603be78d36426c2f35838d4be60c4ff72fe8664eb0f8dfce8a6cceee1
+DIST patch-5.14-rc7.patch 70593573 BLAKE2B 47396856eb7ed4f8fff1341d8280124a0211a2fb6192e60dd5f735827a0b3e4468beef187e74c45b1701254da3b7d3a24b82a1f371b95fbb523ed62f307c448a SHA512 c9c7d7135fbe704c5cf7c08fcceb4097f910c82f6f1c64b174640e4ebf9a325539186148652c8d9014814364b72f1ce25170816858119413ffc795dbcbd4bb3e
diff --git a/sys-kernel/git-sources/git-sources-5.14_rc7.ebuild b/sys-kernel/git-sources/git-sources-5.14_rc7.ebuild
new file mode 100644
index 000000000000..d43c5c0ce00d
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.14_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.13"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}