summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-23 02:37:51 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-23 02:37:51 -0400
commit4b85d444031fb78c616869408835939b273a11b2 (patch)
treecc2da6233560a48441def9d2c891ba69368d6d60 /sys-fs/hfsplusutils
parentsys-fs/hfsplusutils: update to EAPI=5 (diff)
downloadgentoo-4b85d444031fb78c616869408835939b273a11b2.tar.gz
gentoo-4b85d444031fb78c616869408835939b273a11b2.tar.bz2
gentoo-4b85d444031fb78c616869408835939b273a11b2.zip
sys-fs/hfsplusutils: clean up more missing header warnings
Diffstat (limited to 'sys-fs/hfsplusutils')
-rw-r--r--sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-stdlib.patch22
-rw-r--r--sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-string.patch26
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild1
3 files changed, 47 insertions, 2 deletions
diff --git a/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-stdlib.patch b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-stdlib.patch
new file mode 100644
index 000000000000..211a50225eb8
--- /dev/null
+++ b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-stdlib.patch
@@ -0,0 +1,22 @@
+needed for exit() prototype
+
+--- a/libhfsp/src/os.c
++++ b/libhfsp/src/os.c
+@@ -46,6 +46,7 @@ int fstat(int, struct stat *);
+ # endif
+
+ # include <stdio.h>
++# include <stdlib.h>
+
+
+ # include <errno.h>
+--- a/libhfsp/src/record.c
++++ b/libhfsp/src/record.c
+@@ -32,6 +32,7 @@
+ #include <errno.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ #include "libhfsp.h"
+ #include "hfstime.h"
diff --git a/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-string.patch b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-string.patch
index 2602876a1127..37abcbd31899 100644
--- a/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-string.patch
+++ b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-string.patch
@@ -1,5 +1,7 @@
---- libhfsp/src/unicode.c.bak 2007-01-08 17:14:44.000000000 -0500
-+++ libhfsp/src/unicode.c 2007-01-08 17:14:52.000000000 -0500
+needed for mem* funcs
+
+--- a/libhfsp/src/unicode.c
++++ b/libhfsp/src/unicode.c
@@ -16,7 +16,7 @@
#include <stdlib.h>
#include <endian.h>
@@ -9,3 +11,23 @@
#define __USE_GNU
/* need wcsrtomb */
+--- a/libhfsp/src/partitions.c
++++ b/libhfsp/src/partitions.c
+@@ -31,6 +31,7 @@
+ #include "os.h"
+ #include "libhfsp.h"
+
++#include <string.h>
+ #include <stdlib.h>
+
+ /*
+--- a/libhfsp/src/record.c
++++ b/libhfsp/src/record.c
+@@ -32,6 +32,7 @@
+
+ #include <errno.h>
+ #include <stdio.h>
++#include <string.h>
+
+ #include "libhfsp.h"
+ #include "hfstime.h"
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
index e11b12018484..380d9b293094 100644
--- a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
@@ -25,6 +25,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-errno.patch"
epatch "${FILESDIR}/${P}-gcc4.patch"
epatch "${FILESDIR}/${P}-string.patch"
+ epatch "${FILESDIR}/${P}-stdlib.patch"
# let's avoid the Makefile.cvs since isn't working for us
eautoreconf
}